No monitor signal in full screen games

Hi All.

I have a problem with games on my system:

> cat /etc/SuSE-release
openSUSE 11.4 (i586)
VERSION = 11.4
CODENAME = Celadon

When I run any game in full screen mode I see only black screen and then ‘No signal’ on the display.
If I run game in window mode the picture is visualized successfully but great delay makes game impossible to play.
Have you any suggestions?

Here is my xorg.conf file:

> cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 270.41.06  (abuild@Patchouli)  Mon Apr 23 17:19:03 UTC 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.40  (  Thu Apr  5 22:33:07 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics M208WA"
    HorizSync       28.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6150SE nForce 430"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option	"Composite"	"Disable"

Installed NVIDIA packages:

> zypper se nvidia | grep "i |"
i | nvidia-computeG02         | NVIDIA driver for computing with GPGPU                               | package   
i | nvidia-gfxG02-kmp-desktop | NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs | package   
i | nvidia-settings           | Configuration Tool for nVidia GPUs                                   | package   
i | x11-video-nvidiaG02       | NVIDIA graphics driver for GeForce 6xxx and newer GPUs               | package  

Driver information:

> zypper if x11-video-nvidiaG02
Loading repository data...
Reading installed packages...

Information for package x11-video-nvidiaG02:

Repository: @System
Name: x11-video-nvidiaG02
Version: 295.40-15.1
Arch: i586
Vendor: obs://
Installed: Yes
Status: up-to-date
Installed Size: 75.0 MiB
Summary: NVIDIA graphics driver for GeForce 6xxx and newer GPUs
NVIDIA graphics driver for GeForce 6xxx and newer GPUs

Your gpu is a bit old, it could perhaps just be that it isn’t fast enough for the game. Regarding the black screen, try change the resolution before going full-screen.

Oh, are you kidding? I try to play the game Professor Fizzwizzle with requirements:
CPU AMD Athlon 600 MHz + / Pentium III 600 MHz; RAM 64 Mb; 22 Mb free space; 32 Мb nVidia GeForce 3 MX/ATI Radeon 7xxx; OpenGL 1.1

With resolution 800x600 I see the picture in full screen mode. Thanks.
But how can I know what resolution is suitable?

And question regarding big delay is still opened.

From what I have seen in other threads (sorry no link at hand now), you
ran into the trouble that the combination of your driver version 295.40
and your card GeForce 6150SE seems to be a problem.
I cannot say if it is THE problem which you have now, but an update to
295.49 or a downgrade to the previous driver version (I think it was
290.10) should probably help.

PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.3 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.3 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Thanks man!
I install previous driver:
NVIDIA - Download Drivers
Now it works fine.

The thread is closed.

Didn’t know which game you tried to play:)
And made a shot in the dark regarding the resolution, though that is something I run into from time to time myself.

Thanks for replies in any case. :slight_smile:

Are you 100% sure about this?
Why don’t you trust the EDID information?