No Mic Output Selection In Kmix

I’ve been running PCLinuxOs 2007 on my desktop for the past year and just installed OpenSUSE on my hp laptop.Kmix in PCLinux presents three tabs: input, output, and switches. These tabs aren’t present in the kmix mixer window I see in SUSE. What is happening is when I speak into the microphone I’m hearing myself through the speakers… very annoying when on Skype. I addressed this on my desktop by turning the mic setting under the output tab all the way down. Anyone have a solution to my dilemma?

The mixer with the KDE4 desktop has a menu item which allows one to add additional controls to the mixer.

Thank you for your reply. I had found that feature and added the mic controls to the mixer window, but mic output doesn’t seem to be an option… only the mic input.

Why would you want a mic output?

I need to see the mic output selection so I can turn it off. The default seems to be on. That’s why I’m hearing myself through the speakers. I would like to have mic input on, mic boost on, and mic output off. I’ve accomplished the first two but not the third.

I do not know about PCLinuxOs 2007 , but in most Linux versions I thought that (hearing yourself thru the speakers) was known as loopback?

Which version of openSUSE are you running? If running openSUSE-11.1 you could, with your PC connected to the internet, type:
and that will provide a URL (if it asks to update, you may need to re-run it as root to ensure the update works). Please post here the output URL you get after a successful run of the script.

Thank you for taking the time to help. I ran as su and it did update. The resulting URL is

I don’t see anything obviously wrong there. I do note your PC has a Cx20468 (uses the snd_ali5451 kernel module). do you get this mic effect with arecord? if not, then it could be a skype problem. You can run arecord as follows, typing in a gnome terminal or a kde konsole:
arecord -d 10 myrecording.wavwhere “-d 10” specifies a 10 second recording. Record 10 seconds there and then a play back “myrecording.wav” with a nominal player. While recording, do you still hear your voice being looped back to you?

It may be that your sound config is not properly configured by alsa. I do not see any options specific to the CX20549, although there are some conexant model options in the ALSA-Configuration.txt list for 1.0.18a of alsa:

 	Conexant 5045
	  laptop-hpsense    Laptop with HP sense (old model laptop)
	  laptop-micsense   Laptop with Mic sense (old model fujitsu)
	  laptop-hpmicsense Laptop with HP and Mic senses
	  benq		Benq R55E
	  test		for testing/debugging purpose, almost all controls
			can be adjusted.  Appearing only when compiled with

	Conexant 5047
	  laptop	Basic Laptop config 
	  laptop-hp	Laptop config for some HP models (subdevice 30A5)
	  laptop-eapd	Laptop config with EAPD support
	  test		for testing/debugging purpose, almost all controls
			can be adjusted.  Appearing only when compiled with

	Conexant 5051
	  laptop	Basic Laptop config (default)
	  hp		HP Spartan laptop

I do not know if any of those are applicable to your laptop. But it would not hut to test them one at a time. I can provided a recommend syntax for an edit to your /etc/modprobe.d/sound file to test them. Accordingly, can you provide the output of:

rpm -qa | grep alsa
rpm -qa | grep pulse
uname -a
cat /etc/modprobe.d/sound

Yes, the mic is heard through the speakers at all times when plugged in; even when Skype isn’t running. If I tap on it, blow, whistle, speak, the sound is coming right through them.

You mentioned the configuration of Alsa. When setting up my desktop I ran something called alsaconfig. I don’t see that listed in the SUSE repositories. Is that a tool that isn’t necessary with this distribution?

results for rpm -qa | grep alsa:


results for rpm -qa | grep pulse:


results for uname -a:

Linux linux-xinm #1 SMP 2008-12-04 18:10:04 +0100 i686 athlon i386 GNU/Linux

results for cat /etc/modprobe.d/sound:

options snd slots=snd-ali5451

H0_h.9IOAySjxlQ5:Pavilion ze4400 builtin Audio

alias snd-card-0 snd-ali5451

alsaconfig? Do you mean “alsaconf” ? alsaconf comes with alsa-utils, which you do not appear to have installed.

Are you certain you did not forget to copy any applications as a result of typing: “rpm -qa | grep alsa” ? I’m really surprised alsa-utils is not present, as that is installed by default. It provides both alsaconf and alsamixer.

I recommend you also install alsa-tools and alsa-utils, reboot and see if you have any additional mixer selections.

I was initially thinking it may be possible to assign a model option to your /etc/modprobe.d/sound file, but now that I can see your /etc/modprobe.d/sound file, I have reconsidered that and I don’t think that is correct. I note the ALSA-Configuration.txt file has this to statye about the snd-ali5451:

  Module snd-ali5451

    Module for ALi M5451 PCI chip.

    pcm_channels    - Number of hardware channels assigned for PCM
    spdif           - Support SPDIF I/O
    		    - Default: disabled

    This module supports one chip and autoprobe.

    The power-management is supported 

with no suggestions for tuning.

Sorry for the confusion on my part. It was installed by default. I was trying to run alsaconfig which, of course, doesn’t exist. I did go ahead and install alsa-tools though, and ran alsaconf, rebooting afterwards. No additional channel selections are offered on kmixer however. Is this uncommon for loopback to occur with an external mic on hp notebooks? As I noted in my op I did experience this issue when setting up my desktop, but it was solved by setting the mic output channel to 0. Is there something from Alsa-tools I could try?

I have no more easy suggestions … you could take a read here:
Matrix:Module-ali5451 - AlsaProject
and research to see if there is a .asoundrc file that might help. But you are pretty much on your own from here on. Some links:

OK. I use gnome, and I had the oposite problem: no mic output from my front jack, but I solved it through alsamixer:

alsamixer -D hw:0

which allowed me to switch between my two mic sources and set the levels. YMMV.

Thank you for your efforts and the links. I’ll try them.


At some point with my tinkering the sound stopped working altogether. I took a look at Yast System Admin => Hardware => Sound and it showed no device configured. Somehow the configuration had been lost. I reconfigured with the quick configure feature and all worked beautifully after that… including the mic loopback problem… gone now. For anyone encountering this problem in the future, deleting the existing sound card configuration and reconfiguring might work. It seems to have for me.