No media playback even with codecs

This is kind of a mess I brought in. I have a large music library which half are duplicated files. Amarok doesn’t clean that cutter up, so I installed perl-duplicate-finder or something and I installed dupeguru pe and dupeguru me (a duplicate finder for songs and the other for photos, which I installed through a repo). I cleaned the clutter and I go to software to remove the apps I’ve installed and also proceeded to remove the repos related.

First thing I notice is that for some reason, software manager is removing yast2 and some other core programs along with the apps I’ve installed. So I interrupted the removal process and rebooted. The 3 programs were removed but but yast meta package handler was removed as well, along with other things. Dragon player wouldn’t open and amarok disappeared. I installed amarok again and the codecs from the community, but still I have no music or video playing. Steam, dropbox, and the plasma desktop was not affected but at this point, I cannot say what else got removed.

Is there a way to revert all the opensuse packages back to default? or is there a way to see what I’ve removed and what needs to be re-installed? If not, at least a way to play videos and audio again :expressionless:

If you had a default 42.1 installation, the root filesystem will be btrfs an snapper will be aggressively saving snapshots of your system. You can use snapper to roll back to before you installed the de-duplication software. (Un)fortunately the home filesystem is not included in the default snapper configuration.

Alternatively something like “zypper dup --from openSUSE-Leap-42.1-Oss --from openSUSE-Leap-42.1-Update” should set you back to a default software installation.

P.S. You might consider using a more relevant title for your thread.

I’ve re-installed all the missing packages. I think I do not need to revert everything back, but Dragonplayer and Amarok still don’t play. I’ve installed gstreamer base, good, ugly, bad, everything. And still I have no music on amarok and video on dragonplayer, if I can get this to work again, I do not need to revert. Unfortunately I do not know what else to do :expressionless:

what’s your repo list?

zypper lr -d

Both use Phonon, what Phonon backends do you have installed?

rpm -qa phonon*

gstreamer is the default, for full codec support you need to install gstreamer-plugins-bad-orig-addon, gstreamer-plugin-ugly-orig-addon and gstreamer-plugins-libav from Packman.
If you use VLC, you need to install the package vlc-codecs.

And you should do a full switch to the Packman repo, to make sure that you don’t have some crippled/incompatible libraries installed.

If you need more help, please post your repo list:

zypper lr -d
 |----     | Sim       |  99       | NONE   |

ibution/leap/42.1/repo/non-oss/ |
10| repo-oss |openSUSE-Leap-42.1-Oss |Sim
| (r ) Sim | Sim | 99 | yast2 |
ibution/leap/42.1/repo/oss/ |
11| repo-source |openSUSE-Leap-42.1-Source |Não
|---- | Sim | 99 | NONE |
e/distribution/leap/42.1/repo/oss/ |
12| repo-update |openSUSE-Leap-42.1-Update |Sim
| (r ) Sim | Sim | 99 | rpm-md |
e/leap/42.1/oss/ |
13 |repo-update-non-oss |openSUSE-Leap-42.1-Update-Non-Oss |Sim
| (r ) Sim | Sim | 99 | rpm-md |

rpm-qa phonon*

This are all the outputs from konsole

Please us the code tags for any computer output. it will prevent the editor from changing the formats

code tags are the # in the forums editor options bars

For playing back MP3 files, you need to install gstreamer-fluendo-mp3 (it’s in the standard non-oss repo).
Either do so with YaST, or run:

sudo zypper in gstreamer-fluendo-mp3

As already mentioned, for other formats you need to add the Packman repo and install the additional codecs from there.
Enter YaST->Software Repositories, click on “Add” and choose “Community Repositories”, then activate it in the list.
Then install the packages I mentioned and you should be able to play back practically all multimedia files.
Choose “Install xxx from Packman Repository (with vendor change)” or similar if asked.

Or just use the 1-click install in the Multimedia subforum or here:

rpm -qa phonon*
pedro@linux-c7cq:~> zypper lr -d
#  | Alcunha                             | Nome                                    | Act
ivado | GPG Check | Refrescar | Prioridade | Tipo   | URI                               
                                      | Serviço
 1 | Nvidia                              | Nvidia                                  | Sim
      | (r ) Sim  | Sim       |   99       | rpm-md |
/leap/42.1/                           |         
 2 | | openSUSE:Leap:42.1:NonFree              | Sim
      | (r ) Sim  | Sim       |   99       | yast2  |
ibution/leap/42.1/repo/non-oss/       |         
 3 |    | libdvdcss repository                    | Sim
      | (r ) Sim  | Sim       |   99       | rpm-md |
nSUSE_Leap_42.1/                      |         
 4 |      | Packman Repository                      | Sim
      | (r ) Sim  | Sim       |   99       | rpm-md |
USE_Leap_42.1/                        |         
 5 | repo-debug                          | openSUSE-Leap-42.1-Debug                | Sim
      | (r ) Sim  | Sim       |   99       | yast2  |
/distribution/leap/42.1/repo/oss/     |         
 6 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | Não
      | ----      | Sim       |   99       | NONE   |
/distribution/leap/42.1/repo/non-oss/ |         
 7 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | Não
      | ----      | Sim       |   99       | NONE   |
/update/leap/42.1/oss                 |         
 8 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | Não
      | ----      | Sim       |   99       | NONE   |
/update/leap/42.1/non-oss/            |         
 9 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | Não
      | ----      | Sim       |   99       | NONE   |
ibution/leap/42.1/repo/non-oss/       |         
10 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Sim
      | (r ) Sim  | Sim       |   99       | yast2  |
ibution/leap/42.1/repo/oss/           |         
11 | repo-source                         | openSUSE-Leap-42.1-Source               | Não
      | ----      | Sim       |   99       | NONE   |
e/distribution/leap/42.1/repo/oss/    |         
12 | repo-update                         | openSUSE-Leap-42.1-Update               | Sim
      | (r ) Sim  | Sim       |   99       | rpm-md |
e/leap/42.1/oss/                      |         
13 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Sim
      | (r ) Sim  | Sim       |   99       | rpm-md |

Here are the outputs with the # thing. I’ve installed the fluendo package, did nothing. Installed the community packages again for codecs and nothing.
Amarok still doesn’t play music and dragonplayer says no files are loaded when I try to play a video. Also noticed that ksnapshot and gwenview were not installed, had to install them again (probably removed when I removed the above mentioned packages).

Also I got a weird error while trying to update saying this:

Wrong digest. the file has been changed by accident or by an attacker since the repository creator signed it. Using it is a big risk for the integrity and security of your system. I think this is related to leap/42.1/oss repo, since I said no to the first pop up and another one appeared saying this repo failed to initialize. I want to share a screenshot but can’t since I can’t upload files here

Run this then:

sudo zypper dup --from 4

If it still doesn’t work, try to remove the gstreamer plugin cache, i.e. delete the folder ~/.cache/gstreamer-1.0/.

I’ve ran zypper dup this afternoon (updated 80 packages). But I did that dup --4 you asked. It downgraded plugins bad and ugly, still no video and audio. I deleted cache and now Dragon Player is working (I can play mp3 songs and mp4 video on the video player). Amarok still isn’t doing anything though

does kaffeine work, amarok uses phonon maybe phonon is misconfigured, do you have phonon-backend-vlc if so remove it, check if you have phonon-backend-gstreamer if you don’t install it.

Sudo zypper dup --4 downgraded 2 packages (plugins good and bad) and did nothing. But deleting the cache worked! Both dragonplayer and amarok are playing, thank you!! :smiley: (Amarok played after reboot. Dragonplayer played video as soon as I deleted cache, but Amarok started working after I rebooted)