no longer able to boot into Windows 7 after deleting OpenSuse extended partition

Hello Everyone:

I had configured my laptop as a dual boot OpenSuse/Windows 7 system. Everything had been working just fine–on normal boot-up I would boot into OpensSuse and it would give me the option of proceeding either to Windows7 or OpenSuse Desktop. However, just today, using a disk management software tool, without touching my Windows7 partition, I deleted the entire extended partition allocated to the OpenSuse (I did this in order to reclaim the no longer needed OpenSuse drive space so that Windows 7 can avail itself of the freed up memory). Now upon reboot, the system did not boot into Windows7. Instead I get a black/white system screen which says:

“Media test failure, check cable"Cannot boot from any device”
“Exiting Intel Boot Agent”

Then i immediately get a subsequent screen saying:

“Cannot boot from any device”

followed by a device status list with a “no valid operating system” or “device not found” descriptors

Is there any way to boot back into Windows7? FYI: I do have in my possession a OpenSuse rescue disk and Live KDE CD. However, I do NOT have a windows 7 repair disk. Also, just to let you know, the Windows 7 C:\ drive data is still there ( I know this because i did a fdisk -l with the OpenSuse rescue disk whereupon the C:\ partition as well as the recovery partition were still visible).

I would be profoundly appreciative of anyone out there who can lend any instructions as to how to go about booting back into windows.

Best,
Nora

Your system seems to boot in legacy/MBR mode.

You could at least say which version of openSUSE you were using.
PLEASE DO SO !!

That makes a difference.

You probably should have asked, what to do, before erasing openSUSE partitions
using some software that doesn’t care.

The most severe problem is the boot loader.

You could try to re-install the same version of openSUSE again as before,
and using the same choices as before
(with respect to the boot loader, if you at all did make any choices during
your 1st installation of openSUSE).

This may seem paradox, but try it.

If you thereafter can boot both, openSUSE and windows, prospects are better
to remove openSUSE.

Besides, why didn’t you like openSUSE ?

Good luck
Mike

This in fact means that you re-create your extended partition prior to the
re-installation of openSUSE.
This extended partition must not have exactly the same size as before.

Try it.

I am going to make a guess. I could be completely wrong. But if I am right, then fixing this is easy. If I am wrong, then at worst you have wasted a few minutes.

My guess is that grub/grub2 was installed on the external partition. And since that partition is deleted, you lost it.

If that is correct, then making the Windows partition the active partition will probably fix your problem.

So boot from a live CD, and use “fdisk”:


# fdisk -l /dev/sda

Decide which is the active partition. In the type code field, it will be listed as type 07. There is often a small partition (maybe 14G) with type code 07, and a larger one also of type code 07. Your main windows partition is the larger one, unless you have installed “bitlocker” for Windows. So now go into “fdisk” again


# fdisk /dev/sda
p

The “p” command should list the partitions. Then use the “a” command. It will ask you which partition to mark active. Use the one you have decided is the main Windows partition. Then use “p” again, just to check. Then use “w” to write the results.

Then see if it boots.

This all changes only one bit in the MBR, so won’t cause any damage.

It might not work, but it is worth a try.

That is what I thought.

Cheers!
Mike

You actually want to make the SMALLER partition ACTIVE (or bootable) and NOT the main Windows partition.
Starting with Windows 7, they’ve created a hidden partition, labeled “SYSTEM RESERVED” and set that one ACTIVE.
It’s typically the 1st partition, weighing in at about 100 MB.
The 2nd partition (visible as C : ) is your main Windows partition.

Nora,
If you are averse to using the command line, you could always find a bootable rescue CD containing “PartedMagic” or “Gparted”.
Gparted is used to maniuplate disks/partitions, but will also allow you to change the active bootable partition.
Gparted is a GUI, and will show you the “SYSTEM RESERVED” partition label.
Then you right click on “SYSTEM RESERVED” , select “manage flags” and check the “boot” box, hit “APPLY” , exit , and reboot.

(I don’t believe that “fdisk” in Linux will show you NTFS partition labels, so if you want to try nrickerts example above, then try setting the 1st, smaller partition active.)

*You didn’t specify WHAT disk management software you used when you deleted the openSuSE partitoin, but if you can get it up and running (was on a live cd), then I’d bet it has a tool to set the active partition as well.

FYI - I forget to mention that I’m using 32-bit Windows 7 Enterprise that uses an MBR layout, not the newer GPT, UEFI, or whatever layout.

Good Luck.

Either one works for me, though there’s a different BCD store used depending on which way you boot. If you install “bitlocker”, then I think you have to boot the smaller partition, since that sets up the crypto needed to access the larger partition.

Oh that’s right.

Also, I was originally thinking in terms of a bare metal install, where there’s usually a separate “System Reserved” partition created.
The fact that the OP references a “recovery partition” indicates to me that this is an OEM install where a separate “System Reserved” partition might not exist, but instead, be integrated into the main Windows (C: ) partition.

Thanks.