No login to XSERVER with nvidia

Lo, I realy hope somebody can help. I think I know totaly screwed up my system.
The default driver which was installed during installation worked (I think it is nouveau) but I wanted more performance.
All I wanted was, to get a working nvidia driver.

My Hardware:
Dell Inspiron 9400 with Geforce 7800 GO

What I did:

  1. Installed kernel-desktop and x11-video-nvidiaG02 deleted nouveau
    -> No X,
    Set the option nomodeset in /boot/grub/menu.lst
    -> Still no X

  2. deleted x11-video-nvidiaG02 installed nouveau
    -> X works but with a resultion 800x600 ! and no way to change

  3. downloaded latest binary driver
    zypper gcc make automake autoconf kernel-source kernel-syms
    echo “blacklist noueveau” > /etc/modprobe.d/nvidia.conf

init 3
Installed binary nvidia
-> no x after reboot
startx message is:

(EE) NVIDIA(0): Failed to get supported display device(s)
(EE) NVIDIA(0): No dieplay device found for this X screen.
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found
xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust /etc/permissions.local

my xorg.conf

Section "ServerLayout"
	Identifier     "Layout0"
	Screen      0  "Screen 0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"

Section "Monitor"
	Identifier        "Monitor0"
        VendorName   "Unknown"
        ModelName     "Unknown"
        HoriSync        28.0 - 96.0
        VertRefresh    43.0 - 60.0
        Option           "DPMS"

Section "Device"
	Identifier       "Device0"
	Driver           "nvidia"
        VendorName  "NVIDIA Corporation"

Section "Screen"
	Identifier "Screen0"
	Device     "Device0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Depth     16
                Modes    "1920x1200"

I hope somebody can help, I’m realy frustrated :frowning:

forget to mention: System is a new installed OpenSuse 12.1

I’d suggest you install from the nvidia repo. Remember to remove the binary installation first - the installer have a --uninstall option IINM. did you check the SDB here?

Remove the stuff you installed and type that:

su -l
zypper ar  nvidia
zypper refresh
zypper install x11-video-nvidiaG02

Did as you sugested.

called nvidia-uninstall
removed xorg.conf
commented all entries in /etc/X11/xorg.conf.d/
installed x11-video-nvidiaG02

I still get a resolution of 800x600 (seems to be vesa)

How can I tell xorg to start a new autodetection of the driver?

I assume you removed xorg.conf before installing the driver (?).
you can check if the module has been loaded with the command:

lsmod | grep nvidia

You can see if the driver is used in the output of

hwinfo --gfxcard

or by looking in /var/log/Xorg.0.log.

the NVIDIA Driver is listed
but I still just get 800x600

Since there so many people having problems with the nvidia driver I’ll reinstall opensuse and use the default driver. (not fast but works at least)
I think the nvidia driver is not yet ready to use with 12.1

Hello everybody,

thanks for the info. i had problem with starting x server now its solved by using code hwinfo --gfxcard as (please_try_again) suggested