No login screen on external monitor (dual monitor setup, KDE, Tumbleweed)


I am running openSUSE Tumbleweed on a Fujitsu P701 (with integrated Intel graphics) notebook with a docking station and an external display connected with a VGA.

The problem is. that why I boot pc in a docking station with the lid closed (so with external display only) KDE login screen does not show up. However I am able to type my password blindly and confirm it. After it everything runs smoothly.

In .local/share/kscreen I have two config files: one of them includes config for enabled internal display and the second one for enabled external display (in this config file external display is marked as primary).

Desired situation would be if login screen was shown on an external display when notebook is docked in it’s docking station with a closed lid and on internal display when notebook is undocked and lid is open. (I rarely use both displays at the same time, so I am fine with switching internal one manually in Settings if needed).

I don’t know if its important but I use a xrandr script to set a correct resolution for my display. It runs on startup.

xrandr --newmode  "1280x1028_60.00"  109.50  1280 1368 1496 1712  1028 1031 1041 1067 -hsync +vsync
xrandr --addmode VGA-1 1280x1028_60.00
xrandr --output VGA-1 --mode 1280x1028_60.00

What I tried was modifying config files in .local/share/kscreen so that when internal display is disabled, external one will be recognized as a primary one. But it hasn’t changed anything. Removing them had no effect either.

Thank you for helping

What does “xrandr script runs on startup” mean? Anything run from $HOME has no effect on the greeter. If you want xrandr to affect the greeter, try putting your script in /etc/X11/xinit/xinitrc.d/.

If the mode you’re setting with xrandr (1280x800) already actually exists for the target display, you should not need to newmode/addmode it.

Given the age of your P701 (Sandy Bridge?), you might enjoy better behavior by switching the Xorg driver. What does

inxi -Gxx

report? (If command-not-found, install it. It’s in standard repos.) If it reports modesetting, try switching to the Intel driver by installing xf86-video-intel, which should automatically cause its use on restart. If using intel, try switching to modesetting by removing xf86-video-intel and restarting, which should result in automatic use of modesetting instead of intel. Last official intel driver update was >3 years ago.

Thank you for your answer.

Installing xf86-video-intel solved the problem.
I have to use script with xrandr commands because for some reason system doesn’t recognize correct resolution by default. It runs after login so bootup-splash is displayed with a wrong resolution. Moving this script to /etc/X11/xinit/xinitrc.d/ has no influence. Instead I used “Yast - Boot loader” to set console resolution but it sets correct resolution only for grub. But that’s something that I can live with.

Thank you for your help.