No login screen in latest tubleweed in virtualbox

I’m running virtualbox 5.1.10 on fedora25. I was trying to run tumbleweed on virtualbox but the login screens seems to be not loading after the installation. Any workaround needed ? This has kept me from moving from FC25 to tumbleween on my Laptop :frowning:


Hm, Tumbleweed works fine here in VirtualBox 5.1.6.

Try to add “iomem=relaxed” to the boot options.
If the vboxvideo kernel module fails to load for some reasons, Xorg will fall back to the non-KMS “vboxvideo” Xorg driver, which only works with that kernel option in TW.

I tried above but still no login screen. when i do a dmesg in guest console, i see there is a segment fault error from gnome-shell.

You’ll have to be more clear not necessarily about what you don’t have, but what you do see.

So, for instance…
Do you see a text only graphical prompt?
A Black screen with or without a blinking cursor?

What Desktop do you have installed, KDE, Gnome or something else?

After you do your Grub2 selection, you can also click the ESC keyboard button to observe the boot process, what is the last thing you see on the screen?

Am also assuming that this is a newly installed Guest, and not an upgrade or migration from another machine…


Sorry for not adding the details, I did a fresh guest installed of the Gnome DE on Vbox. My host OS is Fedora 25. As i mentioned its either the X server or the GDM fails according the logs. I can jump into console by entering CTRL+F3 from the VM emulator.

I no longer running Fedora 25 since i took a leap of faith and installed tumbleweed as my host OS. But i will try to install vbox and see whether i can run a guest installed of tumbleweed and see whether my problem was due to Fedora Host or Fedora VBox version.

I did NOT have any problem to set up such a configuration with Tumbleweed in both of host and guest. Maybe this could give you more confidence :slight_smile:

P.S. Just for my curiosity, did you try to install from the ISO? I did that once and made my Tumbleweed on the guest run into black screen but I managed to save it by entering CLI using Right Ctrl + F1. Here is a Guidance on VirtualBox, you might find it useful: It is important to notice that openSUSE has it’s own VirtualBox package and the Guest additions are packaged as well so it does not need the ISO to install guest additions for Linux, unless you use a difference source of VirtualBox package.

There were indeed problems with gnome-shell in VirtualBox, as I read meanwhile…

Can you re-try a new Tumbleweed snapshot, it might have been fixed AFAIK.