No login screen in KDE 4.2

I’m probably missing something pretty basic, but it’s got me stymied.

I’m running Suse 11.1 with KDE 4.2. On boot, I don’t get a login screen, it simply automatically logs me in as one particular user. It happens to be the user that I need 95% of the time, so it’s not that bad. But if my wife wants to login as her after a reboot, she can’t do it. My user is automatically booted.

If she waits until KDE starts up and then goes to log my user out, instead of getting to a graphical login screen like she’s used to, she gets dumped to a console (and here’s the kicker) with my user still logged in. To login and get to KDE with her username, she has to log me out from the console, then login as her, then startx. That’s waaaay too much hassle for her, and it shouldn’t be that way anyway, so I’d like to fix it. How? Auto-login is disabled in the Login manager.

taken from another thread in the forums, but:

yast - security & users -user management. look for autologin & change it

Expert Options button → Login settings

That did it. I knew it would be something easy. Thanks guys.

As an aside, how many different places do they need an auto-login option? I know one’s a Suse thing and one’s a KDE thing, but still…

–chriscrutch