No login screen after latest upgrade

I did a zypper dup upgrade this morning (I do one every other day). Lots of new packages. Looked like a new KDE version. Unfortunately, after I reboot, the system does not give me a login screen. It just stays stuck at the green background. I was able to see the nvidia logo briefly though, just before it stops. I am able to move the cursor around. I can press Ctrl Alt Backspace and the screen goes black momentarily before it goes back to the green screen. If I press the power button on the machine, the system begins the shutdown process and halts cleanly.

In the failsafe mode, I am able to log in and start the network. When I type uname -a, it says that I am using the 3.1.10-1-desktop kernel. Any advice to resurrect my system? It will be much appreciated.

So, if you upgrade the KDE Desktop to 4.8, there was an issue in which you needed to reselect your default desktop session, such as KDE Plasma so the login would work. I might add that you did not specify your openSUSE version or the Desktop selected which makes it hard to know what you really did. Further and in general, no one suggests that every other day you should be doing a zypper dup command. I recommend you will want to read the following message post so that you might understand just what you are doing:

Thank You,

I don’t use anything other than KDE. But, I will search the forum for a thread that might show me how to do that.

Sorry about that. I am using OpenSuse 12.1 with the Tumbleweed configuration.

I am a PCLinuxOS refugee. As you likely know, PCLinuxOS is a rolling release distro and the advice there was to always install all updates. I know OpenSuse Tumbleweed is not exactly a rolling release distro, but I thought that the philosophy of installing all updates still applied. Maybe I am wrong. I will read the link you provided.

Well, I found a thread that talks about needing to reselect KDE as the default desktop after a KDE 4.8 upgrade.

However, I doubt that that is the issue I am having. I cannot even see the login screen, much less be able to get to KDM to make the change. Besides, I was already in 4.8. I believe I just upgraded from KDE 4.8.4 to 4.8.5-6.

You said there were lots of packages and that you can briefly see the NVIDIA logo. Those two things together could mean that there was a kernel update in there as well…

When the kernel updates, you need to re-install the NVIDIA kernel module. You don’t have to re-install the entire driver.

Boot back into runlevel 3 and use the same nvidia .run file that matches the version of driver you are running.

When you re-run the file, append the flag -K to the end. This should re-compile the kernel module and let you reboot back into KDE.

From the nvidia --advanced-options page:

  -K, --kernel-module-only
      Install a kernel module only, and do not uninstall the
      existing driver.  This is intended to be used to install
      kernel modules for additional kernels (in cases where you
      might boot between several different kernels).  To use this
      option, you must already have a driver installed, and the
      version of the installed driver must match the version of
      this kernel module.


Thanks a lot for the response. What you say seems like it may be a good thing to try. I will try to accomplish what you are saying, although I have to first track down several steps that I do not know how to accomplish. I found this page which seems to have what I need.

I’ll report back latter.

Further help in installing the nVIDIA driver the hard way can be found here:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums


LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46 - Blogs - openSUSE Forums

Good Luck.

Thank You,

Bummer, now I can’t install the nvidia driver. I am getting this error when runing the .run file:

ERROR: The kernel header file ‘usr/src/linux/include/linux/version.h’ does not exist. The most likely reason for this that the kernel source files in ‘/usr/src/linux’ have not been configured

I see that someone else had that problem recently and solved it by installing and removing who knows what.

As I mentioned before, I am running kernel 3.1.10-1-desktop kernel. So my problems doesn’t seem to be the kernel. I do have all the sources and development packages installed. The nvidia package I downloaded and are trying to install is

I don’t know if I have the patience for this.

In KDE open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install. Gnome will be similar, but exactly the same to start YaST.

Thank You,

On the link I provided above I was instructed to remove the nvidia packages. I guess that is why I can now log in to KDE with a very low resolution. So, I was able to follow your advice and install those patterns. However, after booting back to failsafe mode, I still get the same error that prevents me to install the nvidia .run file.

I wonder if I can try installing the nvidia driver from yast now. Which packages should I choose? I see several nvidia packages in Yast.

Didn’t work. Dropped me to a console login. I am sorry guys. I just don’t have the time for this. I’m going back to PCLinuxOS for this system. I still have OpenSuse on my laptop (Intel graphics) and I am enjoying it. PCLinuxOS has a new release that I am running on another system and is very nice. Unfortunately, no 64 bit version, but the 32 bit one is incredibly fast and snappy. More so that any other distro I have tried.

Thanks for your help.