No login screen after dup from 42.3 to 15.0

I upgraded Thinkpad T420s (nVidia only enabled) from 42.3 to 15.0. I disabled all non Suse Repos except for nVidia, edited config (replaced 42.3 with 15.0 and tested that all links work)

zypper up --download-only
 zypper ref
systemctl set-default
systemctl isolate
zypper dup --no-refresh

After rebooting machine in the morning and changing systemd target to graphical, the machine boots, but I get grub splash, then loading initial ramdisk, then 3 green dots. After that I come to black screen with working gray mouse cursor, which can be moved. Problem is only there is no login screen or any way to log in to desktop and get kde.

If I CTRL+ALT+F1 I can login with text and update the machine.

I tried installing kde and laptop patterns, I’m thinking it’s some config or missing package issue. Which package provides login screen? (tried searching in yast but the kde-ones seem installed). Does anyone have any ideas how to sort this out?

It probably has to do with the nVidia drivers. Perhaps try a forced reinstall of those.

Please show the repositories:
zypper lr -d.
Do you change nvidia from 42.3 to 15?
Or uninstall the old nvidia driver and install the new one?

I had something similar with an AMD machine which hung; but Ctrl-Alt-Backspace (twice) brought up the login screen - it happened once later but otherwise no further problems with getting to the login screen.

yes if you get no gui press ctrl+alt+F1 and do a console login
if you have an nvidia card either uninstall the old 42.3 driver or change the nvidia repo to point to the 15.0 drivers and force a reinstall
you should really tell us your repo’s

zypper lr -d

the LEAP 15 nvidia repo is located at
you only need to change 42.3 to 15.0 but if you’re uncomfortable with the console uninstall the nvidia packages and reinstall them for 15.0 from a gui desktop

I ended installing 15 from scratch and it’s fine.

The nVidia driver repos were already at 15 and I tried removing nvidia repos, doing update and then reinstalling nvidia drivers.

I had some problems from 42.3 as at some point when installing some software I managed to remove most of kde by switching repos to some qt base or somesuch. I managed to solve that by switching repos manually to suse 42.3, changing priorities and doing dup. I was stuck with vanilla kde (cube with login name underneath) login screen but everything otherwise worked. I thought upgrading to 15 would get login screen back to opensuse but it didn’t. At that point I decided to reinstall (backed up my home before the upgrade).