No Login Prompt After Screensaver Lock

Recently, well, mostly today, I’ve had an issue where if I leave the computer alone and the blank screensaver kicks in, I can come back and type in my password to see the desktop again.

That’s normal… the issue is, after I type in my password and let it sit idle again (I’m bad about doing that), it goes back to the blank screensaver, only this time when I move the mouse, no login dialog appears!

So I’m left looking at a black screen where I can move my mouse cursor, but nothing else happens. Also, I’ve noticed that when mousing around, I can get the “resize window” mouse cursors near the borders of where I remember having an application at.

Anyway, I end up doing Ctrl+Alt+Backspace twice, which takes me back to “main” user login screen for GNOME. After logging back in, of course, I’ve lost all of my work in my open applications.

Thankfully I haven’t been doing anything major on the computer recently, and thus haven’t lost any real work, but the thought is scary and this is frustrating.

I don’t really know what is going on or what to do about it. Any help is greatly appreciated.

I’m running openSUSE 11.1 x86_64 GNOME. Also, I’m curious if this happened immediately after the recent xorg and sax2 updates from last week (July 12th - July 18th, 2009). My current versions are: xorg-x11 7.4-8.19.1, sax2 8.1-542.11.1

I just realized that I can downgrade those packages, so I might try that out.

Regards,
Matt

Better disable screensaver to be honest, just tends to cause issues like this.

I got into the Screensaver settings earlier, but now I can’t. I even rebooted the computer and still can’t.

I went to Computer > Control Center > Look and Feel > Screensaver, but now the Screensaver Preferences window comes up completely grey (I changed the theme window background to grey, since I’m used to it from Windows) except for the white rectangular screensaver selection box, which is solid white with nothing listed now.

I can let it sit and it doesn’t refresh that window, and clicking the “X” to close it finally asks me to “Wait” or “Force Quit”.

Now what? :expressionless:

I really ought to install gnome myself just so I can get familiar with all the settings and learn where all the config files are.
Hopefully - someone with gnome knowledge will see this. Temp’ you could try creating a New User account (it can be deleted later)

Wait for further replies and I’ll see what I can find out.

Hi,
you can use gconf-editor to disable the screensaver

goto apps>gnome-screensaver
and uncheck the idle_activation_enabled key

HTH

@maill - Thanks

That location is in hidden files
.gconf/apps/gnome-screensaver

@caf4926
Glad to help :slight_smile:

I tried the Screensaver preferences again, and this time it worked. I unchecked the ‘Activate screensaver when computer is idle’ option, and then double-checked the value in gconf-editor.

I’ll update if I have any more problems.

Thanks you two! :slight_smile: