No loggin screen after update to 12.2

I have the same message in my Xorg.log and also have nVidia with proprietary drivers but I do not have issues with graphic. I do not use KDE though (for a change this time :slight_smile: )

I wonder, why nobody else is complaining about this blue screen.

There are many complaints about nVidia + nouveau (native Linux driver) but they usually are fixed by using proprietary driver. Are you sure driver is correctly installed? You say

moothly fades into the kde-Desktop
which leds me believe you are still using nouveau with KMS, which means you hit well known problem.

Can you post a link to a place where one can learn how to replace nouveau by nvidia. It doesn’t seem so easy.

SDB:NVIDIA drivers - openSUSE

I installed the current driver, uninstalled nouveau-driver, but no change at all. I still cannot log out from KDE, blue shaded screen. Also there is still the same transition from a simple green screen to the KDE-desktop during startup.

Does anyone know how to turn off the grub2 splash screen? I’d run into one of the problems talked about here (the blocky screen after boot, before login) with my NVIDIA GeForce 8600M GT card. had a workaround of hitting ESC at the boot splash screen, but I’d rather it just not come up at all if I have to manually intervene each time.

Do you really mean GRUB2 graphical menu or kernel splash screen? For the latter, edit /etc/default/grub, change “splash=silent” into “splash=0” on GRUB_CMDLINE_LINUX line and recreate grub2 configuration with “grub2-mkconfig -o /boot/grub2/grub.cfg”. I wish I new how YaST2 handles it, but I still use grub1 after updating from 12.1.

OK in GRUB2 you go into Bootloader - Boot Loader Options and edit Optional Kernel Command Line Parameter field which contains the same.

Kernel splash screen.

Perfect! I put that in in /sbin/yast2 (or whatever came up in the search window in the start button with “yast”), changed the config, let the reboot work its magic, and I got a real login screen. Thanks for the help.