No loggin screen after update to 12.2

My loggin screen disappeared once I installed to opensuse 12.2
Instead of the green splash screen with the moving white circles I suddenly see a blue shaded screen and nothing else hapens.
When I use a alt-F1 console, I eventually am able to run startx and kde appears but also without the usual window where the different startup icons appear one after another.

Help is really appreciated. Please let me know, what additional information you need. Nvidia is updated too.
Thanks, Johannes.

I wonder if the kdm (login manager) got lost along the way…

Run the following from a terminal to see what you have installed and let the forum know what it says:

zypper se -si kdm

You could also post the output of

zypper repos -d

If you find that kdm is not there (the output of the first command will be empty), install kdm then see if you can access the login settings to change the login theme.

Can you maybe also explain what method you used to install the NVIDIA drivers? It could be a conflict with nouveau.

How did you install 12.2? Was it an upgrade/dup or a fresh install?

On 09/12/2012 07:06 PM, p6majo wrote:
> When I use a alt-F1 console, I eventually am able to run startx

if you run startx as yourself, a simple user it will not run (by design).

but, if you run it as root it will run…but then you are in the GUI as
root, and you should not do that…


Log into alt f1 as root and enter kdm if nothing happens the go to alt f10 the last line will tell you that another xdm is running and give a pid. Back to alt f1 and kill that pid. then retry kdm.

What does cat /var/log/Xorg.0.log say.
You may have another windowmanager running besides kde try right and left clicking to see if a menu pops up. the icewm behaves this way

I am not sure if p6majo found a solution or not, but I think I have this problem too.
Situation new installation (no update) of 12.2.
After the installation the graphic is fine and nouvelle driver is used for my geforce 8400m G graphic card.
Then after the first reboot (without selecting failsafe) no login screen but strange patterns all over the display monitor. The mouse pointer turns into a red (or rather pink) square.
Selecting failsafe in the grub menu helps to start KDE, but the resolution must be something like 800x600 or less and the windows are not made for this (so one can hardly reach the “ok” or “abort” buttons at the window bottom).
Starting kde from the failsafe console helped to start kde with normal resolution (something like 1280x800x16), but kde was hardly stable and froze frequently. If it froze it kind of froze to death, so kde crashed and the system returned to the failsafe console.

As time went by I tried several things (please do not laugh, I do not claim to be a linux expert)
I reinstalled opensuse (one time with automatic configuration, one time without), without success.
I played around in the bootloader with the kernel parameter without success.
I read somewhere that downgrading the nvidia driver would help. So I downgraded the driver (x11-video G02) from 304.43 to 295.71 from the nvidia site and used tabu in Yast to prevent the upgrade of every driver that seemed to be related to nouveau or to the nvidia hardware but comes out of an opensuse repository.
Well, this worked so far.
Now I can use the default option in grub and the login screen looks normal, and even after the login screen the computer hardly freezes and it never froze to death so far.

Still I do not like the frequently freezing of the computer (sometimes I can still move the mouse, but clicking has no effect, sometimes even the mouse freezes for several seconds).

So please help me to find out what this freezing is all about. Maybe we find a way to use the nouvell drivers to keep the open source system completely open source.

cat /var/log/Xorg.0.log said: (I cut only the lines related to errors to keep it short)
22.289] (II) Loading extension DRI2
22.289] (II) LoadModule: “glamoregl”
22.290] (II) Loading /usr/lib64/xorg/modules/
23.003] (EE) Failed to load /usr/lib64/xorg/modules/ /usr/lib64/xorg/modules/ undefined symbol: _glapi_tls_Context
23.003] (II) UnloadModule: “glamoregl”
23.003] (II) Unloading glamoregl
23.003] (EE) Failed to load module “glamoregl” (loader failed, 7)
23.003] (II) LoadModule: “extmod”

(this were the two errors I found in the situation as p6majo described it)

27.942] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
27.942] (II) No input driver specified, ignoring this device.
27.942] (II) This device may have been added with another device file.
53.857] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x0000971c, 0x00009b0c)
54.821] (WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x00009b0c, 0x00009b0c)
86.715] (EE) NVIDIA(0): Error recovery failed.
86.791] (EE) NVIDIA(0): *** Aborting ***

(this is what if find now additionally)

Any idea to avoid these errors is apreciated.

I have the exact same problem as you on every single PC i’ve installed openSUSE on that runs NVIDIA GPU’s but my limited knowledge means I don’t know where the real problem is but have found a solution for my case which may help you.

Can you try booting without the Splash screen enabled?

Replace the “splash=somedefaultoption” kernel option with “splash=0” and optionally remove the “quiet” option from the line so that you get more output during boot.

You can change boot options in the Boot Loader found in YaST. Press the Boot Loader Options button (for Grub2).

Here is what mine looks like. I have nomodeset because that’s required for the nvidia kernel module to load successfully at boot time.

resume=/dev/mapper/cr_swap splash=0 showopts nomodeset

You will probably have a different ‘resume’ option depending on your partitioning.

This should turn off the Plymouth splash and other startup scripts.
If you enter the splash=0 option and still see a splash screen (at any time during boot) during start up press the <Esc> key on your keyboard to close the splash screen.

Does the PC boot to a normal desktop now because the splash screen is disabled?

If it does, go ahead and remove the plymouth/splashy packages or ‘mask’ out the splash/splash-early and plymouth services.

If you need help on how to do either of those, feel free to ask =)

Maybe just install the NIVIDIA driver??? That generally clears up these graphic problems

Thanks a lot for the quick reply.
I just tried it, but the only change was, that there is no splash anymore during the startup after grub and before the login screen. After the login and just before the K-symbol of kde appears the screen and mouse freeze for approximately 6 seconds like before. After KDE is up sometimes it still freezes (especially if I lauch firefox).

try renaming ~/.kde4 may be a bad KDE config file.

Thankx for the help gogalthorp!
I updated the NVIDIA driver to the latest version(304.43), but KDE became very instable. I could hardly start X
So I tried to find ~/.kde4 files, but I only found macros.kde4 and .
Did you suggest to remame these files?
I had some doubts, since none of these two files is in ~/config.

.kde4 is a folder in your home folder. It certainly exists.

Note that the name .kde4 starts with a period which makes it a hidden file if you are using a graphic browser you need to set the show hidden menu item on.

Note also you should not do this if you are running as the same user as the home directory since it is like changing the tires on a car while driving it!!!

Why I’d do it is to boot to run level 3 (command line)
log in as root
change directory to the home I was going to edit
cd /home/usernamehere
rename directory
mv …/.kde4 …/kd4.bak

reboot and start normally

Thank you very much guys for all of your hints.

To finish this off, I just want to describe how I finally solved this issue for me.
By using old or new NVIDIA driver did not solve it.
removing the .kd4 did not help.
After a new installation (selecting grub and not grub2) I faced again the destroyed login screen, but with CTRL+ALT+F1 I could change to console and startx as root.
After removing the “splash=silent” out of the optional parameter for the kernel parameter the issue was solved.

Weird that that never worked before but it does now, probably has to do with grub2 vs grub =)

I think splash=0 is the same as removing the splash=silent.

Thanks for all your effords. I somehow expected the forum to send an email to me when replies are written. It didn’t that’s why I only reply now.

First: kdm is installed and nvidia is updated as well.
I really regret updating to 12.2. Now I’m not even able to switch between different windowManagers. As soon as I log out from KDE I get this blue screen.

I don’t want to reinstall everything. Is it possible to switch between grub2 and grub on an existing system?

Thank you,

YaST2 offers selection of bootloader. Should be possible.

I used a network image on an SDCard to perform the upgrade

Somehow, now I’m able to boot a ll the way through to kde. However the screen with the appearing icons at startup doesn’t show. When I log out to start a different window manager, I get the blue shaded screen again. I Tried your advice, and killed the running xdm-pid. When I type kdm again, alt f10 shows:X server died during startup.

How can I change the default window Manager?

I finally walked through all your suggestions

splash=silent -> splash=0
the initial splash screen disappeared (but it didn’t turn out to be the problem)

After a lot of information about the booting process a green screen appears again (without the usual kde-symbols showing up one after another). This screen smoothly fades into the kde-Desktop which is nice.

If I log out from kde to switch to another window manager I get this ugly blue shaded screen which is not a windowmanager (left right mouse clicks have no action at all)

I cannot start kdm, since another xdm is locking the screen. If I kill this xdm, kdm is not starting instead I find the message: X-server died during startup

My /var/log/Xorg.0.log shows exactly the same failure as stated in previous posts:
22.289] (II) Loading extension DRI2
22.289] (II) LoadModule: “glamoregl”
22.290] (II) Loading /usr/lib64/xorg/modules/
23.003] (EE) Failed to load /usr/lib64/xorg/modules/ /usr/lib64/xorg/modules/ undefined symbol: _glapi_tls_Context
23.003] (II) UnloadModule: “glamoregl”
23.003] (II) Unloading glamoregl
23.003] (EE) Failed to load module “glamoregl” (loader failed, 7)
23.003] (II) LoadModule: “extmod”

Uninstalling plymouth had no effect at all.

I wonder, why nobody else is complaining about this blue screen. This is why I turned away from windows.

How can I change the default windowManager to gnome?

Thank you for your patience.