No line input playback

Hello,

I can record from line input, but I can only listen to my vinyls after replaying my recordings in Audacity. With pavucontrol or Audacity, I see the input level meters moving, but I don’t hear playback.

I am sure I simply need to turn on an option on my configuration, but I can’t seem to find it anywhere. I haven’t been able to figure that out since I upgraded to 12.1 a few months ago. Beside this minor issue, everything is working fine with my sound setup.

Here’s the output of alsainfo.sh: http://www.alsa-project.org/db/?f=7754ffaf85eea9e44f6911c1dc88ff01667c33b9

Does anyone know how to enable the sound playback from line input? Any suggestions are welcome!

Thanks and regards.

JeromeQc wrote:

>
> Hello,
>
> I can record from line input, but I can only listen to my vinyls after
> replaying my recordings in Audacity. With pavucontrol or Audacity, I see
> the input level meters moving, but I don’t hear playback.
>
> I am sure I simply need to turn on an option on my configuration, but I
> can’t seem to find it anywhere. I haven’t been able to figure that out
> since I upgraded to 12.1 a few months ago. Beside this minor issue,
> everything is working fine with my sound setup.
>

Right, you need to enable “Software playthrough” in Audacity.
Simply tick the checkbox at the “Transport” menu.


Have a lot of Fun!

Thanks a million: I can now listen to my new records!

I will reopen this old thread I created last year because even thought I can hear my records in Audacity with “Software playthrough” activated I am still experiencing 2 related issues with 12.2 and KDE.

  1. I can’t hear any playback without Audacity even if the line channel volume is set to maximum. About 2 years ago, on a previous version, I would always hear the sound from line in;
  2. I just discovered Audacity is skipping when recording and/or monitoring my records and it doesn’t play in real time. After just a minute of playing it starts to lag of a few seconds.

This second issue made me waste about 8 hours because I thought my turntable that was skipping and I tried everything to fix it, until I started to mess with the arm pivot screws and ended up breaking something. I placed an add to give my broken turntable and I bought a new one, just to realize the problem was not with my beloved turntable.

Is it possible to always hear the playback from line in as it used to work by default on previous releases ?

Does anyone have any idea why Audacity is lagging and skipping when recording or monitoring the playback from line in?

Thank you for any advice or suggestion!

After a dozen of bad vinyls rips, a damaged turntable and days of pain and frustration, I finally found a solution! It doesn’t skip or buffer anymore when recording and monitoring in Audacity with the JACK Audio Connection Kit!

All I had to do was to launch JACK and select it as the host device in Audacity, with playback and recording device set to system (was by default) under the preferences Devices tab.

I wonder if Pulse Audio could be the culprit to blame. From what I read JACK is a sound server just like Pluse Audio, and both are running over ALSA. Is that correct? When selecting ALSA in Audacity, it is still going through Pulse Audio, right?

Well, this thread is already 2 years old but I just found the solution to the first issue I reported above:

I can’t hear any playback without Audacity even if the line channel volume is set to maximum. About 2 years ago, on a previous version, I would always hear the sound from line in;

When running alsamixer from the command line, even if the line in wasn’t set to 0, it was set to M at the bottom and I just had to hit the M key to unmute it. I know it might sound dumb but it was not obvious as the level was not down to 0 and I never noticed the M a the bottom of the meter.

I am now using this board as a convenient notebook but I hope it will help others as well…