No language shown (selectable) in IBus Preferences

Hello,

I am new to Linux and installed OpenSUSE 12.1. I finished basic set ups and now I am trying to install Anthy + IBus to type Japanese. So far I installed those relevant packages shown in the bottom. However, I cannot see Japanese language selectable in the “Select an input method” tab in IBus Preferences and so cannot add the language to “Input Method”. Could anyone please suggest what I should do (or the way I can check if my installation is correct)? Thanks!

i | ibus | Intelligent Input Bus for L-> | package
i | ibus-anthy | The Anthy engine for IBus i-> | package
i | ibus-devel | Development tools for ibus | package
i | ibus-gtk | IBus im module for gtk2 | package
i | ibus-gtk3 | IBus im module for gtk3 | package
i | ibus-m17n | The M17N engine for IBus pl-> | package
i | ibus-qt | Qt IBus library and Qt inpu-> | package
i | ibus-table | The Table engine for IBus p-> | package
i | libibus-1_0-0 | IBus libraries | package
i | libusb-0_1-4 | libusb-1.0 Compatibility Li-> | package
i | libusb-1_0-0 | USB Library | package
i | libusbmuxd1 | A library to abstract socke-> | package
i | libustr-1_0-1 | String library, very low me-> | package

i | anthy | Kana-Kanji Conversion Engine | package
i | anthy-devel | Include Files and Libraries mandato-> | package
i | ibus-anthy | The Anthy engine for IBus input pla-> | package

see my screenshot :
https://picasaweb.google.com/lh/photo/4LW66iPOqEJI22y-jrq1ONMTjNZETYmyPJy0liipFm0?feat=directlink
click the symbol “>”
you can select anthy module

If you use anthy, you may try gcin-anthy-module from M17N repository
use following command with root

zypper ar obs://M17N/openSUSE_12.1 m17n
zypper in gcin-anthy-module

then set your INPUT_METHOD variable as normal user with command

echo "export INPUT_METHOD=gcin" >> ~/.profile

relogin you can see gcin icons in system-tray
click on keyboard icon, you can select anthy module

Thanks a lot! The screen shot is very helpful. The problem was solved.
Apart from the suggestions above, I also needed to tick:
IBus Preferences -> Advanced -> “Share the same input method among all applications”
and display the system tray widget on the panel to see IBus icon (I previously removed the panel for some reason).

Also, YaST2 -> System -> Language -> tick “Japanese”