No keyboard or mouse in redirection viewer on install of openSuSE 12.2 64bit DVD

I’m installing openSuSE 12.2 x86_64 DVD on a headless Supermicro server X8DTU-F using the remote console with keyboard/video/mouse redirection and virtual media connection.

On powerup, the DVD is recognised as the boot device and the first menu appears with Boot from hard disk, installation, check media, etc. At this point, the keyboard is active and I can select F2 to change to a UK keyboard layout, and F3 to change to a text mode install (I’ve also tried this with default resolution, no KMS with the same result). The kernel loads and startup correctly, then it probes for a terminal, and the initial licence screen appears. At this point, the keyboard does not respond. Starting the install with the default resolution or no KMS has the same result and the mouse does not respond either. I cannot proceed past this point with no keyboard or mouse.

Am I missing something obvious? Any suggestions?

Why not use openSUSE 12.3? If you have access to the server, I would plug in a keyboard to get the install going.

Thank You,

Thanks for the reply. I have a ton of machines on 12.2, so will stay with that for the time being but plan to move to 12.3 before long.

I don’t have easy access to the server unfortunately, so I do want to try to get to the bottom of this problem.

Some further investigation show the following:

The kernel loads, then hardware detection, then loading the installation system 1/6 through 6/6, then this

stty: standard input: unable to perform all requested operations

then loads drivers, probes terminal and displays licence screen, and still no keyboard/mouse.

Hoping someone has seen this and has the answer.

Is the remote keyboard wireless or plugged into a USB 3.0 port by chance?

Thank You,

The remote keyboard is plugged into a standard KVM running on a Windows 7 (sorry!) machine. Note that the remote keyboard works fine in the first part of the install selecting installation, language, etc. It only stops working once the Yast licence screen is displayed.

My previous post with the stty message could be a red herring (i.e. nothing to do with this problem) of course.

I’m stumped for clues right now.

Problem solved using a workaround.

Use another installtio method, in my case ssh.

See this link for how to:

openSUSE 12.3: Chapter 2. Remote Installation

Happy to hear you found a solution and thanks for sharing it with us.

Thank You,