No keyboard after upgrade to 11.4

A few days ago I upgraded my workstation from OpenSuse 11.2 to 11.4 and found that when I got to an X login screen I could not type anything though the mouse worked. If I went straight to a terminal, such as by booting to runlevel 3 the keyboard worked fine so I figured the problem was related to Xorg. I did some research on the web and tried various fixes, such as reloading the proprietary Nvidia drivers, trying the nouveau drivers, booting with the nomodeset option, as well as trying most of the suggestions in this excellent article: SDB:Configuring graphics cards - openSUSE. No of these solutions remedied the problem.

Eventually I looked closer into the new (at least compared to 11.2) configuration for xorg. If I used the xorg.conf.install file or used an earlier Nvidia-specific xorg.conf file the problem continued. After taking a closer look at /etc/X11/xorg.conf.d/90-keytable.conf file I noticed all of the values for the options were blank, just “”. I set XkbLayout to “us”, started X and I had a functioning keyboard!

Other issues and problems proved to be minor and most of them are solved now. I hope my post can help someone else with a similar problem.


Excellent write-up, thanks - solved the same problem for me.

Many - many thanks. I know this thread is a bit old, but I wanted to say this fixed my problem as well. Thank you.