No kernel-source update for 3.0.4-43.2?

The recent Tumbleweed updates to kernel-desktop and kernel-desktop-devel 3.0.4-43.2 don’t include updates for kernel-devel and kernel-source. Usually they also get updated at the same time. I haven’t applied the update yet.

Any potential or real issues with that?


There was no update to

for kernel-desktop-3.0.4-43.2.x86_64
or kernel-desktop-3.0.4-43.3.x86_64

nor was there a need to recompile the proprietry video driver fglrx.
Installed driver still works ok.

Assumed, change not significant enough to warrent it.

Yes, I eventually assumed that yesterday after seeing the same for kernel-desktop-3.0.4-43.3.x86_64, and made the full upgrade without incident (so far so good). Except of course libreoffice going to 3.4.2 along with Calc’s issue/bug of “the lower navigation bar (for panning left/right through a
spread sheet)”.

BTW, kernel-firmware isn’t regularly updated with the kernel, in my experience. :slight_smile:

Didn’t need to reinstall Nvidia drivers either with this update.

Me neither. Normally I reinstall the NVIDIA drivers as a habit, this time I forgot, and all is fine.

Just be happy no kernel-source download is needed!

…and no, for building propr. Nvidia you don’t need no kernel-source at all!

:D. Unfortunately not the same could be said for LibreOffice.

Same for me too; no need to reinstall Nvidia or Virtual Box.

Kernel 3.1.rc7(the newest kernel around :stuck_out_tongue: ) can be found here: Index of /repositories/Kernel:/HEAD/standard i have it already under Vbox where is run openSUSE 12.1 Beta 1 (a.k.a Factory)

Today I tried the new driver.
It installed ok according to fglx-install.log but did not work.

Tried different methods with the same results.

Booted into the gui ok but no graphics acceleration.

No problems going back to

Anyone else seeing the same?

Kernel dependency problem or bad driver?

Linux linux-qz4c 3.0.4-43-desktop #1 SMP PREEMPT Wed Aug 31 09:30:44 UTC 2011 (a432f18) x86_64 x86_64 x86_64 GNU/Linux

As for nvidia driver may for ati driver you need to add “nomodeset” option to stop the loading of the generic video driver offered by the kernel. Have you added nomodeset to your bootloader options ?

Unnecessary for nvidia. It’s in the script in the drivers from Nvidia site.

NOMODESET is there.

Also KMS_IN_INITRD is set to YES.

Does anyone have the driver working?

The video card being used is the ATI Radeon HD 3200 Graphics.

KMS_IN_INITRD should be NO


if KMS_IN_INITRD is set to NO
then KMS is enabled

are you saying KMS should be enabled?

No, KMS should be disabled, and KMS_IN_INITRD = no will disable it.

Can’t recognize any logic … :frowning:

Creatura, I am right? (double negations are somewhat hard to decode)

enabled by default?

File: /etc/sysconfig/kernel
Possible Values: yes or any value
Default Value: 
Activation Command: /sbin/mkinitrd

 This variable disables the initialization of KMS in the initrd
 by not including the modules required for KMS even though KMS is
 supported on the underlying hardware.
 After changing run mkinitrd again.

if KMS_IN_INITRD is set to NO
then KMS is enabled

if KMS_IN_INITRD is set to NO then KMS is DISABLED

Updated to Linux 3.0.6-1-desktop x86_64 from “

Installed and driver worked on first try.

Up and running now for over 1 hour, no negative effects noticed.

updated to,


Kernel 3.0.6-44 in Tumbleweed :slight_smile:

ulenrich: you must add nomodeset to your bootloader options too.