No kdm on suse 11.2 after change of mainboard

i’ve recently changed my mainboard and now i got ati radeon graphic card. i had nvidia on the old board and my display was configured for nvidia.

have tried oldcpu guides for ati driver install but it has failed.

  1. uninstall the nvidia driver (if it was installed)

rpm -qa | grep -q nvidiaG02 && zypper rm x11-video-nvidiaG02
rpm -qa | grep -q nvidiaG01 && zypper rm x11-video-nvidiaG01

  1. delete/rename /etc/X11/xorg.conf (if any)

-f /etc/X11/xorg.conf ] && mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

  1. install the radeonhd driver (if it wasn’t installed)

zypper in xorg-x11-driver-video-radeonhd

  1. or install the proprietary driver (fglrx) as explained in other posts.

Somehow got it working, not sure what I did. Found one thread from July on ati hd2600, it now works.


I am unable to get desktop effects with this card. Any help?

ATI Radeon is ****, I need to find ATI opensource driver for this card -

david@linux-ftcs:~> glxinfo | grep “direct rendering”
Xlib: extension “NV-GLX” missing on display “:0.0”.
direct rendering: No

How to fix this.

What graphic driver are you using?

Do you an /etc/X11/xorg.conf file ? Have you done any special edits to the files under /etc/X11/xorg.conf.d/ directory ?

Please open your /var/log/Xorg.0.log file with a text editor, copy the file contents, and then paste the file contents on the web site - #1 paste tool since 2002! (or PhotoBox v2.0 or pastebin - Type, paste, share.) and press submit (as applicable) on that site, and post here the URL/web address it gives (indicating where the file contents located). Do NOT post the file content directly here.

That ‘might’ give some information in which to come up with an idea.

here xorg

david@linux-ftcs:~> cat /etc/X11/xorg.conf
Section “ServerLayout”
Identifier “aticonfig Layout”
Screen 0 “aticonfig-Screen[0]-0” 0 0

Section “Files”

Section “Module”

Section “Monitor”
Identifier “aticonfig-Monitor[0]-0”
Option “VendorName” “ATI Proprietary Driver”
Option “ModelName” “Generic Autodetecting Monitor”
Option “DPMS” “true”

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:5:0”

Section “Screen”
Identifier “aticonfig-Screen[0]-0”
Device “aticonfig-Device[0]-0”
Monitor “aticonfig-Monitor[0]-0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24

xorg log is here X.Org X Server 1.6.5 Releas - Avenuemax - GXdABrcS -

below are more details -

david@linux-ftcs:~> glxinfo | grep direct
Xlib: extension “NV-GLX” missing on display “:0.0”.
direct rendering: No

In many cases one does not need an /etc/X11/xorg.conf file in openSUSE-11.2 (although it is not as good as openSUSE-11.3 for automatic configuration of graphics).

I note these warnings:

#(II) Primary Device is: PCI 01@00:05:0
#(WW) Falling back to old probe method for fglrx

#(--) Chipset Supported AMD Graphics Processor (0x9610) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:1) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:1) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
#(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found

#(II) fglrx(0): ATI Video BIOS revision 9 or later detected
#(--) fglrx(0): Video RAM: 262144 kByte, Type: DDR2
#(II) fglrx(0): PCIE card detected
#(--) fglrx(0): Using per-process page tables (PPPT) as GART.
#(WW) fglrx(0): board is an unknown third party board, chipset is supported

#(WW) fglrx(0): Option "VendorName" is not used
#(WW) fglrx(0): Option "ModelName" is not used

Is this a ‘no name brand’ graphic card? X does NOT identify the vendor nor model very well.

What happens if you rename the xorg.conf file to /etc/X11/ and then reboot with no file in place ? Does that work for a reboot ? If stuck at a text prompt just rename the file back with:

su -c 'mv /etc/X11/ /etc/X11/xorg.conf'

another thing you could try is configure the card with the ATI graphic config program. Do this by booting DIRECT to run level 3 (not by typing init 3 in X) by typing 3 in the grub menu. Login as a regular user, then type ‘su’ (enter root password) to get root permissions. Then type:

mv /etc/X11/xorg.conf /etc/X11/'

and then try to create a better xorg.conf file with:

aticonfig --initial

and then reboot with

shutdown -r now

if that fails, then again boot to run level 3 (by typing 3 in the grub menu) and try sax2 (which is still present in openSUSE-11.2) by typing:

sax2 -r -m 0=fglrx

and then reboot with

shutdown -r now

Note at any time you can restore your backed up file to xorg.conf.

I am very busy packing currently, for a 3 week vacation in a different continent with limited to no internet access, so some one else (depending on post timings) may need to provide more info/suggestions if needed.

Thanks Old,

This is acer supplied mainboard and its all crazy.

david@linux-ftcs:~> su -c ‘mv /etc/X11/ /etc/X11/xorg.conf’
mv: cannot stat `/etc/X11/’: No such file or directory

I guess I did not make myself clear. That command you quotes was to RESTORE your xorg.conf after 1st backing it up … How familiar are you with Linux ? Apologies as I think I COMPLETELY misjudged your experience.

FIRST try this to backup file to different name:

su -c 'mv /etc/X11/xorg.conf /etc/X11/'

then reboot, test …

then restore if reboot fails with …

su -c 'mv /etc/X11/ /etc/X11/xorg.conf'

I use *nix for last 6 years. Never bothered with graphics card earlier (had nVidia earlier, which was straight forward).

I will prefer reinstalling x and configuring ati. In my etc/x11 I have several xorg.conf some generated by nVidia and some by ati. The trouble is I am unable to get sax generate a fresh xorg.conf.

There is no sax. There was a sax2. Is that what you mean ?

sax2 has been depreciated. But it is available in 11.2. What is your problem with sax2 ? Can not find it?

Did you try any of my suggestions? IMHO that command line hiccup you had was because you skimmed my post, as opposed to reading it.

I am running 11.2 kde.

I did read your post and have tried several things already. When I run sax2 and try and save the conf it just doesnt work, I get an error. What if I delete all xorg.conf and run sax2.

Ok, tried several things … that is vague … I am trying to understand but you need to be specific. Did you try booting with no xorg.conf? Did you try creating an xorg.conf with the program ‘aticonfig --initial’ (when there is no previous xorg.conf in place) ?

If you run ‘sax2 -r -m 0=fglrx’ that should be the same as running sax2 with no xorg.conf as those arguments tell sax2 to ignore any xorg.conf.

yes I have done all that. I am not getting kde desktop effects.

To sum this up -

  1. when my board changed, i had no display
  2. i ran sax2 and got the display
  3. enabled ati repo and got the driver from there
  4. sax2 -r -m 0=fglrx &
  5. aticonfig --initial

need to know how to get 3d going.

i’m going to hang out with my mates for a while, will be back later.

You have a great vacation.

Good luck. I don’t think I can help anyway.

Note that running ‘aticonfig --initial’ will wipe out your setup from ‘sax2 -r -m 0=fglrx’.

Figured that already. I wish to enable 3D and desktop effects, if it isnt possible with ati ****; i will buy nVidia and install.

Re your PM

Hi Carl,

Hope you are having a great Sunday. I have changed my mainboard and got a new onboard graphics card, I cant get 3d desktop effects to work with ati radeon. Have made a thread at No kdm on suse 11.2 after change of mainboard, if you can could you please take a look and tell me whats wrong with it.




What is sysinfo:/ showing about your driver

I can tell you, that in most cases, you will get a much better experience from a card rather than on-board. nvivda is always my choice, but others may differ in opinion.

It sounds like you have the driver installed, but what exactly happens when you try to enable effects?


Sorry I was away making breakie and couldnt revert promptly. OpenGL is not supported by ATI and there is no 3d support for their driver. I got 2d working thought (I can play The Simpsons only). I have tried various options but no luck so far. When i try to enable desktop effects I get a notice that unable to enable desktop cube animation. I understand that suse has developed a driver for ati (radeonhd) and will like to use that instead of radeon propriety. I am unable to find that rpm for 11.2.

Thanks & happy Sundays.

Check here
Index of /repositories/X11:/XOrg/openSUSE_11.2