No KDE after motherboard, memory and Motherboard change

Greetings !!

I had last week a catastrophy: motherboard or processor dead (no other motherboard nore other AMD FX to diagnose).
In the urgency I changed the whole set: motherboard and processor.

I kept the RX550 and that’s all.

At boot, Linux seems to work but no ip address, no network, and no KDE.
I got lot of ACPI error messages at boot.

Linux works in runlevel 3 without any problem but I would like to run KDE again ^^

I use the amdgpu-pro proprietary driver for the RX550.
Looking at the logs Xorg.0.log the last message is “no screen found”.

The network issue can’t be resolved, I don’t know why this is a realtek but I don’t know the chipset (lspci gives RTL8111 but this is the driver choosen, I will look at BIOS in the B550 asrock it is rtl8111h)
I need help here for different reasons:

  • I read in different articles that some BIOS may be updated in order to be fully supported by the kernel -> I’m using a Ryzen 7 processor.
    Do you confirm that Ryzen 7 could be supported by this kernel ? (4.12.14)
  • I need steps in order to set KDE back.

Concerning the dual boot with windows 7, this one is completly dead, it reboots at windows boot even in “secure mode”.
Do you think it is better to backup linux system personnal settings then reinstall windows 7, then reinstall linux as new ?

Or there is a way to prevent windows 7 to “loop in boot” ^^ (I think the reinstall as new would be better but i’m not sure)

Thank you for the time lost reading ^^

Ok, after a reading, I’m forced to install windows 10 on this computer (I’m very very upset but this is it :{ )

Question: I remember been forced to set some instructions (can’'t remember which) to tell win7 to DO NOT TOUCH the linux partition in case of dual boot.
Is this the same with windows 10 ?

****ing microsoft vampires !!

Not had any issues with winX on the dual boot laptops here with UEFI…

[LEFT] Hello,

I have a Ryzen CPU and a B550 motherboard (MSI Tomahawk). And the same GPU - RX550.
Here everything is working fine with TW and kernel 5.8.7 (also another PC with MSI B450 Tomahawk MAX is fine).
I have the same ethernet chipset (RTL8111h).

There are some error messages

common_interrupt: 1.55 No irq handler for vector 
 common_interrupt: 2.55 No irq handler for vector 
 common_interrupt: 3.55 No irq handler for vector 
 common_interrupt: 4.55 No irq handler for vector 

Look at this thread
I have the last BIOS but this problem was not solved.
From what I read I understand that the message would be harmless.

For Ryzen and B550 I would recommend a newer kernel (and TW).


I can not retreive the command to let windows do not touch GRUB :{

bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi

Is this command still valid on windows 10 to avoid GRUB to get ********** up in a dual boot environment ?

Now I will try it to see if it works ^^

still no kde :{
wait for a while the time I get the boot log…

here is the log…

    11.292] (II) AMDGPU: Driver for AMD Radeon:
    All GPUs supported by the amdgpu kernel driver
    11.313] (II) AMDGPU(G0): [KMS] Kernel modesetting enabled.
    11.326] (EE) No devices detected.
    11.326] (EE) 
Fatal server error:
    11.326] (EE) no screens found(EE) 
    11.326] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
    11.326] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    11.326] (EE) 
    11.350] (EE) Server terminated with error (1). Closing log file.

Can you show us what is in your


you may want to try the following too:

  1. Delete/move the contents of /etc/X11/xorg.conf.d/ by typing in
su -
mkdir -p /etc/X11/xorg.conf.d_back/
mv /etc/X11/xorg.conf.d/* /etc/X11/xorg.conf.d_back/
  1. Recompile the kernel
su -
  1. reboot, or try to start the Xserver

Uninstall and lock xf86-video-ati package and see if that helps, if not try adding the boot option (linuxefi line) amdgpu.dc=0 either at boot or via yast bootloader (the ncurses version).

If you log into a Virtual Terminal (VT – tty1 through tty6 – <Ctrl-Alt-F1> … <Ctrl-Alt-F6>) as the user “root” and from the CLI execute “yast2”, in the Network section, is the Network Interface enabled and configured?

The Leap 15.1 Kernel has support for AMD Ryzen 7 CPUs – the Linux Kernel as such, has supported the AMD Ryzen 7 since version 4.10 – March 2017 …

LEAP 15.2 has runlevel 5, network and works good
the fact windows 10 won’t boot is another issue