no internet

Hi, I’m new to suse. I installed 11.1 a couple days ago. I’ve used debian and kubuntu before, and I want to try something new.

The problem is I have no internet. I’ve messed around in the network settings in yast, and followed stuff I’ve googled. However, nothing has worked yet. I’d really appreciate some help.

I’m on my windows install now, but I can switch to get info I might need.

You didn’t say if you were using gnome or kde. Also need to know if you have a router or not. Dialup Modem, DSL Modem, Cable Modem? Ethernet or USB?

I am having similar problem. I am new to SUSE 11.0 I am using new PC I have built. I had XP on machine and connected to internet no problem. I have stand alone PC using modem. I went in and set up modem. Since PeoplePC is not listed as ISP I added and put in phone number, but nothing seems to happen. I am sure I am missing something and once I do X,Y, and Z it will work fine. Is there a way I can load the PeoplePC software so I can connect to my ISP?

Please say what type of connection are u using wired or wireless.?

I use kde, netgear router, cable modem, wired, and ethernet.

braelin, are you using DHCP?
If you check for an IP Address in a shell with “ifconfig” have you successfully received an IP Address from your router? Are you able to ping your router? What hardware are you using (PC, NIC)?
As a test, can you try configuring your machine with a static address / default route as well as statically defining your ISP’s DNS IP address/es and see if that makes any difference.

Yes. I’m using DCHP. When I used ifconfig I got two paragraphs.
looked like thing I’m putting on the bottom with eth0.(not mine) when I looked I couldn’t really find anything about an ip address. Not sure what you mean by PC and NIC. I tried some manual stuff, but it didn’t work. I might have been doing something wrong though.

“THIS IS NOT MINE” just an example I found cause I can’t put mine here from suse and I’m lazy.
Link encap:Ethernet HWaddr 00:0C:20:5D:C6:E3
RX packets:0 error:0 droped:0 overruns:0 frame:0
TX pactkets:0 errors:0 dropped:0 overruns:0 carrier:0
collicsion:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
itnerrupt:16 Base address:0x2024

Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:42 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:- txqueuelen:0
RX bytes:2708 (2.6 Kb) TX bytes:2708 (2.6 Kb)

It would be useful to have the output of ifconfig from your Suse installation.

If the illustration you provided is just like yours, then you’re not getting an IP address via DHCP (look at the listing for eth0, there’s no IP in there).

Ok. I got my ifconfig moved from suse to windows.

eth0 Link encap:Ethernet HWaddr 00:50:F2:7A:AA:ED
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:60 (60.0 b) TX bytes:342 (342.0 b)
Interrupt:17 Base address:0xc000

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:700 (700.0 b) TX bytes:700 (700.0 b)

I just tried the suse livecd on my brother’s computer, and it’s working fine. Does this mean it has to do with my ethernet card?


Try this…

[your root password]
ifdown eth0
ifup eth0

Your first paragraph should include an address from your DHCP.

If “ifdown” returns an error, then you need to open up the following location and check the radio button to use “Traditional ifdown”

YAST > Network Devices > Network Settings > General tab

If you get lost with all that, try re-booting, it’ll do the same thing but takes a while longer…

I tried ifdown and there wasn’t an error, but when I did ifup it didnt give me an ip still. I’ve been doing a lot of rebooting and this hasn’t fixed it.

what I type

: what it returns.

ifdown eth0

:eth0 device: Microsoft Corporation Device 0002 (rev 11)

ifup eth0

:eth0 device: Microsoft Corporation Device 0002 (rev 11)
Starting DHCP Client Daemon on eth0… . . . . . . . . . . . . . . . . no IP address yet… backgrounding.


You likely have a fundamental DHCP or network connectivity issue…

Verify your DHCP server is indeed issueing addresses. For that to succeed,

  • You need to have a good network connection. If wired, verify NIC lights are lit and flashing (which indicates activity). If wireless, you need to configure SSID/Password and verify good wireless connection before DHCP is the next step.

  • You need to to enable broadcasts between your PC and the DHCP server. Initially, drop all firewalls if you can do so safely or know how to configure your firewalls properly. Minimize network switches between the DHCP server and your PC.

  • You need to have a working DHCP Server. Are you picking up a public IP address from your ISP, a private address from your router, or are you setting up your own other DHCP Server?

  • If you have another known good machine which can be used for testing, it can narrow down possibilities. If you don’t have a known good machine, know what subnet your Gateway supports and configure a Static Address, even if temporarily… That will tell you whether the problem is a DHCP or basic network connectivity issue.


I tried out a different ethernet card on my computer and it worked. Then when I put the other one back it stopped again. Is there a way I can get mine to work? It works on windows, and I think kubuntu worked. so it isn’t broken. Probably just not linux friendly. Maybe I just need to find some drivers?

This is it.
Microsoft(R) PCI Adapter MN-130

Doing a bit of a search on the web came up with this posting, albeit it is a little dated and things could have changed.
Using a Microsoft MN-130 PCI Adapter on Linux -

Reading through through the posting it looks like Microsoft was playing tricks by making it “Microsoft” branded. The card looks like it takes a Tulip driver (well supported since goodness-knows when under Linux) but you have to modify source in order for the network setup to detect the card. Now, if you aren’t into modifying source (and most people aren’t) and re-compiling the driver for every kernel update, etc. that happens, then I would highly recommend going out and buying a Realtek based gigabit network card. They are dead cheap (you can pick them up for ~£8 in the UK at a computer fair or on eBay) and it will save you a LOT of trouble in the long term. Also, you can’t beat gigabit over the 100BaseT that the Microsoft card supports. And, yes, Realtek cards have great support under Windows, etc. as well.

If you want to spend a bit more then an Intel GigaExpress card is also good but make sure you get the right kernel revision (the problem should be fixed under the release version of OpenSuSE 11.1). If you search through the OpenSuSE website there is coverage for these cards as well (recently a bit hiccup with the drivers under certain kernel revs. :slight_smile: