No internet connection

OpenSUSE 12.2
Virtualbox 4.2.4

Hi there!

I have a problem connecting my virtualdisks (*.vdi) to the internet. In the network settings of Virtualbox4.2.4 I have already tried out “Bridged Adapter” or “NAT”,using the eth0 or wlan0 functions, but nothing works.

The funny thing is that I use the samevirtual disks on an Ubuntu PC with the same Network settings (BridgedAdapter and eth0) and there it works perfectly. The only differenceis that the Ubuntu PC is wired and my openSUSE laptop is wireless.

Any idea what I can do?

Firewall issue?

Hi Knurpth!

Firewall? Maybe. How can I find and solve it out? I never had to configure the firewall…

Learning by doing :wink:

On 12/10/2012 09:36 AM, dank245 wrote:
>
> Hi Knurpth!
>
> Firewall? Maybe. How can I find and solve it out? I never had to
> configure the firewall…
>
> Learning by doing :wink:

Step 1 is to use YaST to turn it off. If that changes the symptoms, then you
know where the problem lies.

The firewall in any guest is unlikely to block simple network access. Try the
host first.

Hi,

I just switched off the firewall and started Virtualbox, but I still don’t get through to the internet.

I use two different images (Win 7 and an openSUSE test environment) and both of them have no connection. It seems pretty much a host problem, but to be honest, I don’t know anymore where to search within the Virtualbox settings. I tried a lot of different network adjustments but nothing works and as I said, using the very same network settings that I use on my Ubuntu PC successfully do not work out on my openSUSE laptop. It’s weird.

On 12/11/2012 04:56 AM, dank245 wrote:
>
> Hi,
>
> I just switched off the firewall and started Virtualbox, but I still
> don’t get through to the internet.
>
> I use two different images (Win 7 and an openSUSE test environment) and
> both of them have no connection. It seems pretty much a host problem,
> but to be honest, I don’t know anymore where to search within the
> Virtualbox settings. I tried a lot of different network adjustments but
> nothing works and as I said, using the very same network settings that I
> use on my Ubuntu PC successfully do not work out on my openSUSE laptop.
> It’s weird.

I have no idea why you are having such trouble. I use both openSUSE and Windows
XP in VMs with openSUSE 12.2 as host. The network settings for each of the VMs are:

openSUSE: Adapter: Intel PRO/1000 MT Desktop (NAT)
Windows: Adapter: PCnet-FAST III (NAT)

I also successfully tested an openSUSE 12.3-M1 guest in Bridged mode.

I am using VB 4.2.4 obtained from the VirtualBox web site, not the one in an oS
repo.

OK, solved out! There must have been a problem with gcc, make and kernel-devel. It’s working propperly, now.