No Internet and Random Password Dialogs on new install on new laptop -- 12.1

I am new to openSUSE, and I’m nowhere near a Linux guru, but I can find my way around the command line with a little effort. I bought a new laptop about a month ago, and, being bored with the Linux distros I’d been using in the past, I decided to try openSUSE. I love it. My favorite distro yet. Except that I can’t get online, and random password dialogs keep opening with apparently no cause. One of the dialogs say that my password is required to refresh the system. This one comes up two or three times an hour. Sometimes I give it my password, sometimes I don’t. It just keeps coming back. Another is my XMarks login dialog, which I realise isn’t an openSUSE product, but given the other one, I think they might be related.

As to getting online, the wireless manager shows that I’m connected to the router, and ifconfig shows an IP address in the right range, but I am unable to view any web pages or ping any host, either on my own network or on the wider Internet. This same laptop is set up to dual boot with Windows 7, and that connects just fine, as does my wife’s laptop, exact same model, bought at the same time, running Linux Mint.

If these need to be treated as two separate issues, I’ll be happy to make another post, but I thought I’d include both in a single post in case they might somehow be connected. I don’t see how they might be, but there’s a LOT I don’t know.

The laptop is an HP 2000 Notebook PC, Broadcom 4313 Wireless adapter, using the STA drivers

Is anyone able to point me in the right direction here?

What desktop are you using? If KDE, you need to use KWalletManager and KNetworkManager. Often, you must start up with a Wired connection, to get all of the required files installed. By STA, you are compiling your own drivers? These must be reloaded for each kernel update that you perform. After the initial openSUSE 12.1 installation, the kernel will be updated from the default. You need to install the kernel source files and basic development files to make all of that work.

Thank You,

Thanks for the quick response! I am using KDE, and I’m using the KNetworkManager and the KWallet. I had to go double check that, but I am using those. Knetwork manager shows a connection to the network. I tried recompiling the drivers this morning (I download them from the Broadcom site), but that didn’t help.

Interestingly, my wife did a reinstall of Mint to resolve a video issue she was having, and now she also cannot connect. In her case, the drivers came with the OS as proprietay drivers. She had a connection after the install, and was able to update her system and get online, but this morning, she cannot. I wonder if there’s maybe a problem with the proprietary drivers? I’ve searched for an alternative driver, but can’t seem to find one.

I feel silly. Turns out my wife moved the router, and that caused some interference. I was able to connect to wireless in the room where the router was. I put it back where it belonged, and the problem was solved. But thank you for your help!

Now, to deal with the random dialogs. But perhaps in a separate post.

Well at least one problem down. Its OK to start a new thread if you like on the single problem. As for the router, not sure where it sits, but I opted to place mine on the wall, as high as I could mount it. It works better for all rooms, not sitting on your desk in the way and its not as likely to get moved somewhere else when you are not looking.

Thank You,