No Internet after install of 11.4 Network connections fine

I have no Internet Access with Firefox

I first tried an upgrade from 11.3 to 11.4 and lost Internet Access, so i re-loaded 11.4 from scratch on clean partitions.
I am connected to my wireless WPA2/PSK connection, have an IP, am able to see the network.
I turned off and disabled the SUSE firewall
I tried setting Firefox proxy settings to auto and to none, i dont use proxy.
I am currently posting this through an SSH connection to my 11.1 server from the new install of 11.4 on a Dell latitude D600 laptop (not using the on-board Broadcomm that is an issue for a later date).
I am running out of ideas anyone got a clue.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Post the output of the following commands from your 11.1 and 11.4 systems
(and mark which one is which):

ip addr
ip route
ip -s link
grep ‘^^#]’ /etc/resolv.conf #get uncommented lines from /etc/resolv.conf

My guess is that you are missing a default route, or perhaps a DNS server
that works, but so far there isn’t much more to go on. These commands
should give some good information; the firewall should be left on and that
is almost certainly irrelevant to your symptom.

Good luck.

On 03/12/2011 10:36 AM, mannycaz21 wrote:
>
> I have no Internet Access with Firefox
>
> I first tried an upgrade from 11.3 to 11.4 and lost Internet Access, so
> i re-loaded 11.4 from scratch on clean partitions.
> I am connected to my wireless WPA2/PSK connection, have an IP, am able
> to see the network.
> I turned off and disabled the SUSE firewall
> I tried setting Firefox proxy settings to auto and to none, i dont use
> proxy.
> I am currently posting this through an SSH connection to my 11.1 server
> from the new install of 11.4 on a Dell latitude D600 laptop (not using
> the on-board Broadcomm that is an issue for a later date).
> I am running out of ideas anyone got a clue.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNe7/vAAoJEF+XTK08PnB5KSQP/2/xo9S2Dlg4WUzJ170sXU2N
Zfs/EVLwh7ikIZz1sJgLTxKlxCZIlOjsCy3BBLOcaGb14fYa1ZiuIKr+YK4zfOr1
It2Hn6lnVzkctJi/Cx83729Q2TeRFXyFv6MYh0VMiZERICz5cGiRbfvoMxkrSOEo
JjTxfNSvQ5OLasADcxq9aeNMvjkuiJIFI2TtjGIIX9R8pfiZhAP2Pk2QABObPED1
Gy7AKPxDedRNnhuaTKv46jV4t6xRHno00FelzdKY4NF/fE6mG3Pd5cAU1MNDJ0sT
t1vBiRJgQlbxgs4A029vsJ4oCbTW47gUc74ILdD9IlkZbBuRT7BXsnxHehNExPhc
acffA5srkTwjbKe7MTox/AklxSQVS7QT+9MTYyjJGIyNbQKpih8nz9QUsqch3caM
5488S1bdtB0sHymXaW+9lVANpgefdulX4Qwa26OQRHe3S8ywNIYNwUiuXbL0N8r7
5nqniKp1n11IyJhBw1p4/qaNtiDy1yzURHHqsqnrpqcbKp+2fSal/Cy9Gwag65kt
DHClt15cwyvACS66oxRF6c/hxeI2BjgCr2VISuU83FRi8qvQmwfkM7nes/Sr1/lF
HVx20pEOt3eyx4ZHMgDrDRSein7bt2pSaLySyWaezfnJPJZfMDBRUEd+6/096ASA
fDgzZW69dXYeT/FSxmD8
=Gh7b
-----END PGP SIGNATURE-----

On 03/12/2011 07:48 PM, ab wrote:
>
> grep ‘^^#]’ /etc/resolv.conf #get uncommented lines from /etc/resolv.conf
>

ok! i like that one a LOT…it is going into my bag of tricks…do i
need to give a creator note to you each time i use it?


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

I am having a very similar problem, and I am inclined to think is exact same problem.

My internet connection fails to navigate through firefox. It seems to be a DNS problem, but
$ cat /etc/resolv.conf
appears to be correctly set up to openDNS nameservers.
$ ping google.com #and
$ ping localhost
all work normally, and packets start transmitting right away

I also have an IP assigned. In addition

route -n

also shows a gateway properly assigned for eth0.
My natural conclusion is that I have internet ready to go. BUT

“$ wget http://www.google.com
is unable to resolve (?)
and consequently, anything else but ping, is unable to resolve addresses. That includes firefox, and also includes inability to connect to repositories to install my broadcom drivers.

I am stuck and very bewilder as well.

(PS: openSUSE 11.3 had internet with my settings working just fine!)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

DenverD: I appreciate the compliment, but I’m pretty sure that, though I
tested and came up with this syntax just now, the idea was stolen from
somebody else doing the same thing. Yeah, it’s a neat trick… thanks to
whomever originally came up with it. Hopefully the Patent and Trademark
Office isn’t clueless enough to give me a patent on it but then again… :wink:

iahern, this is a good bit of information. A ping test confirms the IP
layer is working, and since you used a DNS name that implies everything
for DNS is working. My next recommendation is twofold: first, disable
IPv6 from within Yast:

sudo /sbin/yast lan

Reboot (you must I believe) to apply this setting as it’s a kernel-level
setting. See if that helps. We’ve had threads in the past that cover
this and I have yet to fully understand it. Other workarounds for
specific applications (Firefox included) involve disabling
DNSv6-resolution which you can do and that may be a good test to avoid
rebooting in the short term (though it’s application-specific so in the
long-term disabling IPv6, unless it actually works on your network through
to the Internet, is likely better). In Firefox use about:config and look
for ‘dns’ (the ‘filter’ field is great for this type of thing) and set
net.dns.disableIPv6 to true (not the default) and test Firefox again. If
it helps then that’s definitely the issue and disabling it system-wide
will probably help everything else like wget.

Good luck.

On 03/12/2011 01:36 PM, iahern wrote:
>
> I am having a very similar problem, and I am inclined to think is exact
> same problem.
>
> My internet connection fails to navigate through firefox. It seems to
> be a DNS problem, but
> $ cat /etc/resolv.conf
> appears to be correctly set up to openDNS nameservers.
> $ ping google.com #and
> $ ping localhost
> all work normally, and packets start transmitting right away
>
> I also have an IP assigned. In addition
> # route -n
> also shows a gateway properly assigned for eth0.
> My natural conclusion is that I have internet ready to go. BUT
>
> “$ wget http://www.google.com
> is unable to resolve (?)
> and consequently, anything else but ping, is unable to resolve
> addresses. That includes firefox, and also includes inability to connect
> to repositories to install my broadcom drivers.
>
> I am stuck and very bewilder as well.
>
> (PS: openSUSE 11.3 had internet with my settings working just fine!)
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNe+PdAAoJEF+XTK08PnB5us4QALl8Cb8tXVayi/i60MlzvvqM
Itj/uzBi5LDVcY+d18Hu+pj1ZIrS8t8o5RO+h+qlqernnReFDO5rWc5Zhpqpkgv/
EN8ubP9Jbg+DE2k2hYN4a/ODRyuEwmnridf1p5BLbMYPyKW522Dk63R936zVdzyW
gU/IVlF+XFl0WO7quVe000h3FHMcSfReptp32j9JdIPOypnR7dXvc+u5sw/fe5/U
IA+FTHCCQmrdh8wxxBJa0J3c+aLPuIRwapn0eur0ULOrIMtlkCuhoj+1UXXdaKTZ
ZL/u8TgCssc9U3IQR4e0hONLeRQ+L4aEWBePtPcoZxm5JFJ8nXolz2LhLngsFA95
GKxuJ1Zk9d/vZ3Tqys6KRkV7gyRi6KHNd+tGJ77sECE8X4W75iDipTfJ5GykMcDH
rvavu+fS10IQLrUXgRXwGIVls37dhBm1QvpR4dRI30tBDhvu/x7zDLoN91hps5EF
VGYqp3j1fFB0xL/oJ91Bz8gDPXmNRF0CC/rW8I5wzyxKTbpw3XizKMjgaQr4v3fu
Z6na+opOQKhnzpZWAr+aYNGRkcyWRL/z27Av/uhagfwyW39iyo0THAEv/PkKJiOh
55urf2F2HFBcMfWT+Mldi33Hk/yiw48XFXov0cBjg0SjVaU2bq92OCNIszC+JU4I
zqXgwwqbTl+e54woFU1t
=EL8L
-----END PGP SIGNATURE-----

Hi ab. Thanks for your reply!

Quite amazingly, setting the dns.ipv6 disabled got my firefox going, and now I can post from my shining 11.4 :wink:

ping still works, naturally.

Nonetheless, I found very intriguing that I have (and had had) unchecked the “enable IPv6” case in Yast Network settings. I assume that is how it is system wide disabled, and I had rebooted. Yet, just to give some examples, wget, thunderbird, or yast seems still unable to resolve (to install software). I assume I do not have a clear idea of where to disable IPv6 systemwide in a proper manner.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

My wires were crossed it seems… I’ve seen this before as well but far
less often. If you are able to test your machine on another network in
its current state that would be interesting.

Why does it do this? There a couple nuances that you’ll likely see in
your LAN trace causing this and I’m afraid I do not yet fully understand
the “why” behind it. Your system likely does not have anything bound as
far as IPv6 is concerned (the ip addr command output requested
previously would confirm that). IP happens at the third layer of the OSI
model and within that you have things like TCP (handles getting data to
the right port on a given system) and a another layer (seven) you have
things like DNS. Because of this layered model there is a lot of flexibility.

Anyway, it’s possible (and not even uncommon) to have DNSv6 requests
(AAAA) within IPv4 packets. Normally one may think that DNSv6 requests
would only be within IPv6 packets but that is just not the case because of
the layers in the model. What I have seen in rare cases (one network out
of dozens, but reproducible there) is that the DNSv6 responses for a site
will come back first (faster than the DNSv4 (A) request’s responses) and
then what I THINK happens is that the application gets confused because it
can’t get to the IPv6 address at all. I also seem to recall seeing where
the responses came back empty and that would throw off the application.
It seems that some applications do not rule out DNSv6 requests and in some
environments that wreaks havoc. Again, I don’t completely understand it,
but I’ve seen it and worked around it like you did. What’s interesting is
that some applications work while others do not so I suspect that some
applications may go through a system service or use a system setting
(somehow… no idea) for things like DNS resolution (I believe nscd is
involved in this on Linux) while others do not. In my testing when I saw
this one another browser didn’t work, and another did. I don’t remember
which did and didn’t but I was testing w/Opera and Chrome. Anyway,
interesting.

Good luck.

On 03/12/2011 03:36 PM, iahern wrote:
>
> Hi ab. Thanks for your reply!
>
> Quite amazingly, setting the dns.ipv6 disabled got my firefox going,
> and now I can post from my shining 11.4 :wink:
>
> ping still works, naturally.
>
> Nonetheless, I found very intriguing that I have (and had had)
> unchecked the “enable IPv6” case in Yast Network settings. I assume that
> is how it is system wide disabled, and I had rebooted. Yet, just to give
> some examples, wget, thunderbird, or yast seems still unable to resolve
> (to install software). I assume I do not have a clear idea of where to
> disable IPv6 systemwide in a proper manner.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNfDZnAAoJEF+XTK08PnB5W60P/RhZm2TyIHLv8GPqCuTYiRkc
4cs9/rfgkvx3/szFXHpsKD0kBfpXSjhXVg2+4lBJwEWrJ9OVjnBTcfhr2bHZIfTK
ZIDsCcKMhcVyaCYFn2FRCyxNx41+K8kt1jd3T/uRs7JRXGS/zcR0yp90VVwlO0FF
wXJZV6d+xVOo3ZnANx+oDBLPuHJHqiQ2qUh2puYtOsYJfnG/EG/LsaGp2HL3LHJ9
YWhQdkm8mxoRNdcqzj1JfSJIgl8sIv/oH9WQgMFRnDmfxLcEq+AQxHNajrUioCsh
DXMzS2EKS1071WmtQ+lyARRvmbzY1aCsxfAy73paCh2pXp2zWUF3lOcNYlEWSqvc
c9pgOurefqFI0oQ3+rIQ81/ejOp3AWk5ZTqXeFb50nrgXB5PeXgM6MzvbMfgGgf1
OskKkAg+sK9P18iIxMN5Yk0h14hhjypHOpmQgafYFbJbDHG0dxm2wRZA3bE9uCYT
ZQjRHc9e1gtigkSd4hw4PrWjHbyllv8fD19/nOxrwIwR0IeKV0drOj4trebW0CdC
CwD+G1TXm8W32T45NHfZ1H2qz6XG3VbKTI8/Z/9Kz4riCWY89xH9oriylUX/J5lF
F92+h66btjuRya8R+4pNclt+eOW59PfrqFRUETqUpvuGHy6l7nItKL+AFwC3GToQ
Db//07mNKtsBQ9fx+ush
=Kjng
-----END PGP SIGNATURE-----

ab
right on target.
besides the difference that 11.1 was hardwired and 11.4 was wireless all the responces were identical except that 11.4 is not accepting the default gateway from dhcp
I can post them if you want.
I added the default gatway from the command line and i am posting this from 11.4 now.
this is not the fix but it is verification of the problem.

My Router is a Cisco/Linksys E2000 dual band N firmware version 1.0.04 wich is current.
the wireless card is AR2413 802.11bg NIC (PCMCIA)
DHCP has no problems for wireless to win XP (caugh caugh my wifes) win7 (my sons) my SUSE 11.1 and my old 11.3 wireless and hardwired.
Only when I upgraded to 11.4 did the problem start.
Also i set the DHCP network setting to IPV4 only in the beginning and verified it is still set this way.
What next I will try to connect via hardwire tomorrow and will post the findings.

Solution

When I went to check the Hardwire connection i went in connection manager to change eth0 to start on cable connect and i saw the the DHCP setting was set to both IPV4 and 6.
I reset it to IPV 4 only and finished the connection. When it finished eth0 connected correctly, the default gateway was there.
i removed it and went back to the wireless connection and the default gateway was there too. I shut down and restarted several times and it worked correctly every time.

Therefore make sure all netwok connections that are present active or not must be set to DHCP IPV4 only, this worked for me.

I’ve just bookmarked this thread :slight_smile: thanks for the read all it’s been very interesting.

Best regards,
Greg

I wanted to confirm that disabling the IPV6 via Yast solved the exact same problem on my virtual machine (VMWare Fusion) on my clean install of 11.4 (KDE) this morning. The icon in the panel still says ‘no network connection’ but I am online and able to use Firefox and get updates from the repos.

Thanks for posting answers to this problem!

dZfox

Hi all.

I am very happy to hear others succeeded disabling ipv6. And firstly, I want to thank everyone here giving me a hand in this helpless situation.

I am describing my situation below:

  1. Current Yast configuration
    – Global options
    x traditional method with if up
    0 Enable IPv6
    Hostname to Send = AUTO
    x Change default Route via DHCP
    – Overview
    wlan0; IP address assigned using DHCP4
    eth0; IP address asigned using DHCP4
    (my wlan broadcom does not detect signals, I assume requires a driver update, as in previous opensuse versions. Not the current problem)
    – Hostname/ DNS
    Modify DNS = use default policy
    Name servers to openDNS
    x Assign hostname to loopback IP
    – Routing : All unset

  2. Ping testing
    $ ping google.com
    google.com ping statistics —
    3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    rtt min/avg/max/mdev = 23.106/23.930/24.433/0.
    $ ping localhost
    — localhost ping statistics —
    3 packets transmitted, 3 received, 0% packet loss, time 2000ms
    rtt min/avg/max/mdev = 0.069/0.098/0.148/0.036
    :slight_smile: ]
    “$ wget http://www.google.com
    asking libproxy about url ‘http://www.google.com/
    libproxy suggest to use ‘direct://’
    “–2011-03-13 11:52:47-- http://www.google.com
    “Resolving http://www.google.com … failed: Name or service not known.”
    "wget: unable to resolve host address “www.google.com” "
    :expressionless: ]
    “$ wget http://74.125.224.176
    “Connecting to 74.125.224.176:80… connected.”
    HTTP request sent, awaiting response… 200 OK
    Length: unspecified [text/html]
    Saving to: “index.html”

           it looks to me a resolving issue. I guess ] 
    
  3. Browsers test
    I currently have konqueror and firefox. Tipically, I use firefox.
    –konqueror is working fine :slight_smile:
    –firefox
    A: disable dns ipv6 = true. Firefox browses fine
    B: disable dns ipv6 = false. Firefox shows “page not found” 100% of the time

(By yast settings above, ipv6 should be disable already — I am bewilder here!!, yet I assume I fail disabling ipv6 some misterious how.
I’ve tried some /etc/modprobe/99-ipv6.conf scripting with no better success so far)

  1. Checking settings
    $ cat /etc/resolv.conf
    it has my searchname and nameserver to openDNS. seems fine to me ]
    $ su -c ’ route -n’
    I have a normal looking table. with lo and eth0. I have gateway with eth0 set up.
    $ su -c ‘ifconfig -a’
    Importantly here, I only have on eth0 one inet addr, but not a ipv6 inet address. Very normal looking too.

  2. Other internet uses:
    Everything else I have tried so far is not resolving. That includes
    repositories and yast install-updates
    instant messenger
    email ; thunderbird

  3. Test my laptop in other networks seems very appealing, but no easy, nor practical, since this is my home machine and I’d love it working on my home network :{ (helpless feeling).
    as stated before, opensuse 11.3 networked just fine.

Lastly, I thank all people participating in this forum.
Best Regards

Please post the output of the /etc/sysctl.conf file to confirm that You’ve got ipv6 disabled. For me the output looks like this :

grzes@opensuse:/etc> cat /etc/sysctl.conf
# Disable response to broadcasts.
# You don't want yourself becoming a Smurf amplifier.
net.ipv4.icmp_echo_ignore_broadcasts = 1
# enable route verification on all interfaces
net.ipv4.conf.all.rp_filter = 1
# disable IPv6 completely
**# net.ipv6.conf.all.disable_ipv6 = 1**
# enable IPv6 forwarding
#net.ipv6.conf.all.forwarding = 1
# increase the number of possible inotify(7) watches
fs.inotify.max_user_watches = 65536
# avoid deleting secondary IPs on deleting the primary IP
net.ipv4.conf.default.promote_secondaries = 1
net.ipv4.conf.all.promote_secondaries = 1

I’ve got ipv6 enabled. The line in bold should be uncommented in your case.

Best regards,
Greg

Hi glistwan

my output does have the line uncommented. it reads as follow

$ cat /etc/sysctl.conf
# Disable response to broadcasts.
# You don't want yourself becoming a Smurf amplifier.
net.ipv4.icmp_echo_ignore_broadcasts = 1
# enable route verification on all interfaces
net.ipv4.conf.all.rp_filter = 1
# disable IPv6 completely
**net.ipv6.conf.all.disable_ipv6 = 1**
# enable IPv6 forwarding
#net.ipv6.conf.all.forwarding = 1
# increase the number of possible inotify(7) watches
fs.inotify.max_user_watches = 65536
# avoid deleting secondary IPs on deleting the primary IP
net.ipv4.conf.default.promote_secondaries = 1
net.ipv4.conf.all.promote_secondaries = 1
$

This looks as it should. The only thing I can think of is fire up wireshark and see what’s actually happening on your network connection when using Konqueror and what happens when for example You try to install the updates. Compare the outputs and maybe this will reveal what’s wrong.

Best regards,
Greg

Hi Greg

Thanks a lot. I used wireshark to figure out that in both cases, when my internet worked and when it did not worked, I had 2 rejections on DNS resolutions. Firefox after a third DNS instance started HTTP and TCP package transfer.

Curious about it, I rechecked my /etc/resolv.conf file to notice openDNS to be a 3rd nameserver, after two of which were likely provided frorm my ISP (go figure).
[which means that all the fuzz I created was largely my mistake, and I due apologies: I guess that is a good reason of why after more than 4 years of openSUSE usage, I still catalogue as a “puzzled penguin” :wink: ]

I switched the order as openDNS servernames 1 and 2 and kept one of the other servernames in a third position.

openSUSE seems to have liked that a lot (viva open. viva openSUSE. viva openDNS)

Thanks again, to everyone in this helpful community.
iahern.

PS: As a general conclusion, for everyone that seems to have lost internet browsing after update, as other previously here mentioned, try disabling IPv6 on yast, and retry after a reboot. If it works, I guess, it all is to blame on the ISPs.

Not sure if my problem is related, but I have just upgraded a laptop and home PC from 11.3 to 11.4 and both display same wireless connect problem. Both can ping any local device but nothing externally.

I rectified both problems by editing the Network Settings in YaST and specified the default IPv4 gateway, this despite having set my wireless devices to DHCP.

I guess it’s not related but You could try setting DHCPv4 instead of DHCP.

Best regards,
Greg

No joy. Tried setting Enabling/Disabling IPv6 and ‘DHCP Version 4 Only’. Same problem. Only defining the ‘Default IPv4 Gateway’ appears to fix the problem.

I would prefer to use WICD but I don’t find any version suitable for 11.4 yet.

Yebo

It appears to be a problem of a different nature given you can not ping outside sites.
Can you get onLine using a wired connection?

Do you know your wireless cards makes? try


$ su -c  lspci
$ su -c 'ifconfig -a'

to get further information on those cards.

In my case, a broadcom card required to install b43* using a wired connection before the wireless worked properly

Good luck. Keep us posted
iahern