No internet access

Hello all,

As you guessed I’m new to Linux, I installed opensuse 11.3 on a laptop along with windows xp. Everything went smooth but I cannot seem to access the internet. I beleive the Wireless and Lan are both connect successfully to my network as It shows IP adresses for both of them 192.168.2.102 Wlan and 192.168.2.103 for the LAN both say active and connected. but firefox and update application cannot get to the internet. I can access the internet if I boot to windows. I have not done anything except change from networkmanager to ifup and back again to try and resolve this. I have a wirless roughter and a DSL modem. thankyou for your help in advance.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Let’s get some network information, please, by posting the output of the
following commands:

ip addr
ip route
cat /etc/resolv.conf

Also, how are you testing your access to the Internet?

dig google.com
ping google.com
curl -v google.com

Good luck.

On 10/30/2010 03:06 PM, rpm429 wrote:
>
> Hello all,
>
> As you guessed I’m new to Linux, I installed opensuse 11.3 on a laptop
> along with windows xp. Everything went smooth but I cannot seem to
> access the internet. I beleive the Wireless and Lan are both connect
> successfully to my network as It shows IP adresses for both of them
> 192.168.2.102 Wlan and 192.168.2.103 for the LAN both say active and
> connected. but firefox and update application cannot get to the
> internet. I can access the internet if I boot to windows. I have not
> done anything except change from networkmanager to ifup and back again
> to try and resolve this. I have a wirless roughter and a DSL modem.
> thankyou for your help in advance.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMzIu1AAoJEF+XTK08PnB5u4UP/1QeCDSOfwS8AFWl+jETNYxe
6I4rO2f+blDHRFPIj05a75n0O7bIntk0EeIQX14J9EEUyKw6BEcL3uPQPp9JFmg1
kBuSraNYAtpQdH5YORyJVZW0n5Tvnyslw85uqk2gjXMGYNAXs2RYGKhxTWmtFK32
zKdW0qde/bIvDZZAzjAiL0Ev1skM2Ls4zz8ehxsmLk+7BgtQR7nDpfRM2KGZuxsH
BrJRxYNUWVhgfg57/qLObXx1qI5GcOk/Lr/eMLgUHUwvhBValojghfjLcbc8Hthu
iac+qhi5QlKGYhQHHfseFcs4AGjW/m1V4ZCgpyrV0SpOJDHuaPuAsCfwTvmPxIen
neUXGjH+IXbZGNkNhxbcIcElhDAw80qhsWthbl0JAueMCkem2p//sExnfrgpQCE/
KxA3P30GcZ9zhBiM83rP3oMtfnDslVrWUUTHim2pNDf7pa79OFHqQQuev1obVdYb
zLpBYoZnY94v3JwTUKBc3O4bMqjufaMZAIoBAiXdjdBoSnztIvYzq4IvfN9i3g/z
HSFT+3euTPPeIKhrj+tM0QDcQRSRmOb39rFmV28DaprM4RBkQVad5+IOdOWMUfvA
fOvAeUOfIvYHqbs4q6GhDyAQlBDNbhMz+2pOtKMXRTM82ao2oqtKZX+ML+XRHF2K
9QyLdItMWSp7A5XEuWW/
=Mfz/
-----END PGP SIGNATURE-----

Looks like a router is supplying IP addresses to the Network Interfaces via DHCP server in the router, beginning at address range …100 or so.

If two interfaces have IP addresses, often you must personally supply into the configuration the IP addresses of the Gateway (router IP probably 192.168.2.1 [or maybe …2.101]) and the Name Servers that translate the common language addresses (like google.com) to IP addresses (like 66.102.11.104). If you don’t know the IP addresses of the Name Servers you can use the freebies from google inc (8.8.8.8, 8.8.4.4). You’ll find spots for typing these addresses in your GUI configurator for the network.

Here is the info requested
home@linux-ijy7:~> ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 00:1b:fc:c6:48:8f brd ff:ff:ff:ff:ff:ff
inet 192.168.2.103/24 brd 192.168.2.255 scope global eth0
inet6 fe80::21b:fcff:fec6:488f/64 scope link
valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether 00:19:d2:3a:95:59 brd ff:ff:ff:ff:ff:ff
inet 192.168.2.102/24 brd 192.168.2.255 scope global wlan0
inet6 fe80::219:d2ff:fe3a:9559/64 scope link
valid_lft forever preferred_lft forever
4: pan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN
link/ether c6:09:43:48:66:a8 brd ff:ff:ff:ff:ff:ff
home@linux-ijy7:~> ip route
192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.103 metric 1
192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.102 metric 2
127.0.0.0/8 dev lo scope link
default via 192.168.2.1 dev eth0 proto static
home@linux-ijy7:~> cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search cfl.rr.com
nameserver 192.168.1.254
home@linux-ijy7:~>

The only way I have tested the connection is by opening firefox. or trying to run a update. I do have internet on the windows side of things. The local ip adress for the router is 192.168.2.1, and it is set to automatic DHCP with DHCP server enabled. all other machines through this router have access to the internet. Is there a similar command in linux to “ping” a website like you can in window cmd window?

Yes. Just use the ping command. For example:

ping google.com

Another thing to try is telnet:

telnet google.com 80

no success yet. still get Server not found from fire fox and also from the system update thing in the system tray. tried manual settings and DHCP.
telnet google.com 80 returned an server not found error

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

swerdna probably answered it best. Don’t be on the same network with two
IPs simultaneously. For now, disable your wireless to prevent confusion
on the system.

Also, with regard to the questions asked about pinging and answered by
ah7013, those were the other commands I posted previously.

Good luck.

On 10/30/2010 07:36 PM, ah7013 wrote:
>
> rpm429;2246334 Wrote:
>> The only way I have tested the connection is by opening firefox. or
>> triing to run a update. Is there a similar command in linux to “ping” a
>> website like you can in window cmd window?
>
> Yes. Just use the ping command. For example:
>
> Code:
> --------------------
> ping google.com
> --------------------
>
>
> Another thing to try is telnet:
>
> Code:
> --------------------
> telnet google.com 80
> --------------------
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMzNyrAAoJEF+XTK08PnB5QDIP/RL2FpiM9hyTInHfocLWxD+d
EloqgxShg01NyrqoZ851YLFBaMUWIbU7PwLNbzgwtw9Nl2csOoPfXe9ThLNRv5wp
wK+lNLGeK5jHnZ6NfkQW1NCbWLxh2l5XEollbHtKUoz58ml1CM2UAIpOtaff/aAM
tn2EhvUOxT23SvNuK6dzKgncTwqfpRpOoMMvGcANUQX3wSYsYnPud5lDNkxcMbKH
A+6E8k5kRMYnjf5gnWYcAU02/2vDTccel4Iekrrb4RfL6T5jNzzLdABg4/GpmnHq
PGFT96UuMyYt1yF8ChRohSX4g6Vt8mWlHkASGKyz3k6CwEUcRqhtZbRyzHNbiKsT
SnOqLHlH+bjlK28OMEmV8BOi+OVa16EQdgyPZALm1N/HJrplN6ZYLRx8Aq2POjhx
DVW78Nht2gHkg2XKJ2TsZQ4HUpfixQtLQ+ukPgb3SiViskusPk3Q2CgeWD0wCXm9
IksZIkuWn7H10jeRndVC00URed1Fk+F4EAEHzH9cfXiD837cl/rW2Yk0rfMFcGt1
4KHmTrBtQZ+cdj84CnE5SJolWTSI6DjFqMJ942XLRlTNtmLovvcXBSF9MNkt9bfq
ocus+KJ1YhBFKHV/A4ABnlxX7pGUNYMZ5oYUWS689/hydVwsER9DaPHyzN8tZJi2
IoJbKFaQ12ZkxLWLjOy5
=4ekQ
-----END PGP SIGNATURE-----

While several people are ddiscussiong with you how to identify and solve yourproblem, I want to suggest you something to make your posts better understandable for your readers.
Please use the Advanced button below and them when you have copied/pasted computer text in your post, select it and yout the # button in the toolbar. This will put CODE tags around your computer text and preserve all formatting. E.g:

boven:~ # cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search xs4all.nl
nameserver 194.109.6.66
nameserver 194.109.9.99
nameserver 194.109.104.104
boven:~ #

i hope you see the difference in the layout (not the contents!).

Thanks for all the replies. I’ll work on my posting skills as well. I diabled the WAN. Using the ping command to yahoo I got ttl=41 time=94.7ms. so it appears I can getout to the internet but not thought any other program.

On 10/31/2010 07:36 AM, rpm429 wrote:
>
> Thanks for all the replies. I’ll work on my posting skills as well. I
> diabled the WAN. Using the ping command to yahoo I got ttl=41
> time=94.7ms. so it appears I can getout to the internet but not thought
> any other program.

If ‘ping yahoo.com’ works, then name serving and routing are both functional.
The only other component that comes to mind is the firewall. If you disable it
with YaST, does the connection work?

Thank you for all your suggestions. I did get It to work by trying swerdna’s sugestion by enerting the Name Server as 8.8.8.8, I only found this setting in ifup. It took me a while to find were to enter it since I turned ifup off after i tried it once. If I use networkmanager I loose connection again, is there a way to enter Name server info also in network manager? Networkmanager seems easier to use.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

It could also be a DNS problem specific to an application, though I’ve yet
to find a satisfactory reason why that is the case even though I’ve seen
it with my own system in rare cases.

With Firefox type the following in the address bar:

about:config

Press [Enter] and then [Enter] again to acknowledge you’re about to enter
the advanced settings (don’t mess up from this point on or you’ll be
unhappy). In the Find field (where your cursor should be already) type
‘dns’ and look for the following entry:

network.dns.disableIPv6

Double-click on that entry to toggle it to true. Now close this tab or
even all of Firefox and try browsing again.

Good luck.

On 10/31/2010 09:49 AM, Larry Finger wrote:
> On 10/31/2010 07:36 AM, rpm429 wrote:
>>
>> Thanks for all the replies. I’ll work on my posting skills as well. I
>> diabled the WAN. Using the ping command to yahoo I got ttl=41
>> time=94.7ms. so it appears I can getout to the internet but not thought
>> any other program.
>
> If ‘ping yahoo.com’ works, then name serving and routing are both functional.
> The only other component that comes to mind is the firewall. If you disable it
> with YaST, does the connection work?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMzdoEAAoJEF+XTK08PnB5VrQQANLFnXc43VvDTSazgPPUfLMU
jGjdyCmFKU2F5GO4PdhLKBm7etJnXcS/MFBjiScQpQng+em1aGCTF6G9dtZu6ni4
qcZK4vzmQvDk/fLmD/58Ro0EUVa5ocG2TBoiXkP/K08kNayNUxiKsvn1Sz0ew5+v
oxvI4Oya0C384lMdmycApS71tcOtYjaEm6YDSaaFZ/xLzj9e5IWUb3QtzgEaPdzM
AZoKegYO/RlFsazLTXV3ircojo+H21PuygYfs+b2Q/0FInXt2xxZwbaBcIU+Z7ib
cKGRyPXGiWLNFcCYNVPZ8Rbf+1RZbnb5LbFcCEs7QUbCZ0rNC2V7T7lSmqL9k6ZW
9V2WABPWZQfJyJMHdWtBwB6QOhEq80WSdI9M9dkBP2GHeJzjS1LLSAjPOaORaxTx
bWPFjLPFfYPeviIUFBqg32zpiMDuQkK3dw8kIbWNo7jJ2gZMPdrW6+a/2pS7pISD
Rx+j/PzwxCWW8OoxtUjhqlYowsHpGcSzCwTbpMOzbHUBciI+GzORHM916Ei5Bcvj
13XrnMrga7s6UNAtFl8FS7y8deks87qky431JXrdoYojVIFOh+IUXHz3a8DUeH9M
BqkLBqRxHN7kZQh8Jt47Q+P07in4czxXPOseMzq4CEwVZzctXYtHulpX8/DmnZvP
3bPCWT/efDj889C8xDj2
=TDHs
-----END PGP SIGNATURE-----

Assuming KDE goto applet –> Manage connections –> Wired (or wireless, whichever you’re using) –> Edit –> I.P. Address –> DNS Servers

In the slot for DNS servers enter this (note the comma): 8.8.8.8, 8.8.4.4
In the slot for Gateway enter the gateway IP

I got it entered into the network manager and I works beautiful. Can you tell me why this setting is a manual entry? I have never had to enter it in windows or Ubuntu and had connection the first time. Not knocking opensuse just curious.

In my experience, I laways neeed to put in the Name Servers when I use a fixed IP address (or two active network interfaces). Also in the windows operating system IIRC although I’m much less familiar with that. But I can’t tell you why, don’t know enough about it.

I can only talk about the “traditional with ifup” way of live (and I assume that when you have a fixed IP,that is the best way to run your network interface). But logicaly the following also is true for a connection made by network manager.

When you have a fixed IP address, you also have to provide the default gateway and the DNS servers. Logical, How should the system know what they are?

When you use DHCP, it is rather normal that the DHCP server (often a modem from your provider) not only serves your system with an IP address (and netmask), but also with a default gateway address (their own address). They often give you also their own address as the DNS server (and then forward all DNS traffic somewhere). Or they may provide you with the DNS server of your ISP’s choice. But DHCP servers differ.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Exactly. I think there may be some confusion on how things are setup in
the environment. If using DHCP then the DHCP server should dish out a
gateway and DNS server(s) along with the IP and subnet mask. If that is
not happening then the DHCP side is broken. If, on the other hand, you
are statically assigning something (either via Traditional or Network
Manager) you, the user, must specify the other network settings. This is
the same with every OS because it’s how IP works (regardless of platform).
If another distribution of Linux “just works” without specifying things
manually then the issue should not be resolved in your setup by specifying
things manually. Until this thread came up I didn’t even know you could
set this kind of setting on your own via Network Manager because I never
do it (I click on the wireless network and I’m in and working without any
manual work). There are reasons things could be broken when DHCP is used
but we need to troubleshoot that to figure out what is happening
environment-specific in your setup.

Good luck.

On 11/02/2010 05:36 AM, hcvv wrote:
>
> I can only talk about the “traditional with ifup” way of live (and I
> assume that when you have a fixed IP,that is the best way to run your
> network interface). But logicaly the following also is true for a
> connection made by network manager.
>
> When you have a fixed IP address, you also have to provide the default
> gateway and the DNS servers. Logical, How should the system know what
> they are?
>
> When you use DHCP, it is rather normal that the DHCP server (often a
> modem from your provider) not only serves your system with an IP address
> (and netmask), but also with a default gateway address (their own
> address). They often give you also their own address as the DNS server
> (and then forward all DNS traffic somewhere). Or they may provide you
> with the DNS server of your ISP’s choice. But DHCP servers differ.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJM0CdiAAoJEF+XTK08PnB53FoP/3kaV69SYoyqOjZfkE3X5xBm
d3AohUeiWsn+5bTvrqplxPj6dQr6ekzwj8YTgYePLGc9s15VXX4F02dJyMPvy8xn
VzSWOp4Ce90/J1HFne1I/C3LC2CLvSMVVNaxZ46vibaxw/Hi5zhV8dgZwhD7SQRH
9yRn+vx7YYetBDMiZWoW5fayyYkyJoY0PDqCAWTJUJkLVuk9Bq4l6MOdDNsu6gsU
P+aS0J0krBhPPiJR8fSY3rTRtgRYQxgVn/6jubkeAq3dDt8JVtFYjlD3SyMa7VaQ
0fo7RKxd061SLixUhBBEz3sqkX0wIjvbbXEhleTscjnP7rGoBFcb/lqv6dkcBx1I
S5Z5l4JhkG7N79vyLya19zV26CvRSaBYr1inkv9Sh+1E85j5q52tBfypEPr2Jd+h
+LslzBdwtuQO6lFPStU02aUDIg1yG7lChnn5mQmHVmm7KpxXvdRsNQKQOWRZll9V
61foLnKXzzUwKlRr+WE/X187DjbHN6ANia1Puf6b6OEBP5MXCn0rwgG5inxUc5Ku
G959c+O4e7oEYGTp/IMGYcMxKDOWZwtAcUNIf1qHUm7gLFb/m4GDyWVznkhQqB9X
9XtAssjKaT4ybAfQ6p1bUj43OVuUxou+moMX6wxjvdLuHMpc2JxcIS73u1mjJTU4
sHH9sGAsSOcMIbBlybwx
=i8wj
-----END PGP SIGNATURE-----