No internet access


I’ve updated the laptop of a friend from Leap 42.1 to Leap 15. Wifi and wired connection are perfectly working with
my local network (
If I tried to connect to another network (wifi, wired), I get an ip adress but no internet access.

I really don’t know what is going wrong.

Somme help is welcome!

Some basic diagnostics first…

Check that a valid IP address is assigned

ip a

and that a default route exists

ip r

Can you ping a well-known internet IP address successfully?


then by hostname…


If it’s name resolution that’s failing, check

grep "name" /etc/resolv.conf

If no valid nameserver is present, do (as root)

netconfig -f update

and then check that DNS resolution is now working as expected.

See how that goes.

/etc/resolv.conf contains just one line:

Bur I’m conected with my smartphone and the ip is

Should In just delete the line?

Thanks a lot!

sudo netconfig -f update solved the problem.

Thanks a lot!

Glad to have been of assistance! :slight_smile: