No internet access with OpenSuse 11.1

Hi!

I am a new user of Linux OS! I just installed OpenSuse 11.1 and i don’t have an internet access at all!I did these tests and changes:
1)I configured Network Settings using each once “Network Setup Methods”:a)User Controlled with NetworkManage and b)ifup
and still nothing.

2)I disabled IPv6 Protocol,…nothing

3)I disabled firewall… still no luck

4)I run the code : rcnetwork restart -o nm and the following messages say that everything is “done” (with green colour)!

What’s wrong???
My router is ok and ihave access with windows OS!

My motherboard is ASUS P5N32 - SLI Premium with chipset nVidia MCP55.

Thanks!

Hi, a few questions:

  • What desktop environment are you using?

  • Are you able to connect with your router (in the manual there should be an address under which you can access the software menu of your router. Can you?

  • reactivate the firewall and make sure your network card is set to “external zone”.

  • did you check your router shows sync on adsl line? With other words, are you certain that your router is connected?

  • which program did you use to check for the connection?

It came to my mind. Open a terminal and issue:

cat /etc/resolv.conf 

What does that give?

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

You have a dns problem for what I see. It should look like this (or similar):

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search 192.168.1.1
nameserver 195.130.131.139,
nameserver 195.130.130.139

Try to do the following:
Open Yast, Goto the “system” tag, chose "editor for /etc/sysconfig
Goto “network” submenu “general” subsubmenu "dns-static-searchlist and join there the value 192.168.1.1

save it and restart the networkservices. Does it work now?
In alternative you can try the google public dns server for the value: 8.8.8.8 and 8.8.4.4
Please report if this was the problem.

I did what you said but when i entered “192.168.1.1” at Domain Search entry, an error message appeared which says:

"The search domain ‘192.168.1.1’ is invalid.
A valid domain name contains of componenets separated by dots.Each component contains letters,digits and hyphens. A hyphen may not start or end a component and the last component may not begin with a digit

Put in for netconfig dns policy:

STATIC_FALLBACK ppp* NetworkManager

Put in for netconfig dns forwarder (that should be already the case by default):

resolver

Put in for netconfig dns static searchlist:

8.8.8.8, 8.8.4.4, 192.168.1.1 

Put in for netconfig dns static servers:

8.8.8.8, 8.8.4.4

Exactly like this respecting commas and spaces and not joining anything else but the code reported. What does this give?

Still error… Especially, with commas…

put only 8.8.8.8 both times, leave all the others out.
I guess the other two lines where accepted without problems?

Are you soundly sure that you are on: Network - general - dns**** submenu?
It is so uttermost strange that you get an error message. Did you perform copy and paste?
What keyboard layout do you use?

BTW: what does that mean when you say “especially with comma”.
Either you have an error or you don’t. If you are able to put in the 8.8.8.8 server of Google you are perfectly done. What do you mean with especially. How can you know (since the error message comes in when you push ok)? Did you try without comma and it worked? Did you then try to connect?