No hibernation (suspend to disk) with openSUSE 11.3

I just installed openSUSE 11.3 but cannot get hibernation (or suspend to disk) working.
It does not go to hibernation but instead it just locks the screen.
The relevant error in /var/log/pm-suspend.log looks like below.

According to /usr/lib/pm-utils/sleep.d/30s2disk-check ‘/dev/dm-1’ must be the swap partition.
What i don’t understand is that why the error says swap partition is not active.
There is no error for swap partition during boot time. Boot message says that swap partition is activated.

Can anybody help to figure out why it doesn’t go to hibernation?

:frowning:

/usr/lib/pm-utils/sleep.d/06autofs hibernate hibernate:Shutting down automount …done
success.
/usr/lib/pm-utils/sleep.d/30s2disk-check hibernate hibernate:INFO: checking for suspend-to-disk prerequisites…
ERROR: resume partition ‘/dev/dm-1’ not active, can not suspend
WARNING: /var/run/pm-utils/pm-suspend/storage/inhibit will be created to prevent suspending!
Returned exit code 1.
Thu Aug 5 19:05:35 MST 2010: Inhibit found, will not perform hibernate
Thu Aug 5 19:05:35 MST 2010: Running hooks for thaw

Below is the device link for partitions

lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-name-isw_ddcjejcaha_LINUX0 → …/…/dm-0
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-name-isw_ddcjejcaha_LINUX0_part1 → …/…/dm-1
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-name-isw_ddcjejcaha_LINUX0_part2 → …/…/dm-2
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-name-isw_ddcjejcaha_LINUX0_part3 → …/…/dm-3
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-name-isw_ddcjejcaha_LINUX0_part4 → …/…/dm-4
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-uuid-part1-DMRAID-isw_ddcjejcaha_LINUX0 → …/…/dm-1
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-uuid-part2-DMRAID-isw_ddcjejcaha_LINUX0 → …/…/dm-2
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-uuid-part3-DMRAID-isw_ddcjejcaha_LINUX0 → …/…/dm-3
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 dm-uuid-part4-DMRAID-isw_ddcjejcaha_LINUX0 → …/…/dm-4
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 raid-isw_ddcjejcaha_LINUX0 → …/…/dm-0
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 raid-isw_ddcjejcaha_LINUX0-part1 → …/…/dm-1
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 raid-isw_ddcjejcaha_LINUX0-part2 → …/…/dm-2
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 raid-isw_ddcjejcaha_LINUX0-part3 → …/…/dm-3
lrwxrwxrwx 1 root root 10 2010-08-05 18:41 raid-isw_ddcjejcaha_LINUX0-part4 → …/…/dm-4

Below is fdisk -l information for the disk which has swap partition.

/dev/dm-0p1 1 2089 16779861 82 Linux swap / Solaris
Partition 1 does not start on physical sector boundary.
/dev/dm-0p2 2090 3395 10482431+ 83 Linux
/dev/dm-0p3 3395 4047 5245055+ 83 Linux
/dev/dm-0p4 1 1 0+ ee GPT

What does ‘free’ show?

Here is the output of ‘free’

                 total         used           free     shared    buffers     cached

Mem: 8192320 1917476 6274844 0 104076 846220
-/+ buffers/cache: 967180 7225140
Swap: 16779644 0 16779644

On 08/05/2010 11:06 PM, onadesert wrote:
>
> Here is the output of ‘free’
>
>
> total used free shared
> buffers cached
> Mem: 8192320 1917476 6274844 0 104076
> 846220
> -/+ buffers/cache: 967180 7225140
> Swap: 16779644 0 16779644

This shows that your swap is enabled. Why hibernate does not like it is beyond me.

On 2010-08-06 04:36, onadesert wrote:

> According to /usr/lib/pm-utils/sleep.d/30s2disk-check ‘/dev/dm-1’ must
> be the swap partition.

It must be given in the kernel command line.

> Below is fdisk -l information for the disk which has swap partition.
>
> /dev/dm-0p1 1 2089 16779861 82 Linux swap /
> Solaris
> Partition 1 does not start on physical sector boundary.
> /dev/dm-0p2 2090 3395 10482431+ 83 Linux
> /dev/dm-0p3 3395 4047 5245055+ 83 Linux
> /dev/dm-0p4 1 1 0+ ee GPT

I don’t know if GPT is supported :-?


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

I found a workaround.
It seems 11.3 has a burg. Actually multiple burgs related to RAID.
Some how if swap partition is on a RAID it cannot resume from it.
I managed to have it go to suspend but it cannot resume.
It just restarts when it is supposed to resume from hibernation.
If swap partition is on a single drive there is no problem for hibernation or resume.

Another problem with a RAID is that if /var is on a RAID that is configured to be handled by ‘MD something system’ it cannot start properly. During installation installer detect the RAID and ask whether you want to have ‘MD something’ handle the RAID. If you say yes it causes problem when /var partition is on the RAID. According to error message, it seems that SUSE creates a some kind of temporary config file on /var for RAID partitions. If /var partition is on a RAID it cannot do that resulting in a trouble for start up.

As a reference below is my system configuration that gives me a trouble.
On a single disk
/boot
/
/usr
/local
/opt

On a RAID0 (3 x HDD, strip)
/swap
/var
/tmp
/home