No hardware display acceleration in OpenSuse 11.0

A bit of background:

The first version of Suse which I installed was 9.3. At that time I had a Radeon X800, and installing the proprietary ATI drivers went flawlessly: xorg was properly configured and I had full hardware (2D) acceleration and everything worked ok.

Later I upgraded to OpenSuse 10.2 (by updating over the old Suse rather than making a fresh install). Installing the ATI display driver still worked and I had full hardware acceleration.

Later I upgraded to OpenSuse 11.0 (again by updating rather than doing a fresh install). Hardware acceleration was still working. A bit later I changed my graphics card to a Radeon 3850HD. The ATI drivers still installed ok, and I had full hardware acceleration.

A couple of days ago I made a grave mistake: I upgraded to OpenSuse 11.1. After the installation was complete and the system booted: X wouldn’t start. I tried installing the ATI proprietary drivers again: No dice. The installer refused to work (stating something about a wrong version).

I switched to using the “radeon” driver rather than the “fglrx”: Now X starts, and there’s partial hardware acceleration. For example windows can be dragged and their contents scrolled at full speed, but the X-Video Extension doesn’t work, which means I cannot watch videos at full screen. This is rather problematic.

Ok, now I start making even more mistakes. Rather than try to solve why X-Video Extension is not working, after some fiddling around I decide to downgrade to OpenSuse 11.0, which was working just perfectly earlier. I do this using the “update” option of the installer.

Oops: X-Video Extension still doesn’t work, and the ATI display drivers still refuse to install. I tried a system restore from the backup I made just before upgrading to 11.1: No dice. Made no difference. (Isn’t “system restore” supposed to restore your entire system to the exact same state it was at the time of the backup? Clearly this isn’t so.)

Now I’m getting desperate: I had a perfectly-working OpenSuse 11.0 system before, but now it’s not working. The ATI drivers refuse to install, and the X-Video Extension doesn’t work.

(Note: I know that it should work even with the “radeon” driver because I have tried it in the past, and there was no problem.)

The system is now also broken in more ways: For example apparmor now reports tons of errors at startup and is not loading. The updater application is complaining about something as well. So the system is now really f***ed up.

After hitting my head on the wall (I had a perfectly-working OpenSuse 11.0 system, and now it’s broken, probably beyond repair), I decided to do a radical thing: Install OpenSuse 11.0 fresh. Maybe this will help. Maybe the ATI drivers will then install and everything will work fine.

No dice: Now it’s way worse than before: The ATI drivers fail to install properly, the “radeon” driver seems to somehow fail to start up properly, and now there’s no 2D hardware acceleration whatsoever! And the refresh rate is now 58Hz (rather than the old 85Hz).

The system is now completely unusable: Dragging windows and scrolling their contents takes forever, and of course even trying to watch some video would be a ridiculous idea.

(More hitting my head against the wall. I had a perfectly-working system with basically no problems, and now I have a completely broken system which I can’t use for basically anything, plus all my data is in backups, and even if I got the hardware acceleration to work I’ll have to spend days restoring all my stuff to the way it was before…)

I’m really desperate here. Could someone please help me getting this to work? I don’t care if it’s with the ATI fglrx driver or the radeon/radeonhd driver. Whatever, as long as I get 2D hardware acceleration working.

Here’s some info:

As stated, I have a Radeon 3850HD.
lsmod does not list either fglrx nor radeon.
modprobe can be used to load the “radeon” driver, but “fglrx” is not found.

Trying to install the latest ATI driver, ie. 9-1 (either using their installer or from their repository) makes the system crash: When X starts, all I get is a black screen with some pixel garbage here and there, and after about 10 seconds the system reboots. The same goes for the previous driver version, ie. 8-12.

I tried an older driver, namely 8-8, and it copies some modules somewhere, but fails at compiling those modules with the error:

kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

Yes, I have installed the kernel sources, I have installed the kernel headers. It doesn’t help. The file mentioned in the error does not exist even after installing those packages (although the directory appears). (And yes, the newest drivers also produce this same error, although they succeed in doing something because the system crashes after I run them and restart.)

I somehow got the display to use the better refresh rate of 85Hz (I think it happened after a “sax2 --vesa 0:1600x1200@85”), but there’s still no hardware acceleration. Examining my current xorg.conf, it seems to (try to) load the fglrx driver (rather than radeon), and X is starting and the refresh rate is 85Hz, but there’s still no hardware acceleration whatsoever, and the system is still unusable.

You can imagine how p***ed off I am now. I had a perfectly good system, everything I needed worked just ok (everything was fast, I could watch videos at full screen, I could even run 3D programs with some hardware acceleration), and now I have a system which is totally broken. No hardware acceleration whatsoever.

Could someone please help me? I’ll supply any information you need. I want this working. I know it’s possible to get it working because it was working before.

Btw, I followed step 3 from this post, and it actually generated the missing version.h file. However, it’s still no good. It just changed the error message to:

kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as “”
instead of “”.

Could someone please help me? As I said, I don’t care if it’s the fglrx or radeon driver, as long as I get hardware acceleration back. (I don’t need 3D acceleration, just the 2D one.)

Success! (At least so far.)

The reason for the last failure was that the kernel sources were from a newer kernel than what I had installed. After upgrading everything to the latest versions available with software update, including the kernel, the sources and the kernel now match, and the ati driver installed properly and now I have 2D hardware acceleration again! Even xvinfo is now printing tons of promising stuff!

Now to reinstall mplayer to see if I can play videos in fullscreen mode again.

It works! I’m happy again! Sorry to have bothered you.

I have found that it’s not a worthwhile investment of time to complain about OpenSuse. If I simply use the time I would have spent grousing about the OS into dicking around a bit, and trying different things, some combination always seems to work for me eventually.

I was not complaining. I was asking for help.