No GUI with Live CD That Previously Worked

I have a really weird issue which is blowing my mind right now. I had installed the 64-bit version of openSUSE 11.1 with KDE from a Live CD. Everything was going smoothly until I installed the ATI drivers for my X1200 card, which hosed everything up. I couldn’t find any way to restore the original settings, so I ended up just going back to Ubuntu for a few days.

Long story short, I wanted to give this another shot (and say forget the ATI drivers, which I have now been smart enough to read about instead of blindly installing), but I can’t seem to load X with my Live CD anymore… which doesn’t make sense because this is the SAME Live CD I used the first time around on the very SAME hardware.

I can boot to the CD successfully, but then if I select to either load the Live environment or boot into Failsafe mode, both eventually just drop me off at a terminal asking me to log in. I can use the normal live CD “root” login, but from there running “startx” or “sax2 -r” both fail.

Any ideas on what might be going on here? Why on Earth would a Live CD which previously worked fine no longer be able to load up the desktop?

Also note that I’ve made sure of the obvious possibility of scratches or anything like that on the disk.

Do the root login at the CLI and use this switch

sax2 -r -m 0=vesa