No GUI at 13.1 boot up

openSUSE 13.1 64bit KDE - Nvidia driver

When I boot I am presented with a small violet CLI with no graphic abilities. If I boot to level 3, log in, and invoke “startx” the GUI starts (albeit slowly) and behaves normally. The last few lines of /var/log/messages shows…

2013-11-21T09:53:17.957338-06:00 linux-6spe systemd[1]: Started Session 2 of user root.
2013-11-21T09:53:17.973021-06:00 linux-6spe systemd: pam_unix(systemd-user:session): session opened for user root by (uid=0)
2013-11-21T09:53:17.981483-06:00 linux-6spe login: ROOT LOGIN ON tty2
2013-11-21T09:53:17.987647-06:00 linux-6spe systemd[2983]: Failed to open private bus connection: Failed to connect to socket /run/user/0/dbus/user_bus_socket: No such file or directory
2013-11-21T09:53:18.022050-06:00 linux-6spe systemd[2983]: Stopped target Sound Card.
2013-11-21T09:53:18.022870-06:00 linux-6spe systemd[2983]: Starting Default.
2013-11-21T09:53:18.023617-06:00 linux-6spe systemd[2983]: Reached target Default.
2013-11-21T09:53:18.024383-06:00 linux-6spe systemd[2983]: Startup finished in 45ms.
2013-11-21T09:53:18.026426-06:00 linux-6spe systemd[1]: Started User Manager for 0.
2013-11-21T09:53:22.984146-06:00 linux-6spe systemd[1]: Starting Stop Read-Ahead Data Collection...
2013-11-21T09:53:23.028892-06:00 linux-6spe systemd[1]: Started Stop Read-Ahead Data Collection.

“Failed to open private bus connection: Failed to connect to socket /run/user/0/dbus/user_bus_socket: No such file or directory” seems to be a problem. How would I correct this?

Thanks in advance.

If you did an upgrade to openSUSE 13.1 and not a clean install, you must uninstall the incompatible nVIDIA driver with kernel 3.11. At this point you could do a full install, but a custom partition for experts where you will reuse all existing partitions. You elect to mount everything as before, but to NOT FORMAT. But with one exception, you do FORMAT the root / partition. This will blank out all system wide settings, but keep all personnel files intact. It is the best I can suggest you do.

Thank You,

You didn’t even get to “Reached target Graphic Interface” which is the most common point I’ve seen where the system might hang.

I guess you’re not able if you can’t even boot to the point you can get to a login prompt,
So, can you d/l and run a LiveCD and post the results of the following?


And, if there anything that was captured by the system log (/var/log/messages), post to SUSE Paste

BTW - If you can get a LiveCD to run, I’ve found it’s useful to use as a comparison running on the same hardware…

Is this first bootup?
Have you tried wiping clean and installing a second time?


It was a clean install on a newly formatted parttion. I have no essential personal files.

I can log in as I metioned in my post, “If I boot to level 3, log in, and invoke “startx” the GUI starts (albeit slowly) and behaves normally.”

lsusb produces…

# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

…and lspci…

# lspci
00:00.0 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: NVIDIA Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB controller: NVIDIA Corporation MCP61 USB 1.1 Controller (rev a3)
00:02.1 USB controller: NVIDIA Corporation MCP61 USB 2.0 Controller (rev a3)
00:04.0 PCI bridge: NVIDIA Corporation MCP61 PCI bridge (rev a1)
00:07.0 Bridge: NVIDIA Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0a.0 Multimedia audio controller: C-Media Electronics Inc CMI8738/CMI8768 PCI Audio (rev 10)

I have booted a number of times, and no I have not yet considered a re-install. Memories of WinDoze days. I think I will suffer along with the console login and startx until the “one-click” Nvidia installation file is available.

Hi IonMich, it seems you have the exact same system hardware as me. I am running 13.1 with proprietary NVidia drivers installed the so-called ‘hard way’ (which is not hard at all)
The drivers by NVidia have been a bit flakey lately in keeping up with newer kernels, but this one 304.1160 installed fine and seems to be working correctly.

Have a look around the forums for how-to install, and look for jdmcdaniel3 blog entries, and his scripts to make it even easier.

Here is the driver file:

NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver

Same problem here, the install ran fine, but I get the small purple terminal box, no desktop. I still get the background, though, with the chameleon with the sheepish grin. I can start wierd versions of yast and firefox but can’t do much else (haven’t tried startx). The victim is a 3 year old e-machines with 2 GB ram, onboard video. OK, not the heaviest iron, but it boots Ubuntu 13.10, Mint 15, and Windoze 7 fine. I’m writing this on my cheap 3 year old laptop, using the same openSUSE 13.1 KDE live DVD.

I admit to being a n00b, this is my first try at SUSE and KDE.

Did you try the ‘nomodeset’ boot code per the release notes ? The appropriate section in the release notes, reads something like this:

5. Technical

5.1. Initializing Graphics with KMS (Kernel Mode Setting)

With openSUSE 11.3 we switched to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently using Grub 2, the default boot loader, add it to the GRUB_CMDLINE_LINUX_DEFAULT kernel default load options line in your /etc/default/grub text file as root and running the terminal command

sudo /usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg

for the changes to take effect. Else, for Grub Legacy, add it to the kernel command line in /boot/grub/menu.lst, also done as root. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.

In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YaST, which then recreates initrd afterwards. Reboot your machine.

On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS); alternatively, for legacy GPUs from Intel the “intellegacy” driver (xorg-x11-driver-video-intel-legacy package) is available, which still supports UMS (User Mode Setting). To use it, edit /etc/X11/xorg.conf.d/50-device.conf and change the driver entry to intellegacy.

On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver supports only KMS). Note, newer ATI and NVIDIA GPUs are falling back to fbdev, if you specify the nomodeset kernel boot parameter.

Another possibility to try, per the openSUSE release notes, if one has nvidia hardware, with garbage on the screen, is from this note:

5.2. Garbage on the Screen During Installation with the Nouveau Driver

On some systems with NVIDIA cards, the installer may show garbage on the top part of the screen due to problems with the default nouveau driver. If you are affected by this problem, you can disable the nouveau kernel module to run the installer and then enable it again once the system is installed or upgraded.
To disable the kernel module, once you boot from the installation media, select the ‘Installation’ entry in grub and press ‘e’ to edit the parameters. Then go to the line starting with ‘linux’ (or ‘linuxefi’) and add brokenmodules=nouveau at the end. Now press F10 to continue booting with the new parameter. After the system is installed, you can re-enable the nouveau module by editing /etc/modprobe.d/50-blacklist.conf and removing the entry that blacklists nouveau.

This thread and the NVIDIA driver v. 304.1160 solved my installation of 13.1. I had the same problems with an old HP Pavilion dv9000 with NVIDIA GeForce Go 7600.

Only difference was, that I didn’t get a small window at first startup but a unclear KDE desktop with lots of bad graphic icons. But after insert of nomodeset as described in 13.1 README the startup went well, but KDE resolution was low (I think the noveau driver was runing). So I install NVIDIA 304.1160.

Now I am working on No Sound problem instead


“No Sound” problem was just openSUSE piano jingle missing. I dont know why it is not heard ? But I can live without it.

You mean the login sound? That’s from KDE, not openSUSE.
And they disabled it by default in the current version.

But you can configure it in “Configure Desktop”->“Application and System Notifications”:
System Settings/Application and System Notifications - KDE UserBase Wiki

Thanks everyone for the suggestions, but here’s what actually worked for me, and I would be really keen to learn the cause.

I went through the Nvidia installation with version 304.116 one more time. Nothing changed. I booted to level 3 as root, disabled the auto-login, and added a new user via YaST. The new user had no problems booting into the GUI. I decided to delete the problem user and his home directory and re-create the account. A new home directory was created with the (presumably) problem file missing.

All is normal now. Problem solved.