No GUI after Opensuse 11 Install

I just installed Opensuse 11 x64 on my Vostro laptop, the boot screen is showing just fine (OpenSUSE logo, loading), but then the screen goes blank. I hear the login sound, and can Ctrl-Alt-F1 to go to the console. Apparently OS isn’t working correctly with my video card (ATI Radeon Xpress 1150). How do I remedy this?

I figured it out, all I had to do was

sax2 -r -m 0=vesa

Hi
Have a look here;
http://en.opensuse.org/ATI

If you go to the console and login, then su to root user and run sax to
set the driver to vesa, that should get a GUI running until you can
install the correct one…


su -
init 3
sax2 -r -m 0=vesa
init 5 && exit

Note that’s a zero above.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 5:40, 1 user, load average: 0.12, 0.11, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

This is an (unfortunately) rather common problem, because the driver is provided by ATI from a software repository they host - which is only accessible post install. More than one way to do this, my suggestion . . . at the boot menu, in the options box below, type in the numeral 3. If there is already some text in that box, just make sure there is a space between that text and the 3 that you type in. Then hit enter to boot. (The first graphical screen you see is displayed by a special “framebuffer” driver that is built into the kernel; it’s not the driver for your ATI card.)

You will be booted to user login prompt. Type “root” (w/o quotes) and then your root password. Then do this:


zypper sa http://www2.ati.com/suse/11.0/ ati-driver
zypper in x11-video-fglrxG01

That’s a zero in “G01”. This will add the ATI repository, install the driver along with its kernel module dependency. Then do . . .

aticonfig --initial

To configure the card. Reboot. There have been some known problems with ATI’s driver and certain versions of the Radeon Xpress series. If at reboot you don’t get to the gui, then at the command prompt login or su to root (or if locked up, reboot with init 3 as above), and do:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf-001
sax2 -r -m 0=radeon
aticonfig --initial --input=/etc/X11/xorg.conf
sax2 -r -m 0=fglrx

If the ATI driver doesn’t work for you at all, then the fallback is the “radeon” open source driver, which works well with many cards. You install it with:

sax2 -r -m 0=radeon

Those are zeroes before the = sign above, btw.

That got you the vanilla vesa driver. If you’re happy with that, fine. The “radeon” driver is probably better, though. See my post above for the syntax to install it (same as you used, except substitute “radeon”). If you want to install ATI’s proprietary driver, instructions posted above.

I just needed to use the GUI so I could do the ATI 1-click install over the net.

Aha, being clever from the start, huh? :slight_smile: . . . welcome to the community; clever users especially!

heh, not really, I also needed to install ndiswrapper before the network would work, which the “Install Software” GUI loads from the OS DVD (I am unfamiliar with using the installation repository at the command line). One day I hope to be able to do it all from the command line :slight_smile:

Still, a pretty darn good job of it, straight out of the gate. Re package management from the command line - the more I get to know zypper, the more I like it. Very powerful, very flexible.

I tried the instructions above, but I keep getting errors that it cant create directories, or find files:

Running: sax2 -r -m 0=vesa (or 0=radeon)

touch: cannot touch ‘/var/cache/sax/files/reinit’ : No such file or directory
touch: cannot touch ‘/var/cache/sax/files/hardware.chg’ : No such file or directory

then it prompts me if I want to enable 3D for this card, then I get:

SaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199

I get that line about 7 times, then I get:

can’t create /var/cache/sax/files/config: No such file or directory at /usr/share/sax/init.pl line 745

And back to # line

any thoughts?
Any thoughts?