no gui after new graphics card install

Hello,

I have just installed a new video card, but now x will not start.

opensuse 11 with kde 4.

The board has onboard mach64, but added a geforce 6600.

I get the boot menu, but then I only get the cli.

Here is what I have tried(under the root account):

startx gets me “no screens found”

sax2 gets me “died at /usr/share/sax/init.pl line 653”

sax2 -r-m 0=vesa gets me the same as running sax2

sax2 -m 0=vesa gets me the same as the other sax2 commands.

I have tried sax2 with some other switch recommendations from online and get the same. SuSELinuxSupport: HowToGetTheGuiBack

I went into yast, then hardware and probed hardware. Under display I have the mach64 and geforce 6600 (which is listed twice) One with 3d support.

Could anyone offer a recommendation or tell me the proper way to upgrade a video card?

please keep in mind that I am fairly new to linux. I have too many things setup and configured to reinstall.

thanks in advance

Nevermind I found the command I needed.

sax2 -c 0 -m 0=nvidia

Firstly do NOT log in as root. To get rid of the on board card you need to disable it in bios.