No gui after installation

Hi, I just installed 11.3 64 bit, installation went fine (though I went to sleep during package downloading), and now the system boots into a terminal (yellow/black) with automatic login.

I’d like to boot into the usual login manager (I chose Kde for desktop), thanks for the help.

Put the installation disk and when you get to the first menu(Boot from hard disk, Installation, etc) press F3 which will give you a choice of resolution, choose let’s say 800x600) and then do choose to start from your hard disk. I have this problem always when I first install a new version. Then I don’t have to tweak it.
or you can try in the terminal to type init 5 which will try to boot to the GUI.

I doubt the setup did change the default runlevel (which is 5) while you were sleeping. (But you can check that in /etc/inittab). If your system doesn’t boot into GUI, Xorg is propably incomplete or misconfigured, most likely the video driver is missing or wrong. Check /var/log/Xorg.0.log to see what happended.

I tried a second install, same result, I stepped away while the installer was downloading packets with 1h40 left, but I came back after an hour to check, and it was in that terminal I talked about, yellow with black font in the upper left corner of the screen, with mouse still active a moving across the entire screen. It’s not the no-gui state which I’m familiar with, it’s more a broken gui stuck in a terminal.

I checked the xorg log, looks like the driver is loading, there is a FATAL though, but I can’t understand it all, I’ll try to paste the log here, though I’m not sure how I can recover it.

By the way I have dual screens (dvi+vga) on a HD4670 if that helps.

Can’t find the edit button, so here’s the xorg log: 27.160] X.Org X Server - Xorg log - mwEjPSQh -](

Hope it helps to find whatever my problem is :slight_smile:

Do I have to login in the novell page every time I come to the forums?

    27.230] (EE) FATAL: RadeonHD presently does not work with kernel modesetting (KMS).
Please disable KMS in your kernel.
    27.230] (II) [KMS] Kernel modesetting enabled.

Add ‘nomodesetting’ as a boot optoin, also try setting up the second monitor after install

Thanks for the tip, I already suspected the dual monitor had something to do with it, so I’m reinstalling with one monitor only, and I’ll try nomodesetting.

Curious though how KMS is enabled by default considering the number of people with Radeon HD cards :slight_smile:

I did an install with an HD card on a dual monitor system and the setup must have disabled KMS since it was using radeonhd at the end.
I did an install on an iMac with an HD card, and it ended up using radeon (not radeonhd) because KMS was enable.
I finally installed the latest ATI proprietary driver on both machines.

Using nomodesetting doesn’t solve the problem, though there’s no more fatal error in the xorg log. Dual monitors isn’t the problem either since I installed with only one monitor plugged.

Would installing the ATI Driver in init 3 solve something?

Also, I just found out in the boot screen, that nscd service doesn’t start, but I doubt that has anything to do with display.

The parameter is not nomodesetting it is nomodeset

Can’t even install ATI Driver using zypper in cli like here: SDB:ATI drivers - openSUSE because the repository url is broken…

nomodeset and nomodesetting both have the same effect which is disabling KMS, I just tried both and then check in xorg log.

nomodeset and nomodesetting both have the same effect which is disabling KMS, I just tried both and then check in xorg log.

I have a HD 4670 ATI card, after the installation of opensuse 11.3 64 bit everything looks fine with the display. I tried to install the propritery ATI drivers and then got the black screen but hence reverted back to the opensource driver and everything is good so far.