No Grub boot menu after monitor upgrade

Very strange. After a monitor upgrade (Dell UP2516D) my system (SuSE 42.1) boots to the logon screen, however the screen is completely blank until then. I get no GRUB menu when my system starts. I’m guessing there is something in the YaST2 Boot loader Kernel Parameters I have to change. As it is, my settings are: VGA Mode: Unspecified, Optional Kernel Command Line Parm: resume=/dev/sda1 splash=silent quiet showopts, Use graphical console: checked, Console Resolution: Autodetect by grub 2, Console theme: /boot/grub2/themes/openSUSE/theme.txt. My monitor will do 2560 X 1440. After I login all is fine however I get no grub boot loader menu and my monitor complains with a “no signal” error message untill the logon screen appears???

You get no BIOS splash screen???Grub gets its info from the BIOS so I’d start there

I have a bios splash screen just no Grub boot menu. When I turn on the system: Bios splash screen - YES, Grub menu -NO, Logon menu - YES. Sorry if I wasn’t clear enough. Just very perplexing.

Maybe set the res of the grub to a known good resolution for the monitor in Yast -bootloader. VGA does have limited resolutions a definite does not use the full res the monitor can use. But maybe you can find one that works

Are you using grub legacy or grub2?
If you are using grub2 - try disabling graphic mode in grub. Set GRUB_TERMINAL=console in /etc/default/grub and run “update-bootlader --refresh”. Do you get output from grub now?

Thanks, I now believe this to be a hardware issue. I was using a display port cable from my computer to my monitor and I switched it with a HDMI cable and now it works. This seems odd. I have recently moved and I believe the display port cable was functioning fine before the move. I don’t know why it would exhibit this behavior but I’ve switched the cables back and forth and it is the cable. Tried the same DP cable and monitor with a windows system and all was fine. Not sure what the issue is, going to try a new DP cable with the linux comp. and see what happens.

Thanks. it seems to be a cable issue. May have a bad DP cable.