No grub after setting pci=noacpi

I’m new to Opensuse, and a beginner with Linux in general.
I had the error message (IIRC) “1 table failure, 7 successful table load” (something like that…).
When searching for a solution, I encountered one suggesting to add “pci=noacpi” to the boot option in the Yast Boot loader menu.
Now, Leap won’t boot at all.
Even worse, the Grub doesn’t show up!
I’ve tried this solution to get it to boot again, with no success.

Any ideas how to make it work again (beside reinstalling Leap altogether…)?


Tell us something about your hardware, a laptop or PC or motherboard model number at least.

What prompted you to choose pci=noacpi as a potential solution? What happened right before you saw the message that prompted you to look for help? How long ago did you install Leap? Did it ever work properly?

Unless your computer is very old or has a specific issue with ACPI you should not be using pci=noacpi
If you get tot he boot menu, press ‘e’ and edit out the option then press F10.
If that boots su to root and edit /boot/grub2/grub.cfg and remove the pci=noacpi, save the changes and then run grub2-mkconfig -o /boot/grub2/grub.cfg then reboot
Still have an issue? come here tell us your hardware and explain the EXACT error message not “or something like that”, otherwise we are trying to read minds

Leap is on my desktop (2 yrs old), with an ASUS b150m motherboard.
I’ve installed Leap for the 10 days ago, and everything worked fine except that I had the error message “ACPI error: 1 table load failures, 7 successful”.
That error motivated me to go for the “pci=noacpi” solution, after trying out “acpi=off” (and for the lack of another solution).
Beside that error (and another unrelated network issue), everything worked perfectly.

Now, when I boot my system, it never reaches the GRUB menu.
It leaves me on a black screen with the message “Minimal BASH-like line editing is supported…”, similar to the one in this video.
As I’ve mentioned in my initial post, I’ve tried editing the GRUB configurations via Yast. The only problem I encountered was that once I had edited it, I could not find a “reboot” option.
Yet, I’ve tried it a second time to see if it saved my modification (removing “pci=noacpi”), and it did, so I really don’t know what to do.

I hope this answers your questions.
Thanks a lot for helping me!

One of mine is an Asus B250. If yours is anything like mine, it’s susceptible to random forgetting of UEFI entries. You may have been as little as one click away from a solution. What exactly did you do after you “had edited it”? It should have been enough to tell YaST OK, exit, then perform a normal reboot.[/QUOTE]You should be able to use your installation media to boot installed system from hard disk , go back into YaST, make any change, e.g. change timeout value a second longer or shorter, exit YaST normally, then reboot normally. On reboot, go into BIOS, confirm there is an openSUSE UEFI selection, and make sure it is listed first.

It’s actually possible to boot from that grub prompt, but to do so requires typing a lot of what’s in /boot/grub2/grub.cfg. You can retrieve grub.cfg via a rescue boot if necessary. If you find yourself needing to go this route, susepaste the grub.cfg file so we can edit what needs to be typed down to a manageable level.

When you get a chance, check if there is a recommended BIOS update available for your motherboard.

After I’ve edited the configs via Yast, I’ve quit it selecting the OK then F to quit Yast. This lead me back to the original prompt screen (the one from which I got to Yast).
At this point, I could not find out how to reboot using a command so I’ve just pressed the power button on my PC to turn it off.

I’ll try to change the timeout value into Yast.

Thanks again for your time!

It worked! I’ve repeated the steps to get to Yast, but this time I’ve change the timeout value and now everything is back to normal.
Since it’s back, should I just ignore the “ACPI error: 1 table load failures, 7 successful” message then?

Thanks a lot!

Check if there is a recommended BIOS update available for your motherboard. BIOS errors are a common source of ACPI error messages. They commonly disappear after a kernel or BIOS update, and typically are not errors that produce perceptible trouble.

If you just see an error message and have no other problems then leave it alone or as suggested look for a BIOS/UEFI update. IMHO if it ain’t broke don’t fix.

Yes, ignore that message, I means that acpi is trying something that your system doesn’t have. Like gogalthorp says: If it works don’f fix it.