No graphics only command line on booting

I recently had to reinstall openSUSE 11.2 on my computer…
nx 6120 laptop
512 Ram
1.77 ghz processor
and i think i have intel 915 graphics chipset or something…

but now to the point. i had to make a fresh install on my computer. Before that it was working fine. I used a live usb for the installation process. there no GUI came up but i used yast2 to install the live usb. installation went smoothly with no hiccups…i restarted the computer and selected open SUSE 11.2 in the boot menu.

but after booting it again comes to this dark screen with a lot green ‘dones’ and then finally at the bottom i have my login space…so no desktop…

does swap have anything to do with this?

so i would like to ask…how can i fix this?

any help highly appreciated
thanks in advance


enter your login username
then your password (which does not display as you type)

now try typing:


If that doesn’t work
reboot and try booting the failsafe option

i tried what you said. but unfortunately it did not work
so i reinstalled and now everything is working fine

thanks anyway for replying!

Some intel graphic hardware does not work well with the 2.6.31 kernel that comes with openSUSE-11.1. I documented some of my less than glowing experiences:

You could try this from the text mode (with root permissions):

cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf

and then restart with

shutdown -r now

That ‘might’ get you a very basic desktop. Once you have that up and running we can try some things to get this working better, … but before we do that, you will need some basic theory. Take a read of post#3 here: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums Post#43/44 in that same thread may be useful dependant on your hardware as you did not read to be very clear at all on EXACTLY what hardware your PC has (where in the Linux world knowing EXACTLY what hardware one’s PC has happens to be MUCH more important than in the Windoze/Mac world).

To get to the text mode, when the “boot/splash” screen first appears, press the 3 key so that the letter 3 appears in the options line of the boot/splash screen. Then boot normally. That will take you to a full screen text mode. Login as a regular user, type “su” (no quotes - enter root password) to get root permissions, and then try what I quoted above.

arkadeep wrote:
> i had to make a fresh install on my computer … Before that it was
> working fine.

RULE ONE: If it ain’t broke, don’t fix it.


Was the first install from the same medium as the second , the way this is worded I can’t tell.

does swap have anything to do with this?

Have you done something with swap since first install that causes you to ask this?

With 512 MB of ram you will need a swap partition.