No graphics on 6.4.x kernels

After updates from 6.3 kernel line to 6.4 no nvidia kernel modules loaded, so no graphics session available. Try to reinstall kernel and Nvidia drivers but did not solve the issue.

Dell 5521 with Nvidia MX450 with Optimus.

NVIDIA drivers fail to build approximately every second kernel version. Either do not use Tumbleweed or do not update kernel before you made sure drivers work for this new kernel version.

Just google for “nvidia driver kernel 6.4”.

1 Like

Thanks for the answer… Was not sure whatever this is the case or not ;(

I just updated to 6.4.1 and have no issues.
6.3.9 disrupted my AMD/Nvdia.

But after as reinstall 2 weeks of waiting, yesterday’s update gave me all screens back.
Maybe also try a reinstall without Nvidia active and after all Updates are through, try to activate Nvdia. Worked for me.

Lucky you. 6.3.9 working w/o issue for me. Now 6.4.2/6.4.3 no graphics.

Hello everyone,
everything is working again after forced re-installation of kernel, Nvidia, explicit key import and forced initrd regeneration (some of it fix the kernel module to load).

hey , i guess my issue is related to this one, and to this one : Nvidia rtx 2070 unable to boot without nomodeset

noob here, so i dont know exactly what nomodset is, i think its a kind of driverless mod for nvdia users

my issue is “simple” : if i do this nvidia update

games wont work(check ur drivers error) , and after a reboot, ill have a black screen,i tried ti wait few minutes but its just frozen ( after grub and before login screen)

it could also be related to this :
ill have to see what that tmp thing is

here is how to modify grub command line directly: Manual "nomodeset" Kernel Boot Line Option for Linux Booting | Dell Deutschland (it is for Ubuntu but applicable for most distributions). Additionally setting tpm_tis.interrupts=0 after the nomodeset will most probably do no harm as well (that’s the second reference you mentioned). Or directly turn off TPM inside BIOS/UEFI (accessed usually via F2key during the machine start before the boot menu shows up).

Seing this thread I have stopped the update while it was still downloading package ( just in case ).

As a noob like you I usually wait some days before trying to update when there is discussions of a breaking update or after doing a breaking update ( happen once ), it’s what I have been doing for one year using Tumbleweed, in this case it’s possible that the next kernel version will work normally with this version of Nvidia.

i have had problems with graphics issues once or twice in the past what seems to work for me sometimes without losing personal data is if you have an older snapshot u can boot it then click “upgrade” and upgrade or well downgrade to an older snapshot until more updates role out to fix the problem.

After upgrade to 6.4.6 kernel and updates of Mesa the Wayland is not using llvmpipe :slight_smile: so working again.

inxi -G

  Device-1: Intel TigerLake-H GT1 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce MX450] driver: nvidia v: 535.86.05
  Device-3: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
    type: USB
  Device-4: Microdia speedlink webcam driver: snd-usb-audio,uvcvideo
    type: USB
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia resolution: 1: 3840x2160 2: 3840x2160 3: 3840x2160
  API: OpenGL v: 4.6 Mesa 23.1.4 renderer: Mesa Intel UHD Graphics (TGL GT1)

The X11 has still problem with my 4th display (built-in one) switched off.