NO graphical user interface after upgrade to Leap 15.0

I just upgraded a 13.2 system to Leap 15.0, and while I obtained a bootable system (I can log in as root or as a user at the command prompt), I never get a graphical login screen during the boot process. I originally tried to do a new install, but could not get the installer to accept the existing mount points. So I tried the upgrade path, which worked, apparently (and somewhat to my surprise given the gap between 13.2 and 15.0). This is a reasonably old machine (2010), uses legacy boot and has an ATI/AMD graphics card in it.

When I choose 15.0 at the GRUB menu I very quickly come to a grey screen that has three small green question marks about 2/3 down the screen. In the space of about 20 seconds these question marks light up, one after the other, and then nothing further happens.

If at the GRUB menu I choose the “Default” option under “Advanced”, then I get the quickly scrolling record of the boot followed by another grey screen, which instead of three question marks, now has an arrow cursor which does respond to the mouse. But no login screen. In the preceding scrolling record I do see a couple of [FAILED:] messages. Whether they are significant I do not know. The first says:

Failed to start LSB: Automatically rebuilding fglrx kernel module ---- and then the little wheel (actually the backslashes and pipe symbol emulating a wheel) goes around and possibly the rebuild completes

and I note that fglrx is the AMD proprietary driver for the ATI card that I have installed. I believe by default that a new install of 15.0 would install the Noveau driver.

The second FAILED} reads:Failed to start Setup Virtual Console. See ‘systemctl status systemd-vconsole-setup.service’

I have no idea what that means.

Does this graphical failure possibly have anything to do with the attempt/failure to upgrade the fglrx package? For an upgrade I was not offered the choice of an AMD/ATI repository,

Thanks for any help. If someone can point me to any files that I can access from the command line that might shed further light on this problem, I am game…

At the grub menu, hit ‘e’. You will get an edit screen.

Scroll down until you reach the line that begins “linux” (or, possibly, “linuxefi”).
Hit the END key to get to the end of the line.
Type in " nomodeset" (without the quotes).
Hit CTRL-X to continue booting.

You should get a graphic screen, though perhaps with poor image quality. But it will be something that you can use for trying to install drivers.

Oops. Forgot to comment on this.

I see these “Virtual Console” messages. Maybe everyone sees them. It is some kind of bug, but it doesn’t actually cause any problems that I can see.

Nouveau is a driver for NVidia gfxchips. Fglrx is a proprietary driver for ATI/AMD gfx. ATI/AMD cards from 2010 should work just fine with FOSS drivers. I have several dating back to around that time, IIRC, all running the default FOSS driver. According to there are no fglrx drivers built for 15.0. Thus, not having uninstalled the proprietary driver prior to leapfrog upgrade is most likely the root of your problem.

You should be able to root login using nomodeset or failsafe and purge whatever proprietary packages remain. Post back output from inxi

zypper in inxi; inxi -Gxx -c0

so we can see exactly which ATI/AMD model you have and which drivers is/are engaged.

Showing us /var/log/Xorg.0.log would also be useful if not required if you have trouble getting any of the suitable FOSS drivers to work. One is xf86-video-ati. Less likely applicable is xf86-video-amdgpu. The third is not a separate driver package, modesetting, which is incorporated within the Xorg server, and should be used automatically if the other possibles are not installed. While booted using modeset most likely the crude and slow fallback driver xf86-video-fbdev would most likely be used for X, if X works at all, which most likely it will not if any of the proprietary driver from 13.2 remains installed.

Thanks for both sets of advice, but so far no success to report:

  1. Editing in GRUB and adding nomodeset to the kernel command line does not result in even a crude graphical interface. I go to the 3 question marks

  2. Logging in as root at the command line, and looking at /var/log/Xorg.0.log shows that X exits after failing in its attempt to load fglrx. The sequence (pardon the typos, hand copied from the screen) is:

“glx” will be loaded by default
LoadModule: “glx”
Loading /usr/lib64/xorg/modules/extensions/
Modulle glx: Vendor=‘Advanced Micro Devices, Inc.’ compiled for 6.9.0, module version 1.0.0
LoadModule: “fglrx’”
Loading /usr/lib64/xorg/modules/drivers/
Failed to load /usr/lib64/xorg/modules/drivers/ /usr/lib64/xorg/modules/drivers/ undefined symbol: xf86Initialising
UnloadModule: “fglrx”
Unloading fglrx
Failed to load module “fglrx” (loader failed, ?)
No drivers available
Fatal server error
No Screens found

Earlier in the log file is the notation that /etc/X11/xorg.conf is being used, and a look at that file shows all ATI/AMD entries. Its creation date is also October 2015, so this is clearly a holdover from my move to 13.2 from 12.3. Does this file need to be deleted? Is some default alternative created if it doesn’t exist at boot?

  1. I also attempted the zypper command, but that revealed that I also have network connectivity problems since I could not get to After this error message I tried to ping my router(direct by ethernet), and that failed also.

So apparently the upgrade was not as successful as I originally imagined…

fglrx does not work with Leap 15.0, the last was Leap 42.1 on which it was working…

So delete fglrx.

Absolutely. As long as it exists, you’re not done purging the proprietary driver from your system.

Is some default alternative created if it doesn’t exist at boot?
No. It’s an optional file that few FOSS driver configurations need, but most proprietary driver configurations do need. It’s existence is preventing the possibility of any non-fglrx driver being used.

  1. I also attempted the zypper command, but that revealed that I also have network connectivity problems since I could not get to After this error message I tried to ping my router(direct by ethernet), and that failed also.
    For this I suggest to open a new thread in the Network/Internet forum, if you have no success with general network troubleshooting instructions, such as those at

Let me close out this thread by saying that I ultimately concluded that my original upgrade was sufficiently flawed that I should retry a clean install. At the cost of deleting all the existing partitions and reformatting the disk (yes I backed -up my /home directory) this clean install succeeded. I have some problems with the boot disk order, and upgrading my KMail, but I will move inquiries about these to different threads. Thanks for everyone’s suggestions.