No Graphical Output after Install

I installed SUSE 11.3 from a commercial DVD as an upgrade to my present working 11.2
" if it ain’t broke don’t fix it" should have come to mind. The install worked and listed the bits of 11.2 to remove and replace plus the other upgrades with a good graphical display. When completed however I was faced with a text log-on which worked but no graphics display, at the end of the script there were 5 errors of drb displays of about 0. 02secs but nothing else. I tried the sax2 route to give me the x screen but that was an unknown command even after I used zypper to unload it. I also tried ctrl+alt+F7 to get back to a display which just gave be a black screen with a flashing cursor but ctrl+alt+F1-6 brought the text version back. The main boot screen did not have a resolution option and once you had pressed the SUSE 11.3 load back came the text. I tried reloading but no different.

Any Ideas anyone

Can you boot in failsafe?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

what video card do you have?


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkxXFfYACgkQJQ+0ABWtaVlZVwCfX4+DdMuFFyOGYCfOX6CMR6hu
YkAAnRmejaUEOy9KK+88LVJSsULCPXxu
=Pm8e
-----END PGP SIGNATURE-----

Hi,
No the failsafe boot fails and goes nowhere, the last messages are
FATAL Module ATI IXP No1 failed
FATAL Module IDE_pci_generic No1 failed
Creating dev nodes with index
1.84221]VDEV starting version 157
2.0120537][drm]initialized DRM 1.1.020060810
2 043418] [drm] radeon defaulting to kernal node setting
2 046239][drm]radeon kernal nodesetting enabled
2 492002] radeon 0000:0:0020 PCI INT A ->GSI0(level, low) ->IRQ0
2 050165][drm]initializing kernal nodesetting (REV770 0x1002:0x442)

(end of messages)

I noticed that at the inital bios display a lot of items were using IRQ10 including display, networking, USB1, USB2

and that coincedently my KVA which has powered my systems for about 9 years first killed off my MS laser mouse at the first install
and now on the reboot today no mouse works ?? have to attach it directly.

any further??

Hi
I have a gigabyte GV-R485-512H-B which is a ATI Radeon HD 4800 series card
The screen shows just before the login

Starting smart gdm[3732] : Warning GDM Display, display lasted 0.2***** secs
gdm[3732] : Warning GDM Display, display lasted 0.2***** secs
gdm[3732] : Warning GDM Display, display lasted 0.2***** secs
gdm[3732] : Warning GDM Display, display lasted 0.2***** secs
gdm[3732] : Warning GDM Total display failure, maximum number of x display failures reached check x server log for errors
Starting Firewall initializing (Phase 2 of 2)
Master Resources Control Runlevel 5 has been skipped services in runlevel 5
Welcome to openSUSe 11.3 “Teal” Kernal 2.6.34-12- desktop (ttyi)
Login

Any thoughts thanks

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

did you install the ATI drivers for openSUSE 11.3?
maybe you upgraded your 11.2 but don’t upgrade the video driver…


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkxYafAACgkQJQ+0ABWtaVnp4ACgucJoImXnYW4Cl5+cLtLm9Cpd
u/wAn2D/PQTE8xAXyqL+RI9GvXVWGi+A
=eowo
-----END PGP SIGNATURE-----

See if you can boot to Yast like this and add the ATI driver repo
Boot to Level 3, then Yast and More…

I also installed 11.3 (on Sony VAIO VPCCW17X) instead of upgrading a working 11.2 and I can’t boot; I get a blank screen but see indicator lights on (power, disk drive,…). I can boot on failsafe though. Any idea how to fix this?

Gee maybe you should tell us the video card, you think??? LOL

And the graphics device you have is…>?

Hi,

I can boot to yast following the instructions but there I can find nowhere to deal with video cards, there is no download for ATI Radeon HD, they should ,but mine is not, be on the list of included drivers.
In 11.2 I used SAX2 create and to add details to the xorg.conf file, xorg.conf does now not exist, xinit tells me that the Radeon HD does not work with nodesetting and must be removed from the kernal
From other forums it seems that SUSE has removed SAX2 from the latest versions as from Nov 2009 and has not replaced it with any system to get your graphical display working once you have got a tty screen.
Other instructions on the web to install an ATI driver all use SAX2 and edit the xorg.conf file.

Until SUSE gets its act together to produce a working xdisplay system, would I be better off, reloading 11.2 as a new installation?
The present tty imput is stoneage 1960’s quality and cannot but drive people away from Linux in droves, when there appears to be no command to sort it out

Thanks

openSUSE Graphic Card Practical Theory Guide for Users

Hi
I have a gigabyte GV-R485-512H-B which is a ATI Radeon HD 4800 series card

SDB:ATI drivers - openSUSE

I see a note about the repo being broken and install needs to be done manually. I don’t know if this is still the case.

Hi,
Thanks for this information, using it I was able to create a xorg.conf, which shows the correct video card and RadeonHD rev770 driver. With a lot of adjustments of changing the RadeonHD driver name, using that terrible editer vi - which ignores its’ own closure command, I got a graphical output at a maximum of 1024x768.

The monitor option has no monitor details and only 3 vga outputs.
When I boot I set the vga to xo376 [which is the maximum before I get an “out of range” message] which works for half the boot, then the SUSE logo increases in size and I am back to VGA on the operational screen.

Is the old sax2 “card and monitor” entry screen hidden anywhere?
Is the xorg.conf file the only method of changing the resolution? which means continually trying random bits of code until it works. I believe I hard coded the framebuffer graphic when I installed 11.2.
My screen savers from Hubble are at 1900x1200 so the Linux system is capable - The linux system is on a swappable hard disc and when I use Windows XP pro SP3 in the same hardware I have no problems in achieving 1900*1200 so there are no problems with hardware.

Many thanks for the info so far we are now on the last half mile so look forward getting 11.3 actually running as well as it can

I think I have helped all I can. I do not have ATI and never have. @oldcpu may be better placed…

My recommendation is you remove your /etc/X11/xorg.conf file that you created, so that you have no such file. Maybe back it up somewhere so you can restore it if need be.

Then reboot, and at the grub boot menu type as a boot option: nomodeset

Does that work ?

You could also try working your way through this guide: SDB:Configuring graphics cards - openSUSE Wiki

I am sorry I have not replied sooner but have been so frustrated by this upgrade, and have spent the last 7 days trying to get the beast to work
I have tried removing the xorg.conf and setting nomodeset as a boot option which by the way does not autocomplete as described in SDB:configuring _graphics_cards but fails all the same with a tty output
I have also spent at least 4 days making various modifications to the device.conf, monitor.conf and screen.con in /X11/xorg.conf.d, none of these worked although in some instances the text became readable so some of the commands worked but a 1600*1200 tty screen but that is not what I was after.
I have tried removing all the alterations but now it will now go to a basic vga screen
I have tried using the installation dvd and upgrading the system to see if it help
I have looked at the log files which stae that there are fatal errors and I have tried setting the YAST file to yes but no luck,
I have tested the driver with glxgears as per SDB Radeon which shows the gears in good resolution but the frame rates shown had no meaning to me
The ATIconfigure file does not exist, I have downloaded and installed the ATI RV770 driver, which is the correct one for my HD4850 card but no ATI commands are there

I have read “Maintaining X configuration impossible with 11.3!” and cannot agree more, if you wish to keep the software for the use of programmers who just need coloured text, fair enough but if you expect people fed up with Windows to come to an alternative system, you need to have a ***foolproof method ***of getting it going. It would not matter so much if the drivers had limits or you did not support exotic items, as long as you knew beforehand. I run a very small software house selling only to very large companies, a bug of any sort is not acceptable or tolerated as a failure would bring that part of the company to a halt. It is not rocket science.

I have seen nothing in the forums other than " where the H!!! is SAX2" it was not good but there were logical methods of getting it to work, I cannor download the SAX2 program until I get a graphical screen as my knowledge is insufficient to download onto my Windows system, where I am typing this and getting it into my SUSE tty system.
It seems that I will have to try and remove 11.3 somehow, without destroying my data and reload 11.2 or another Linux flavour

ANy other ideas

Thanks

installing sax2 is not a magical answer. It has not been maintained and the odds are it won’t work.

But if you want to install it, it is incredibly easy from a terminal IF you have wired internet accesss. Do you have wired internet access from the terminal ? If so then just very carefully type with root permissions:

zyyper ar http://download.opensuse.org/repositories/home:/flacco/openSUSE_11.3/ flaccos-repos

zypper in sax2 sax2-gui
zypper rr flaccos-repos

where we are following a simple zypper command sequence of:

zypper ar URL anyname-I-madeup #ar means add repository
zypper in application1 application2 #in means install
zypper rr anyname-I-madeup #rr means remove repository

or alternatively, with root permissions, simply type ‘yast’ and use the ascii yast to do what is needed to be done to add the repository and install the sax2. I find the zypper commands easier.

Its almost impossible to help given the rambling nature of the post in terms of what you tried. I understand your frustration, but this ramble is not helpful.

For example, I’ve never heard of an ATIconfigure file. You need to show us you are using the correct syntax and the correct syntax is not ATIconfigure. The command I am familiar with is “aticonfig” run with root permissions. This command is ONLY for users whose PC has the proprietary radeon graphic drive installed. For example

aticonfig --initial

(backup any functional /etc/X11/xorg.conf before trying that).

How about posting on Pastebin.com the output (in separate pages) of /var/log/Xorg.0.log and /home/your-user-name/.xsession-errors. And then post here the URL/address provided by pastebin.com so we can see what those logs look like ? (do NOT post the log content here - only post the address).

Its also not possible to tell what level of video graphics you have achieved. In one post it suggests you have seen 1024x768, in another it appears you have only a terminal.

I do not see how a good recommendation can be made with out a simple summary description of the symptoms instead of forcing users to go through over a dozen of posts which in some cases appear to contradict.

My apologies as I appreciate your frustration must be massive, but please try to make the problem description simple, so we can understand this.