No graphical display

I did a zypper dup today from leap 15.2 to Leap 15.3 and now have no graphical display

I have a nVidia card in the computer. I use kde.
I disabled the packman repository but left the nVidia repository enabled.

During the dup process, there were a bunch a problems found, mostly concerning the files used by vlc. I chose to have them changed to the openSUSE repositories however, I was asked to accept a license for the nouveau driver. Once again, I accepted this thinking I can reinstall the nVidia propriority driver once the process was complete.

When I rebooted, I was presented with only a terminal screen. I opened yast2 and uninstalled the nouveau driver and installed xf86-video-nv but still do not have kde showing.

I then went into yast2 and did a refresh on all the nVidia drivers I could find, they said they all came from openSUSE and it said it ran a posttrans script but still no graphical display.

What’d I do wrong?

Review the following guide:

BTW, are you using secure boot?

I don’t think so. I did get the blue MOK screen at first boot. Is that an indication? How can I tell (from the command line)?

This machine does dual boot Windows.


Alright! I looked at the suggested links and lo and behold, Secure Boot is enabled. I distinctly remember setting it to NO during the initial installation of openSUSE. Obviously, during some update or upgrade, it got changed.

Being past my bed time, I don’t trust this old brain to be sharp enough to mess with this right now, Tomorrow, I’ll go through those docs again, and, by golly, I’ll fix this darn thing!

Thanks for the directions. I’ll be sure to post the results.


still no joy.

Using yast2, I disabled secure boot and rebooted. No graphics.

So I tried

# mokutil --disable-validation

and rebooted. The MOK screen came up at reboot but still no graphic display.

NOTE! During the process of changing the repositories, I missed the NVidia repository and it stayed at 15.2 because of the $releasever thing. Obviously, I have some conflicting files in there.

Can I, using yast2, delete the nVidia drivers and install the nouveau driver? And if that works, just reinstall the nvidia driver?


That package just contains the (deprecated) X-server driver, not the kernel driver, and not usually required as the modesetting driver suffices for most.

You should check to see if the nouveau driver is blacklisted (by the proprietary driver installer perhaps). Remove the blacklisting if required.

I won!

I opened yast2
I did a search for nvidia
I did a delete of all the installed files shown in the list
Rebooted and, as I figured, there were no graphics.
I opened yast2
I did a search for nvidia
I selected to install the GO5 driver and a whole list of files were added by yast
After the process completed, I rebooted and my ked screens came up just perfect.

Lesson learned: Don’t allow anyone to distract you when working on the system!

Thanks for the help.


Good result. :slight_smile:

Secure boot is a UEFI/BIOS function turning it off in the OS only tesll the OS not to use it future updates may see it on in BIOS and thus try to use it. Best to turn off in BIOS/UEFI. It is security theater any way since it only protects the boot stack and anyone able to change that already owns your machine :open_mouth: