no fstab folder after cmos reset

I made a goof changing some bios settings and had to reset. BTrfs wont mount my drive do to a now missing fstab folder. Emergency shell doesn’t have a text editor so im hoping i can just enter all the info by hand, just not sure how.

Maybe tell use exactly what you did and exactly the error and exactly what point it fails. What were you trying to change??

the cmos/BIOS/EFI has nothing to do with the fstab and that is a file not a folder

-reset bios. No other changes

OpenSUSE 13.2 boots to emergency shell.

Journal contains failed to load log tree, dependency failed for initrd file system, reload configuration of real root and open_ctree errors.

/etc/fstab does not exist while in emergency shell, so im assuming it is the source of errors.

Think you are assuming wrong.

reset of the BIOS may do odd things. The problem is in the BIOS not in the OS. Is it EFI BIOS or older legacy? More then one drive? Is the boot order right in the BIOS?

If it boots at all (without external disks/drives) then the root should be intact. If root partitions is ok then there should be a /etc directory with an fstab file. DO you have a separate boot partition???

I think that some default BIOS setting is just wrong. Check any setting having to do with drives. Not knowing if EFI or legacy BIOS does not help. They are different

Yes i have 3 partitions. Root is btrfs and home is xfs. I managed to fix root.

I am now getting a superbock error on my xfs partition. Aka home dir.

Xfs utilities are not installed. Tried to zypper them in and im not getting a network connection

Still think you have a wrong drive setting in the BIOS which we still not know if it is EFI or legacy BIOS.

Just resetting the BIOS should not in any way change anything on the drives.But it may make the drives unreadable/usable

You should be able to just do a fsck the partition to fix or at least get more information. A partition must be unmounted to do this. All the basic file systems utilities should be installed by default.

It is running in efi.

Not sure why resetting it did what it did. But running xfs_repair fixed the super block error.

System now runs normally. Thanks for the help.