No free space after fresh install

Hello. I’ve tried doing a fresh install of both 13.2 and Leap and after install I have less than 15 GB of remaining space on a 256 GB disk.

I am not setting Home as its own partition and I am using ext4. Currently it shows I have only 13.7 GB of 20 GB of free space.

In gparted and GNOME disk utility it doesn’t show that my partition is this small and I’ve tried other distros and they allow me my full space.

What could be causing this issue and what information would I need to provide for assistance? Space fills up extremely fast in my /tmp folder and the computer quickly becomes unusable and freezes when this happens.

Post the results of the following so people can see what is happening on your disk

df -h



fdisk -l


cat /etc/fstab

df -h

Filesystem               Size  Used Avail Use% Mounted on
/dev/mapper/system-root   20G  4.9G   14G  27% /
devtmpfs                 7.8G     0  7.8G   0% /dev
tmpfs                    7.9G   80K  7.9G   1% /dev/shm
tmpfs                    7.9G  1.5M  7.9G   1% /run
tmpfs                    7.9G     0  7.9G   0% /sys/fs/cgroup
/dev/sda1                156M  4.8M  152M   4% /boot/efi

fdisk -l

Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt

Device      Start       End   Sectors   Size Type
/dev/sda1    2048    321535    319488   156M EFI System
/dev/sda2  321536 468860927 468539392 223.4G Linux LVM

cat /etc/fstab

/dev/system/swap     swap                 swap       defaults              0 0
/dev/system/root     /                    ext4       acl,user_xattr        1 1
UUID=      /boot/efi            vfat       umask=0002,utf8=true  0 0

openSUSE will default to a /home in addition to /
If you change that then you would need to alter the size of /
obviously you didn’t

If you are going to edit the defaults, you ought at least know how to do so
If you don’t, then perhaps it’s better to leave well alone and go with the default recommendation?

Having /home separate is a good idea IMO

Other Linux OS’s don’t go that route, and where I have used them I alter their default of just /
To / and /home

You are the master of what happens
What you have is what you set up

I wasn’t clicking random options.

I wanted set up to be similar to the Windows C:\ drive with everything all in the same partition, so I unchecked the option to make Home its own partition.

As for why I used ext4, it’s because I read it was better for SSDs.

If I wanted both the system and Home to be on the same partition did I not do the correct thing? I still don’t understand why I have so little usable space if it’s supposed to be all on the same partition.

un-Select the option to create separate home then
Use the option
Create Partition setup
then the Custom partitioning for experts
And point the install to your pre-created partition xxxGB

And you used LVM. Why? I do not see any reason, so please explain.

My conclusion so far (but I do not have any information about the LVs you created), you created a PV of the rest of the disk (that is witthout EFI partition) and within that PV you created a LV for Swap and a LV of 20 GB which now has the complete system because you did not create a separate /home.

Your argument about doing things like in Windows is of course, …well, I do not know how to say this polite …

Linux is not Windows and Windows is not Linux.

Better re-install and let the installer propose something nice (which will be something like partitions for /boot/efi, swap, / and the rest for /home. Either simply accept that (why not?) or come here for advice. And you can use ext4 when you like that.