No Flash Sound on openSUSE 11.2 (KDE 4.4)

I just lost flash sound on my openSUSE 11.2 x86_64 desktop. I’m using the built-in HDA Intel audio, and I have sound in all other appliations (Amarok, mplayer, Minitube, ect) but not in Flash (I’ve tried Firefox and rekonq; no dice). I’ve never had issue with Flash sound before (hough I know many have) and I can’t seem to find anything recent or relevant to my issue (most of the problems reference pulseaudio, which I, thankfully, do not have, or are for older versions of Flash).

I’d like to know where to start looking for this issue; it came up fairly recently (I don’t use Flash all that often so I can’t say when) and I have made no concious upgrades or changes that would affect it (though I do zypper dup pretty regularly). I updated to KDE 4.4 but I had Flash sound afterwards; I also tried downgrading the Flash player to 10.42 (instead of .45), but that didn’t help. This issue is global (to all users on the system), so I don’t think it’s messed up configuration at the user level.

I should also mention that I followed Red Dwarf’s “Checking you Multimedia Problem…” guide to verify that I have the correct software installed; as far as I can tell I’m in good shape.

# rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*vlc*' | grep -v avahi | sort
cuberok-gstreamer-0.0.11-1.57.x86_64                                                                                                 
dragonplayer-4.4.0-2.5.x86_64                                                                                                        
flash-player-10.0.42.34-0.1.1.i586
gstreamer-0_10-0.10.26-999.pm.1005.1.x86_64
gstreamer-0_10-ffmpeg-0.10.9-999.pm.999.4.x86_64
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.42.3.x86_64
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.42.2.x86_64
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.42.2.x86_64
gstreamer-0_10-lang-0.10.26-999.pm.1005.1.noarch
gstreamer-0_10-libnice-0.0.10-0.pm.1.3.x86_64
gstreamer-0_10-plugins-bad-0.10.17-999.pm.1000.18.x86_64
gstreamer-0_10-plugins-bad-lang-0.10.17-999.pm.1000.18.noarch
gstreamer-0_10-plugins-base-0.10.26-999.pm.1001.2.x86_64
gstreamer-0_10-plugins-base-lang-0.10.26-999.pm.1001.2.noarch
gstreamer-0_10-plugins-good-0.10.18-999.pm.999.8.x86_64
gstreamer-0_10-plugins-good-extra-0.10.18-999.pm.999.8.x86_64
gstreamer-0_10-plugins-good-lang-0.10.18-999.pm.999.8.noarch
gstreamer-0_10-plugins-ugly-0.10.13-999.pm.1000.8.x86_64
gstreamer-0_10-plugins-ugly-lang-0.10.13-999.pm.1000.8.noarch
kdebase4-runtime-xine-4.4.0-190.1.x86_64
libavc1394-0-0.5.3-134.2.x86_64
libavcodec52-0.5.21861svn-0.pm.1.4.x86_64
libavformat52-0.5.21861svn-0.pm.1.4.x86_64
libavutil50-0.5.21861svn-0.pm.1.4.x86_64
libgstapp-0_10-0-0.10.26-999.pm.1001.2.x86_64
libgstbasevideo-0_10-0-0.10.17-999.pm.1000.18.x86_64
libgstinterfaces-0_10-0-0.10.26-999.pm.1001.2.x86_64
libgstphotography-0_10-0-0.10.17-999.pm.1000.18.x86_64
libgstreamer-0_10-0-0.10.26-999.pm.1005.1.x86_64
libgstreamer-0_10-0-32bit-0.10.26-999.pm.1005.1.x86_64
libgstsignalprocessor-0_10-0-0.10.17-999.pm.1000.18.x86_64
libpostproc51-0.5.21861svn-0.pm.1.4.x86_64
libswscale0-0.5.21861svn-0.pm.1.4.x86_64
libxine1-1.1.17-1.pm.31.5.x86_64
libxine1-codecs-1.1.17-1.pm.31.5.x86_64
libxine1-gnome-vfs-1.1.17-1.pm.31.5.x86_64
phonon-backend-gstreamer-0_10-4.3.80-6.1.x86_64
phonon-backend-xine-4.3.80-6.1.x86_64
plasmoid-xineramoid-0.3-2.32.x86_64
pullin-flash-player-11.2.1-0.1.1.x86_64
xinetd-2.3.14-143.2.x86_64

PCM Volume can change dynamically, so ensure your PCM volume is UP in your mixer when you start a flash video.

Did you try playing a flash video on your hard drive (as opposed to playing one in your browser) to see if this is media specific as opposed to browser plugin specific?

If browser specific, you could check Configure Desktop > Multimedia and ensure the appropriate sound card is first in the list under Audio Output > Music and also under Video.

I assume you are using the xine backend ? (that is what I use).

Thanks, oldcpu. I think I’ve already checked all those areas - except for the local flash file. My Intel HDA is listed first in all the ‘Configure Multimedia’ catagories (I do have multiple sound cards, so I was aware of that possiblility), PCM is at max, and I am using the XIne backend.

I wan’t so sure about the local Flash file thing. I don’t have any Flash videos locally, so (after much Googling) I discovered youtube-dl and got one on my hdd. However, I edon’t know how to get it to play. Kaffeine (the default player for local Flash) plays the video without sound (otherwise in good quality), but the “Flash Player” entry in the menu won’t play it (it just does nothing - no video or sound).

I tried fumbling with the commandline cmds “nspluginplayer” and “nspluginviewer” but neither would launch the downloaded video. So I don’t know if Flash videos (with sound) play locally; unless of course Kaffeine is using the Flash plugin - in which case I guess the answer is no.

Note also when testing, you should ensure you have no other multi-media application running at the same time, to ensure no other application is running and refusing to share the audio device.

Still no sound in Flash, but I found this tidbit:

ALSA lib confmisc.c:392(snd_func_concat) error evaluating strings
ALSA lib conf.c:4154(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251(snd_func_refer) error evaluating name
ALSA lib conf.c:4154(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4633(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib pcm_hw.c:1433(_snd_pcm_hw_open) Invalid value for card
ALSA lib confmisc.c:768(parse_card) cannot find card ‘0’

This is the console output while watching a Flash video (YouTube) in a browser (rekonq).

Interesting, isn’t it? That seems to be related to the problem (again, all other sound apps are working normally). I’m going to look a the Yast2 Sound module.

Fixed it! Turns out that the Yast2 Sound module’s ordering of the sound cards didn’t match the line up I had set up in systemsettings (I hope the overlap between KDE/GNOME system configs and Yast gets resolved in a future openSUSE release). Straightened them out and sound works perfectly! Thanks, oldcpu.

Congratulations on sorting this, and thankyou for sharing your solution.

I have the same problem but i didnt get your solution cause i am a beginner,will u plz explain more about your solution?