No Flash in Google Chrome

Hello, I Downloaded Chrome version and upon starting it I see that I have no flash alright so I Create a plugin directory for chrome and copy the into that directory and issue the following command in the applications command line /opt/google/chrome/google-chrome --enable-plugins %U hit ok and restart the browser and still no flash…I’ve even tried this solution Getting Flash to work on Google Chrome for 64-bit Linux | K-Squared Ramblings but to no avail. So has anyone figured this one out yet? Thanks

Just creating a symbolic link to /usr/lib/browser-plugins/ in /opt/google/chrome/plugins did the trick for me.

I just did that and still no flash…wonder what this could be,by all means this should work but for some reason isn’t

I suggest you grab the version from the Contrib repository;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 8 days 9:33, 2 users, load average: 0.02, 0.03, 0.06
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Yes I have tried chromium and I’ve had an odd experience with it too…upon going to youtube and clicking on a video I can hear sound but just a blank space where the video should be…now if I choose to open the video in a separate window flash works fine…this is all very odd.

I have Google Chrome from the repositories installed.
I created the symlink for Flashplayer with ln -s /usr/lib/browser-plugins/ plugins as Root from /opt/google/chrome/ . I still get “Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.” when I go to youtube and try and watch video.

The latest Flash is installed and works perfectly under FireFox 3.6
What is missing or why is Chromj such **** which ever applies.


Probably because the Contrib version of chromium is
in /usr/lib{64}/chromium and not /opt/google/chrome these days?

ls /usr/lib64/chromium/plugins

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 13:58, 3 users, load average: 0.17, 0.16, 0.06
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Which it just a softlink to;

ls -la /usr/lib64/chromium/plugins
lrwxrwxrwx 1 root root 18 2010-01-22 10:56 /usr/lib64/chromium/plugins
-> ../browser-plugins

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 14:00, 3 users, load average: 0.14, 0.16, 0.08
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Weird. I just updated to the latest beta version of Chrome and get
flamebait@linux-v5xu:~> ls /usr/lib64/chromium/plugins
ls: cannot access /usr/lib64/chromium/plugins: No such file or directory

No joy. I am running openSUSE 11.1 64 and KDE 3.5 if this makes a difference.

Never mind I uninstalled Google Chrome.

Mozilla FireFox 3.6 worked out of box and excepting the KDE 4 file chooser it uses it works fine on my Desktop without and CLI interventions to get it to do what is dirt basic web browsing in 2010.

It’s a softlink to /usr/lib64/browser-plugins.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 14:24, 3 users, load average: 0.01, 0.03, 0.05
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Wait No, I would still like to some help on this as Chrome is my browser of choice and it’s a pain in the ass to have to open firefox to watch videos…Now with the knowledge that’s been given what else would you guys suggest trying? (also don’t know if I mentioned it before but I’m running 64bit chrome)

I copied over the java and flash plugins from their respective folders.

Java can be found in /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/

Then I got the 64-bit version of flash from adobe’s site here:
Adobe Labs - Downloads: Flash Player 10.1
The link is down at the bottom and it’s a tar.gz

Use ark for KDE or gnome’s equivalent to extract the flash plugin then using a super user file manager like dolphin, create a plugins folder in /opt/google/chrome then place the plugin into /opt/google/chrome/plugins

Just got it to work for me.

Take Care,


Thanks…almost there except there is no “” file and don’t know if this makes a difference but my path differs a bit from yours /usr/lib64/jvm/java-1.6.0-openjdk-1.6.0/jre/lib/amd64

also I have downloaded and installed the one off of sun’s site and I still don’t see the file in question.

ah nevermind found the file in question was in my downloads folder…oops but anyway did what you told me and Chrome recognizes the java plugin but still fails to recognize the flash plugin…what gives? this is really starting to get rediculous.

Right, if you hadn’t installed Sun’s java then your firefox will tell you that you have Ice Tea instead of Sun’s Java. So I installed java from Yast and the original file in /usr/lib64/browser-plugins was linked to an /etc/alternatives/javaplugin which in turn was linked to that final file I told you. But as long as it works!

As for flash, I also placed the 64-bit version in /usr/lib64/browser-plugins (after deleting flash from Yast) to make sure that it actually worked. After I established it worked in Firefox, I copied it straight from the /usr/lib64/browser-plugins folder over to Google Chrome’s /opt/google/chrome/plugins folder. Then, open chrome and type


And check to see if it recognizes it. It will be down at the bottom.

Take Care,


Thanks I’ll give it a try.

Copying files to /opt/google/chrome/plugins/ is not a good idea, because such copies will not get updated by the openSUSE software management. Think about a flashplayer update fixing critical vulnerabilities for instance.

What works however on openSUSE 11.2 x86-64 is symlinking the entire /usr/lib64/browser-plugins directory. Assuming /opt/google/chrome/plugins/ does not yet exist:

ln -s /usr/lib64/browser-plugins/ /opt/google/chrome/plugins

After doing that on my system, the official 32bit flashplayer package works together nicely with nspluginwrapper and Chrome 64bit. So nicely in fact that I don’t see any reason why I should throw an unsupported 64bit alpha flashplayer into the mix…

Well I guess I didn’t read everything correctly. What the rest of the thread is talking about is chromium and not chrome. I thought that symlinking to /usr/lib64/browser-plugins had already been suggested by malcomlewis so I provided an alternative that is currently working for me.

Symlinking is definitely the better way for 32 bit flash since there’s an implementation for that with nspluginwrapper, but there’s no 64 bit flash in YAST so I provided the way to use the 64 bit version of flash since, at the moment, I thought the user was saying the 32 bit version wasn’t working for them.

THAT is why I would throw an alpha flashplayer (which happens to work by the way) in the mix.

Take Care,