No Firefox Plugins in SUSE 11.0

I’ve just upgraded to SUSE 11.0 from 10.3. Firefox 3.0 is showing no plugins and yet browser plugins are present in usr/lib64/browser-plugins.

Is Firefox supposed to look in this directory automatically, or do I have to do something?


You shouldn’t have a problem. Assume by upgrade you mean a install of OS11 and keeping /home, otherwise a new install to /

And FF is installed from the install dvd?

in your ff location bar:


gives what?

Very mysterious. The first time I ran about:plugins, it came back with “no plugins”. I closed firefox, restarted it and tried again to confirm the exact response, and now all the plugins appear.

Fingers crossed that it stays that way!

Thanks for your response. You solved my problem, albeit indirectly! When I started Firefox from my thread reply email notification, I had plugins. When I started it from my panel shortcut, I didn’t.

A quick bit of investigation showed that my shortcut was set to /usr/lib64/firefox/firefox whereas the preferred application setting was “firefox %s”.

I’ve now changed by panel shortcut to just “firefox” and I have plugins.

Thanks again!