No external device automounts since 11.4 upgrade.

Back when I used 11.3, everything was great. Everything worked, and I was happy. As time passed, installing new software became a pain as dependency issues arose. I finally decided, hey, lets upgrade to 11.4. That’ll make everything better.


The upgrade broke everything. At least, it broke everything that I used. I finally got most of the problems fixed, but I can’t figure out how to mount external devices. CDs, USB drives, CF cards, SD cards, none of it works. Everything was 100% before, so I know all of the hardware is good (I use a multi-purpose media device reader that fits in my floppy drive slot. Plugs into the motherboard via USB pins, worked great). I’ve finally come to a point where I absolutely need to mount a CF card. I haven’t touched my IPod in months, but I’ve squeezed by without that. The reality is that I’ll end up switching distributions soon, just because this last update was such an absolute nightmare, so I’m not looking for a permanent fix. You know, unless it’s easy for my feeble-minded brain to comprehend/execute.

tl;dr: I need to manually mount a CF card. What do?

What I would do is test a new user login. See if it’s a problem in /home or deeper. If the new user works, it might be easier to solve than you think. If it doesn’t, then I suspect the ‘Upgrade’ to the system (which you didn’t explain)
Upgrade seems to be used to refer to different things, so perhaps you can explain what you mean/did

The upgrade involved me booting up the 11.4 install DVD, and using the ‘upgrade’ option. I did the same thing that I did upgrading from 11.1 to 11.3, which worked absolutely fantastic. I was really impressed with how smooth that went, so I figured I’d try that again.

I’ll make a new user and see if that works. I think logging in as root works, but I never really considered that a viable option. Despite my lack of linux knowledge/vocabulary, I’m quite paranoid about security. It’s one of the reasons I’ve stuck with OpenSUSE.

I’m quite paranoid about security
Then you’ll not be doing any logging in as root!

Keep us informed about the results with a new user.

So was this same install once 11.1?

Well, here’s what I did. I just wanted to get it done, so I went ahead and logged in as root. Everything mounted properly automatically, and even old Amarok worked (I never did get it to work after the upgrade. Switched to Clementine). I copied the contents to my regular user’s home folder, gave permissions, etc.

For the sake of the hunt, I did make a new user through Yast, using default new-user settings. It did concern me that the only groups were video and users, and when I switched, lo and behold, no automount.

When struggling to configure my sound after the tragedy, I found out that simply being in the wrong group at the wrong time means death, so I never put myself in a group unless I knew it would solve a problem. Perhaps the issue is that I’m not in the right group to automount?

Groups I’m in right now: audio,dialout,video,pulse-access,disk,cdrom,users,pulse.

Also, after mounting the card while in root, I kept the card in, logged out of root and logged back into my regular user, and the card was still mounted. I rebooted to get rid of this legacy for my test of the new user, and the card was STILL mounted. I removed it, thus unmounting it, and put it back in. No automount. Went ahead and tested the new user.

Edit: Yes, this is still that same version that was once 11.1. Never fully reformatted. All of my stuff is so unorganized and poorly managed that I’m totally uncomfortable with the idea of losing my /home folder to a reformat.

Edit 2: I want to apologize if my first post came off as whiny or bashing. It happened at a particularly bad time for me, and I still get a little frustrated when I think about it. I know it’s free software and I can’t really complain.

Your problem sounds deeply rooted

I seem to be in only video
I have not changed it from default

On 08/27/2011 05:56 AM, Waldo II wrote:
> The upgrade involved me booting up the 11.4 install DVD, and using the
> ‘upgrade’ option. I did the same thing that I did upgrading from 11.1 to
> 11.3, which worked absolutely fantastic. I was really impressed with how
> smooth that went, so I figured I’d try that again.

recommended and supported methods of performing administrative tasks
(such as upgrading) change over time and to assume otherwise is not
always the best course of action…

you mention that since your 11.4 upgrade was so disastrous you may
switch distros…which of course you should do if you think that is your
best course…

imo, changing to a different distro would be best done with a complete
fresh format and install…and then migrate old data (saved to a safe
location) to the new system…

it would be my guess is if you backup your data to off machine media
in prep for such a distro switch, but then did a clean format and
install of openSUSE 11.4 you would find that everything now broken would
suddenly work again as expected (at least, my clean format install of
11.4 is sweet, very sweet)…

either way (new 11.4 or new something else), when you want to move to a
later version i’d highly recommend you follow the then current upgrade
path of your chosen distro and not what was an impressive method some
years ago (Linux is moving FAST, what was known wonderful administrative
actions in 11.1 either won’t work or might damage 11.4)…

currently there are two openSUSE community supported ways to ‘upgrade’
to 11.4, unfortunately you used neither and your system is now in some
kind of intermediate state of mixed up software and configs giving you
all sorts of strange symptoms…you can avoid those next time you
upgrade to 11.4 by following the recommended paths:

and, by the way the 11.1 to 11.3 upgrade you did wasn’t supported at the
time…only 11.2 to 11.3 was supported, you were lucky then, but not so
lucky to 11.4, which is unfortunate–but it happens often, reading
around in these fora you will find lots of sad tales about “upgrade to
11.4” problems…none of which, if my memory serves correctly can be
attributed to problems encountered by exactly following either of the
supported upgrade paths!!

DD Caveat
openSUSE®, the “German Engineered Automobile” of operating systems!