No /etc/init.d/boot script found in SLES11 rescue image

Hi, All

Currently I run into a rather confusing case.
I met bellow mount errors when I was about to enter the rescue mode on SLES11:

Loading Rescue System (1/2) (19784 kB) - 100%
Loading Rescue System (2/2) (10268 kB) - 100%
Reading Driver Update...

Driver Update ok

INIT: version 2.86 booting
System Boot Control: Running /etc/init.d/boot
Mounting procfs at /proc                                              done
Mounting sysfs at /sys                                                done
Mounting debugfs at /sys/kernel/debug                                 done
Remounting tmpfs at /devmount: can't find /dev in /etc/fstab or /etc/mtab
Initializing /devcp: cannot remove `/dev/console': Read-only file system

Then I tried to extract the rescue image and to see what’s wrong in the scrip, but it turn out that there is no boot script under /etc/init.d directory, either a similar one that may as it.

Could someone point to me that where is the script or which is the script does the mount things in rescue image?

PLUS, I can see /etc/init.d/boot script in SLES10 rescue image.

Any help will be great appreciated!


You are running SLES, these forums support the community linux version, i.e. openSUSE. You’ll find links to Novell’s support forums on the home page of the forums.

Good luck

OK, thanks.