No easy way to set up a network

Hi. I’ve just installed Tumbleweed (with KDE) on my laptop. However, I’m encountering an issue. Rather than finding anywhere a list of networks available, when I try to open configurations for network, this appears:
https://i.imgur.com/zJUG0l7.png

After clicking the ‘plus’ button, and choosing ‘wifi’, I am prompted with this:
https://i.imgur.com/UcHjFHc.png

Now. I’m not sure if this is how it’s supposed to go, but I’m not sure how to set a network up that way, and would it be possible for someone to link to a tutorial?

I’ve tried a few things, including changing settings in YaST (something about Network Manager, which was already selected anyway) and nmtui (clicking on ‘Activate connection’ gives an empty box). Am I missing something here?

As a further note, when I connect it to my phone and enable tethering through the cable, the internet works fine. It automatically connects.

What about the Hardware ?
Please post:

/sbin/lspci -nnk | grep -iA3 net

and

rfkill list all

Please use Code-Tags.

Please verify,
Open YaST > System > Network Settings > Global tab (far left)
That Network Manager is selected, else as you describe nothing will be working.

Then, although the simple act of affirming the selection and closing YaST should restart your network services to activate your selection, you can still run the following to be doubly certain it’s done

systemctl restart network
~> /sbin/lspci -nnk | grep -iA3 net
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
        DeviceName: Hanksville Gbe Lan Connection
        Subsystem: Hewlett-Packard Company Device [103c:84ae]
        Kernel driver in use: r8169
--
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
        DeviceName: WLAN
        Subsystem: Hewlett-Packard Company Device [103c:831a]
04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd] (rev c4)
~> sudo rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

And yes, NetworkManager was selected:
https://i.imgur.com/0it31CZ.png

systemctl restart network

did not seem to work.

Please post the results of the following command

systemctl status NetworkManager

TSU

The output you’ve posted re Sauerland’s request shows that there is no wifi driver for your wireless hardware, and from your opening post I assume that it is wifi connectivity that you’re after.

Hi
As can be seen from the lspci output you have no driver present for that wireless card…

You need to grab the kmp from user Sauerland’s Tumbleweed build at Welcome - openSUSE Build Service

Can you plug in an ethernet cable and update your system to ensure your on the 4.19.2 kernel, or your already there?

Grab the kmp and install with zypper manually…


wget https://download.opensuse.org/repositories/home:/Sauerland:/branches:/home:/Sauerland/openSUSE_Tumbleweed_standard/x86_64/rtl8821ce-kmp-default-git20180902_k4.19.2_1-28.5.x86_64.rpm
zypper in rtl8821ce-kmp-default-git20180902_k4.19.2_1-28.5.x86_64.rpm

Thanks to user Sauerland, we have openSUSE packages required to gain that wifi support for your hardware…

https://software.opensuse.org/search?utf8=✓&q=rtl8821ce

You’ll need to use wired ethernet connectivity to install these (subscribe to the repo), or failing that you can just download the appropriate ‘rtl8821ce’ and ‘rtl8821ce-kmp-default’ packages via another machine perhaps, save them to a memory stick, and install the required packages with the package manager.

Yes, that worked! Thank you.

I turned my phone’s USB tethering (which is how I posted the screenshots. I lowkey messed up the Windows boot files, but shh. That’s a problem for another day.), used those commands and restarted my laptop, it then worked.

On that note, since I like to learn and would prefer to be self-reliant, could I ask which part of the output earlier showed that there was no driver and such? I’m semi-familiar with Linux, but I’m still kind of a beginner.

Hi
Glad you got it sorted. The lspci output, no third line showing the kernel module in use, if that’s missing == hardware no go :wink:

So for your ethernet card that line is present, not so for the wireless output…

Now, please note until that driver appears in the kernel, you need to grab the kmp file for the new kernel from the same link (will be a different kernel number/build). You should get by for at least one kernel update (it moves the driver over to weak-updates) before it may not work until you update.

I will? ****. This isn’t exactly a laptop I bought last week either, so I’m guessing it might take a while to have the driver by default? I’ll look if there’s a way to make a script so that is done automatically when I update.

TIL the automatic swear censorship in these forums are very strict. Lol

Hi
Well you can add the repo, but sometimes it takes time for the changes to the Tumbleweed kernel to get rebuilt on users home repositories;


zypper ar -g -f -n "openSUSE-Sauerland-kmp" https://download.opensuse.org/repositories/home:/Sauerland:/branches:/home:/Sauerland/openSUSE_Tumbleweed_standard/ repo-sauerland-kmp
zypper ref
<accept the key always>

Next time the kernel updates, when you do a zypper dup, as long as it’s built the updated kmp will be installed…

Hi
Yes they are :wink:

Okay. Thank you!

Added repo: zypper ar -f http://download.opensuse.org/rep ofositories/home:/Sauerland/Kernel_stable_standard/home:Sauerland.repo
Removed and installed again regardless of non matching version numbers: zypper in rtl8821ce-kmp-default Success! :wink: