No display output after kvm switch, hdmi

So I have installed tumbleweed with kde, but when I switch away from it with the kvm for some time then go back the display won’t turn on. Seems to be ok if I leave for awhile and come back without switching the kvm. I went in settings and unchecked the one where it shuts off the display after 10 mins. Any other ideas?

I’ve had another problem as well, I was in kde and it just up and rebooted once while I was on there. I’m well aware that hdmi won’t output video if it is not hooked up when it boots so it could possibly be this as well (if it rebooted while I was away), but I can’t be sure unless I mess around and ssh in and track the uptime and so on. Also, I could have swore it rebooted once right in the middle of startup while it was loading the kernel. It boots so fast though hard to tell what it’s doing.

I would almost suspect hardware for this kind of outrageous behavior but then this thing has been built and running another linux for months without much issue, not as a daily driver though. Maybe its a newer kernel thing? Other linux was running a 5.4-ish one.

I may just try switch to xfce if there’s a way with zypper and one would be so kind to point me in that direction.

Oh, some perhaps irrelevant background: I’ve only tried opensuse for the first time the last couple days. First time I’ve touched an rpm based one in about twenty years or so. I used to compile everything and keep up with the newest years ago but then it just got so time consuming…

There’s a similar very recent thread here somewhere for amdgpu solved by adding amdgpu.dc=0 to the kernel command line in Grub.

Hmm I can’t find the thread, and I’ve answered so many random questions they are starting to repeat. There is about forty pages about dual displays and no graphics output if monitor is off though.

This might just be sddm stuff. I think I’ve worked around this for now… added xfce and switched the display manager to lightdm and now it’s always up when I switch back (and also doesn’t lock the screen at all). I’m not entirely sure how kde was locking the screen anyway if xscreensaver isn’t running. Is sddm doing it itself? I never could get sddm to play nice with anything. I think the alternatives may be broken too because after I used YaST to set the displaymanager to lightdm and the desktop back to plasma5 and it still starts xfce instead.

I pretty much only wanted to test kde because I’m gettting a convertible laptop/touchscreen to give my shoulder a break and kde is supposed to have support for those.

2 days ago:

Just though I’d say that it’s not the alternative sysconfig in YaST or anything that was still starting xfce. I had forgotten about the tiny tiny icon top right for choosing the session in lightdm.

In other news, the laptop arrived so I went ahead and unboxed it and installed tumbleweed on it if only because I still had the install media on the usb ssd. Was pleasantly surprised that it installed fine after my experience with the first two. Third time and all I guess. I installed xfce first this time then added kde. Unfortunately it seems that kde is not so good with a touchscreen either… there’s no cursor like on xfce but everything is still too tiny.

Maybe theres a good kde theme or something for touchscreens? Maybe kde can manage to install a theme without crashing the whole settings window if there’s no sddm installed? Who knows? Anyway I’ll probably work on it for a week or so and if I’m not satisfied it’ll have to go back I guess. That’d kinda be a shame though, as it’s way nicer than I expected for an HP Envy.

Ah thanks for the link, now I know for sure that was not my problem though. Gosh I haven’t done modelines in years… used to have a multiseat setup with a monitor/keyboard in one room and tv/keyboard in another room with different desktops but just all on one computer… what a pita that was to set up :slight_smile: